Project

General

Profile

Bug #17766

Freenas freezes few times a week

Added by Tobias Andersson almost 4 years ago. Updated about 3 years ago.

Status:
Closed: User Config Issue
Priority:
No priority
Assignee:
Josh Paetzel
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Freenas is working wonderfully. Except it freezes a few times a week. Cannot log into it. Needs to do a hard reboot. I do not see a pattern in time.

var/log/messages says this:

Sep 26 00:00:00 freenas newsyslog21712: logfile turned over due to size>100K
Sep 26 00:00:00 freenas syslog-ng1392: Configuration reload request received, reloading configuration;
Sep 26 03:01:11 freenas find_alias_for_smtplib.py: [common.system:288] Failed to send email: Connection unexpectedly closed
Traceback (most recent call last):
File "/usr/local/www/freenasUI/common/system.py", line 270, in send_mail
server = _get_smtp_server(timeout, local_hostname=local_hostname)
File "/usr/local/www/freenasUI/common/system.py", line 201, in _get_smtp_server
local_hostname=local_hostname)
File "/usr/local/lib/python2.7/smtplib.py", line 256, in init
(code, msg) = self.connect(host, port)
File "/usr/local/lib/python2.7/smtplib.py", line 317, in connect
(code, msg) = self.getreply()
File "/usr/local/lib/python2.7/smtplib.py", line 368, in getreply
raise SMTPServerDisconnected("Connection unexpectedly closed")
SMTPServerDisconnected: Connection unexpectedly closed
Sep 26 04:06:13 freenas re0: watchdog timeout
Sep 26 04:06:13 freenas kernel: re0: link state changed to DOWN
Sep 26 04:06:13 freenas kernel: re0: link state changed to DOWN
Sep 26 04:06:17 freenas devd: Executing '/etc/rc.d/dhclient quietstart re0'
Sep 26 04:06:17 freenas kernel: re0: link state changed to UP
Sep 26 04:06:17 freenas kernel: re0: link state changed to UP
Sep 26 04:06:22 freenas re0: watchdog timeout

and then repeats those link state messages for hours.
Until, I think, I hit the power button:

Sep 26 07:39:05 freenas GEOM_ELI: Device ada5p1.eli destroyed.
Sep 26 07:39:05 freenas GEOM_ELI: Detached ada5p1.eli on last close.
Sep 26 07:39:05 freenas GEOM_ELI: Device ada0p1.eli destroyed.
Sep 26 07:39:05 freenas GEOM_ELI: Detached ada0p1.eli on last close.
Sep 26 07:39:06 freenas GEOM_ELI: Device ada2p1.eli destroyed.
Sep 26 07:39:06 freenas GEOM_ELI: Detached ada2p1.eli on last close.
Sep 26 07:39:06 freenas GEOM_ELI: Device ada3p1.eli destroyed.
Sep 26 07:39:06 freenas GEOM_ELI: Detached ada3p1.eli on last close.
Sep 26 07:39:06 freenas GEOM_ELI: Device ada4p1.eli destroyed.
Sep 26 07:39:06 freenas GEOM_ELI: Detached ada4p1.eli on last close.
Sep 26 07:39:06 freenas devd: notify_clients: send() failed; dropping unresponsive client
Sep 26 07:39:06 freenas devd: Executing '/etc/rc.d/dhclient quietstart re0'
Sep 26 07:39:06 freenas kernel: re0: link state changed to UP
Sep 26 07:39:06 freenas kernel: re0: link state changed to UP
Sep 26 07:39:06 freenas kernel: epair0a: link state changed to DOWN
Sep 26 07:39:06 freenas kernel: epair0a: link state changed to DOWN
Sep 26 07:39:06 freenas kernel: epair0b: link state changed to DOWN
Sep 26 07:39:06 freenas kernel: epair0b: link state changed to DOWN
Sep 26 07:39:08 freenas kernel: ifa_del_loopback_route: deletion failed: 48
Sep 26 07:39:08 freenas Freed UMA keg (udp_inpcb) was not empty (180 items). Lost 18 pages of memory.
Sep 26 07:39:08 freenas Freed UMA keg (udpcb) was not empty (1670 items). Lost 10 pages of memory.
Sep 26 07:39:08 freenas Freed UMA keg (tcptw) was not empty (135 items). Lost 3 pages of memory.
Sep 26 07:39:08 freenas Freed UMA keg (tcp_inpcb) was not empty (180 items). Lost 18 pages of memory.
Sep 26 07:39:08 freenas Freed UMA keg (tcpcb) was not empty (63 items). Lost 21 pages of memory.
Sep 26 07:39:08 freenas Freed UMA keg (ripcb) was not empty (60 items). Lost 6 pages of memory.

History

#1 Updated by Tobias Andersson almost 4 years ago

  • File debug-freenas-20160926093504.txz added

#2 Updated by Bonnie Follweiler almost 4 years ago

  • Assignee set to Erin Clark

#3 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 4 years ago

  • Category changed from 144 to 137
  • Assignee changed from Erin Clark to Josh Paetzel

#4 Updated by Josh Paetzel almost 4 years ago

  • Status changed from Unscreened to Screened

Your realtek NIC is going out to lunch.

You could try replacing the ethernet cable or using a different switch port. If that doesn't solve the issue replacing the NIC is the next step.

#5 Updated by Tobias Andersson almost 4 years ago

Josh Paetzel wrote:

Your realtek NIC is going out to lunch.

You could try replacing the ethernet cable or using a different switch port. If that doesn't solve the issue replacing the NIC is the next step.

Will try a different nic. thanks!

#6 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 4 years ago

  • Status changed from Screened to Closed: User Config Issue
  • Target version set to N/A

#7 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Seen in changed from Unspecified to N/A

#8 Updated by Dru Lavigne about 3 years ago

  • File deleted (debug-freenas-20160926093504.txz)

#9 Updated by Dru Lavigne about 3 years ago

  • Private changed from Yes to No

Also available in: Atom PDF