Project

General

Profile

Bug #17770

FreeNAS does not Alert for disk errors.

Added by Johan Vogel almost 4 years ago. Updated about 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

My server does not give a Alert when a harddisk has gone bad.
Before on my other machine i gotten a Alert when bad sectors where found but now nothing.
Alerts do work, i get them for firmware and storage %.

As attachment a recent smart report which shows that ada1 has problems which should have triggered the alert button.

Thank you kindly for any help.

History

#1 Updated by Johan Vogel almost 4 years ago

  • File debug-freenas-2-20160926180636.txz added

#2 Updated by Johan Vogel almost 4 years ago

  • File SMART_output.txt added

#3 Updated by Heather Ownby almost 4 years ago

  • Assignee set to William Grzybowski

#4 Updated by William Grzybowski almost 4 years ago

  • Status changed from Unscreened to 15

I honestly see no problem here.

smartd has found no new errors on the drives based on the reports you attached, it neither tried to send anything new.

Yes, I can see reallocated sectors, but nothing smart has found to be actionable as new error.

Can you please explain further on what you think is wrong?

#5 Updated by William Grzybowski almost 4 years ago

  • Seen in changed from Unspecified to 9.10.1

#6 Updated by Johan Vogel almost 4 years ago

Then i am afraid i remember wrong.
I thought that on a previous version of FreeNAS the Reallocated Sector Count where also a reason to trigger a alert.

My bad then, sorry.

#7 Updated by Vaibhav Chauhan almost 4 years ago

  • Target version set to 9.10.1-U3

#8 Updated by William Grzybowski almost 4 years ago

  • Status changed from 15 to Closed: Cannot reproduce

#9 Updated by Dru Lavigne about 3 years ago

  • File deleted (debug-freenas-2-20160926180636.txz)

#10 Updated by Dru Lavigne about 3 years ago

  • File deleted (SMART_output.txt)

#11 Updated by Dru Lavigne about 3 years ago

  • Target version changed from 9.10.1-U3 to N/A
  • Private changed from Yes to No

Also available in: Atom PDF