Project

General

Profile

Bug #17789

Bug from latest updates for 9.10.1 on 09/27/2016

Added by Rudi Pittman about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Critical
Assignee:
William Grzybowski
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Running migrations for api:
- Nothing to migrate.
- Loading initial data for api.
Installed 0 object(s) from 0 fixture(s)
Running migrations for freeadmin:
- Nothing to migrate.
- Loading initial data for freeadmin.
Installed 0 object(s) from 0 fixture(s)
Running migrations for vcp:
- Nothing to migrate.
- Loading initial data for vcp.
Installed 0 object(s) from 0 fixture(s)
Running migrations for support:
- Nothing to migrate.
- Loading initial data for support.
Installed 0 object(s) from 0 fixture(s)
Running migrations for directoryservice:
- Nothing to migrate.
- Loading initial data for directoryservice.
Installed 0 object(s) from 0 fixture(s)
Running migrations for account:
- Migrating forwards to 0024_add_media_user_and_group.
> account:0024_add_media_user_and_group
- Migration 'account:0024_add_media_user_and_group' is marked for no-dry-run.
! Error found during real run of migration! Aborting.

! Since you have a database that does not support running
! schema-altering statements in transactions, we have had
! to leave it in an interim state between migrations.

! You might be able to recover with: (migration cannot be dry-run; cannot discover commands)
! The South developers regret this has happened, and would
! like to gently persuade you to consider a slightly
! easier-to-deal-with DBMS (one that supports DDL transactions)
! NOTE: The error which caused the migration to fail is further up.
Error in migration: account:0024_add_media_user_and_group
Traceback (most recent call last):
File "/usr/local/www/freenasUI/manage.py", line 42, in <module>
execute_from_command_line(sys.argv)
File "/usr/local/lib/python2.7/site-packages/django/core/management/__init__.py", line 399, in execute_from_command_line
utility.execute()
File "/usr/local/lib/python2.7/site-packages/django/core/management/__init__.py", line 392, in execute
self.fetch_command(subcommand).run_from_argv(self.argv)
File "/usr/local/lib/python2.7/site-packages/django/core/management/base.py", line 242, in run_from_argv
self.execute(*args, **options.__dict__)
File "/usr/local/lib/python2.7/site-packages/django/core/management/base.py", line 285, in execute
output = self.handle(*args, **options)
File "/usr/local/lib/python2.7/site-packages/south/management/commands/migrate.py", line 111, in handle
ignore_ghosts = ignore_ghosts,
File "/usr/local/lib/python2.7/site-packages/south/migration/__init__.py", line 220, in migrate_app
success = migrator.migrate_many(target, workplan, database)
File "/usr/local/lib/python2.7/site-packages/south/migration/migrators.py", line 256, in migrate_many
result = migrator.__class__.migrate_many(migrator, target, migrations, database)
File "/usr/local/lib/python2.7/site-packages/south/migration/migrators.py", line 331, in migrate_many
result = self.migrate(migration, database)
File "/usr/local/lib/python2.7/site-packages/south/migration/migrators.py", line 133, in migrate
result = self.run(migration, database)
File "/usr/local/lib/python2.7/site-packages/south/migration/migrators.py", line 114, in run
return self.run_migration(migration, database)
File "/usr/local/lib/python2.7/site-packages/south/migration/migrators.py", line 84, in run_migration
migration_function()
File "/usr/local/lib/python2.7/site-packages/south/migration/migrators.py", line 60, in <lambda>
return (lambda: direction(orm))
File "/usr/local/www/freenasUI/../freenasUI/account/migrations/0024_add_media_user_and_group.py", line 14, in forwards
group.save()
File "/usr/local/lib/python2.7/site-packages/django/db/models/base.py", line 545, in save
force_update=force_update, update_fields=update_fields)
File "/usr/local/lib/python2.7/site-packages/django/db/models/base.py", line 573, in save_base
updated = self._save_table(raw, cls, force_insert, force_update, using, update_fields)
File "/usr/local/lib/python2.7/site-packages/django/db/models/base.py", line 654, in _save_table
result = self._do_insert(cls._base_manager, using, fields, update_pk, raw)
File "/usr/local/lib/python2.7/site-packages/django/db/models/base.py", line 687, in _do_insert
using=using, raw=raw)
File "/usr/local/lib/python2.7/site-packages/django/db/models/manager.py", line 232, in _insert
return insert_query(self.model, objs, fields, **kwargs)
File "/usr/local/lib/python2.7/site-packages/django/db/models/query.py", line 1514, in insert_query
return query.get_compiler(using=using).execute_sql(return_id)
File "/usr/local/lib/python2.7/site-packages/django/db/models/sql/compiler.py", line 903, in execute_sql
cursor.execute(sql, params)
File "/usr/local/lib/python2.7/site-packages/django/db/backends/util.py", line 53, in execute
return self.cursor.execute(sql, params)
File "/usr/local/lib/python2.7/site-packages/django/db/utils.py", line 99, in exit
six.reraise(dj_exc_type, dj_exc_value, traceback)
File "/usr/local/lib/python2.7/site-packages/django/db/backends/util.py", line 53, in execute
return self.cursor.execute(sql, params)
File "/usr/local/www/freenasUI/../freenasUI/freeadmin/sqlite3_ha/base.py", line 376, in execute
execute = Database.Cursor.execute(self, query, params)
django.db.utils.IntegrityError: UNIQUE constraint failed: account_bsdgroups.bsdgrp_group


Related issues

Is duplicate of FreeNAS - Bug #17794: Update Failed Critical Alert for FreeNAS-9.10.1-U1Closed: Duplicate2016-09-27
Has duplicate FreeNAS - Bug #17818: Update Failed - Check /data/update.failed for further detailsClosed: Duplicate2016-09-27
Has duplicate FreeNAS - Bug #17820: Update fails if media group already existsClosed: Duplicate2016-09-27
Is duplicate of FreeNAS - Bug #17824: Update to FreeNAS-9.10.1-U1 failedClosed: Duplicate2016-09-28
Has duplicate FreeNAS - Bug #17897: Upgrading problem with accountClosed: Duplicate2016-09-29
Has duplicate FreeNAS - Bug #17925: Failed upgradeClosed: Duplicate2016-09-30

Associated revisions

Revision 86d1d3d6 (diff)
Added by William Grzybowski about 4 years ago

fix(gui): do not try to create "media" user/group if one exists Ticket: #17789

Revision 6527c8b1 (diff)
Added by William Grzybowski about 4 years ago

fix(gui): do not try to create "media" user/group if one exists Ticket: #17789 (cherry picked from commit 86d1d3d6c8e0afc94a71a5f73bce68b26cf026bd)

Revision 96c08756 (diff)
Added by William Grzybowski about 4 years ago

fix(gui): do not try to create "media" user/group if one exists Ticket: #17789 (cherry picked from commit 86d1d3d6c8e0afc94a71a5f73bce68b26cf026bd)

History

#1 Updated by Rudi Pittman about 4 years ago

  • Subject changed from Bug from latest updates for 9.10 on 09/27/2016 to Bug from latest updates for 9.10.1 on 09/27/2016
  • Seen in changed from Unspecified to 9.10.1

#2 Updated by Vaibhav Chauhan about 4 years ago

please attach debug by going into system, advanced, save debug

#3 Updated by Rudi Pittman about 4 years ago

  • File debug-freenas-20160927031742.tgz added

#4 Updated by Greg Ledet about 4 years ago

  • File debug-freenas-20160927081558.tgz added

Same issue for me as well.

cat /data/update.failed
Running migrations for api:
- Nothing to migrate.
- Loading initial data for api.
Installed 0 object(s) from 0 fixture(s)
Running migrations for freeadmin:
- Nothing to migrate.
- Loading initial data for freeadmin.
Installed 0 object(s) from 0 fixture(s)
Running migrations for vcp:
- Nothing to migrate.
- Loading initial data for vcp.
Installed 0 object(s) from 0 fixture(s)
Running migrations for support:
- Nothing to migrate.
- Loading initial data for support.
Installed 0 object(s) from 0 fixture(s)
Running migrations for storage:
- Nothing to migrate.
- Loading initial data for storage.
Installed 0 object(s) from 0 fixture(s)
Running migrations for system:
- Nothing to migrate.
- Loading initial data for system.
Installed 0 object(s) from 0 fixture(s)
Running migrations for services:
- Migrating forwards to 0198_iscsi_expunge_lun_auto.
> services:0198_iscsi_expunge_lun_auto
- Migration 'services:0198_iscsi_expunge_lun_auto' is marked for no-dry-run.
- Loading initial data for services.
Installed 0 object(s) from 0 fixture(s)
Running migrations for directoryservice:
- Nothing to migrate.
- Loading initial data for directoryservice.
Installed 0 object(s) from 0 fixture(s)
Running migrations for tasks:
- Nothing to migrate.
- Loading initial data for tasks.
Installed 0 object(s) from 0 fixture(s)
Running migrations for plugins:
- Nothing to migrate.
- Loading initial data for plugins.
Installed 0 object(s) from 0 fixture(s)
Running migrations for sharing:
- Nothing to migrate.
- Loading initial data for sharing.
Installed 0 object(s) from 0 fixture(s)
Running migrations for jails:
- Nothing to migrate.
- Loading initial data for jails.
Installed 0 object(s) from 0 fixture(s)
Running migrations for network:
- Nothing to migrate.
- Loading initial data for network.
Installed 0 object(s) from 0 fixture(s)
Running migrations for account:
- Migrating forwards to 0024_add_media_user_and_group.
> account:0024_add_media_user_and_group
- Migration 'account:0024_add_media_user_and_group' is marked for no-dry-run.
! Error found during real run of migration! Aborting.

! Since you have a database that does not support running
! schema-altering statements in transactions, we have had
! to leave it in an interim state between migrations.

! You might be able to recover with: (migration cannot be dry-run; cannot discover commands)
! The South developers regret this has happened, and would
! like to gently persuade you to consider a slightly
! easier-to-deal-with DBMS (one that supports DDL transactions)
! NOTE: The error which caused the migration to fail is further up.
Error in migration: account:0024_add_media_user_and_group
Traceback (most recent call last):
File "/usr/local/www/freenasUI/manage.py", line 42, in <module>
execute_from_command_line(sys.argv)
File "/usr/local/lib/python2.7/site-packages/django/core/management/__init__.py", line 399, in execute_from_command_line
utility.execute()
File "/usr/local/lib/python2.7/site-packages/django/core/management/__init__.py", line 392, in execute
self.fetch_command(subcommand).run_from_argv(self.argv)
File "/usr/local/lib/python2.7/site-packages/django/core/management/base.py", line 242, in run_from_argv
self.execute(*args, **options.__dict__)
File "/usr/local/lib/python2.7/site-packages/django/core/management/base.py", line 285, in execute
output = self.handle(*args, **options)
File "/usr/local/lib/python2.7/site-packages/south/management/commands/migrate.py", line 111, in handle
ignore_ghosts = ignore_ghosts,
File "/usr/local/lib/python2.7/site-packages/south/migration/__init__.py", line 220, in migrate_app
success = migrator.migrate_many(target, workplan, database)
File "/usr/local/lib/python2.7/site-packages/south/migration/migrators.py", line 256, in migrate_many
result = migrator.__class__.migrate_many(migrator, target, migrations, database)
File "/usr/local/lib/python2.7/site-packages/south/migration/migrators.py", line 331, in migrate_many
result = self.migrate(migration, database)
File "/usr/local/lib/python2.7/site-packages/south/migration/migrators.py", line 133, in migrate
result = self.run(migration, database)
File "/usr/local/lib/python2.7/site-packages/south/migration/migrators.py", line 114, in run
return self.run_migration(migration, database)
File "/usr/local/lib/python2.7/site-packages/south/migration/migrators.py", line 84, in run_migration
migration_function()
File "/usr/local/lib/python2.7/site-packages/south/migration/migrators.py", line 60, in <lambda>
return (lambda: direction(orm))
File "/usr/local/www/freenasUI/../freenasUI/account/migrations/0024_add_media_user_and_group.py", line 14, in forwards
group.save()
File "/usr/local/lib/python2.7/site-packages/django/db/models/base.py", line 545, in save
force_update=force_update, update_fields=update_fields)
File "/usr/local/lib/python2.7/site-packages/django/db/models/base.py", line 573, in save_base
updated = self._save_table(raw, cls, force_insert, force_update, using, update_fields)
File "/usr/local/lib/python2.7/site-packages/django/db/models/base.py", line 654, in _save_table
result = self._do_insert(cls._base_manager, using, fields, update_pk, raw)
File "/usr/local/lib/python2.7/site-packages/django/db/models/base.py", line 687, in _do_insert
using=using, raw=raw)
File "/usr/local/lib/python2.7/site-packages/django/db/models/manager.py", line 232, in _insert
return insert_query(self.model, objs, fields, **kwargs)
File "/usr/local/lib/python2.7/site-packages/django/db/models/query.py", line 1514, in insert_query
return query.get_compiler(using=using).execute_sql(return_id)
File "/usr/local/lib/python2.7/site-packages/django/db/models/sql/compiler.py", line 903, in execute_sql
cursor.execute(sql, params)
File "/usr/local/lib/python2.7/site-packages/django/db/backends/util.py", line 53, in execute
return self.cursor.execute(sql, params)
File "/usr/local/lib/python2.7/site-packages/django/db/utils.py", line 99, in exit
six.reraise(dj_exc_type, dj_exc_value, traceback)
File "/usr/local/lib/python2.7/site-packages/django/db/backends/util.py", line 53, in execute
return self.cursor.execute(sql, params)
File "/usr/local/www/freenasUI/../freenasUI/freeadmin/sqlite3_ha/base.py", line 376, in execute
execute = Database.Cursor.execute(self, query, params)
django.db.utils.IntegrityError: UNIQUE constraint failed: account_bsdgroups.bsdgrp_group

#5 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Assignee set to Sean Fagan
  • Target version set to 9.10.1-U2

#6 Updated by Andrew McCann about 4 years ago

  • Assignee deleted (Sean Fagan)

And same issue for me, can send debug if required.

#7 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Assignee set to Sean Fagan

#8 Updated by Gary Oberbrunner about 4 years ago

Me too, exact same issue.

#9 Updated by Ryan Be about 4 years ago

Same issue. I assume it's because there was a "media" user/group that I had created manually.

> account:0024_add_*media*_user_and_group

django.db.utils.IntegrityError: UNIQUE constraint failed: account_bsdgroups.bsdgrp_group

#10 Updated by Rudi Pittman about 4 years ago

Ryan Be wrote:

Same issue. I assume it's because there was a "media" user/group that I had created manually.

account:0024_add_*media*_user_and_group


django.db.utils.IntegrityError: UNIQUE constraint failed: account_bsdgroups.bsdgrp_group

I also had manually edited my group so media was the same user transmission used:

From /etc/group
media:*:816:media

#11 Updated by William Grzybowski about 4 years ago

  • Status changed from Unscreened to Screened
  • Assignee changed from Sean Fagan to William Grzybowski

#12 Updated by William Grzybowski about 4 years ago

  • Status changed from Screened to Needs Developer Review

#13 Updated by William Grzybowski about 4 years ago

  • Is duplicate of Bug #17794: Update Failed Critical Alert for FreeNAS-9.10.1-U1 added

#14 Updated by William Grzybowski about 4 years ago

  • Is duplicate of deleted (Bug #17794: Update Failed Critical Alert for FreeNAS-9.10.1-U1)

#15 Updated by William Grzybowski about 4 years ago

  • Is duplicate of Bug #17794: Update Failed Critical Alert for FreeNAS-9.10.1-U1 added

#17 Updated by William Grzybowski about 4 years ago

  • Priority changed from No priority to Critical

#18 Updated by Adam Lewis about 4 years ago

  • File update.failed added

Another case piping up here, rolled back boot snapshoot to get things smoothly running again which i fine for now.
Attached my update.failed in case it's useful, but I doubt anything new can be gleaned from it as it looks to be the same as others to my eyes.

#19 Updated by William Grzybowski about 4 years ago

Adam Lewis wrote:

Another case piping up here, rolled back boot snapshoot to get things smoothly running again which i fine for now.
Attached my update.failed in case it's useful, but I doubt anything new can be gleaned from it as it looks to be the same as others to my eyes.

Can you clarify what happens apart from the alert message?
Are you unable to use the UI?

#20 Updated by Josh Paetzel about 4 years ago

  • Status changed from Needs Developer Review to Reviewed

#21 Updated by Adam Lewis about 4 years ago

Oh, apologies, should have said of course.
Unable to browse to shared directories remotely, jails with networking tasks (eg mineos) were running, well, flakey, but not broken outright. Sorry, vague there.
Could ssh in, and webui worked fine.
Status alerts in the web ui that were new to me and appeared after update included (just a few, rest are along the same lines)
generate_smb4_conf.py: [generate_smb4_conf:1498] Unable to open /var/db/samba4/private/secrets.tdb: [Errno 2] No such file or directory

smbd: dnssd_clientstub ConnectToServer: connect()-> No of tries: 1

smbd: dnssd_clientstub ConnectToServer: connect() failed path:/var/run/mdnsd Socket:35 Err:-1 Errno:2 No such file or directory
mDNSResponder: mDNSResponder (Engineering Build) (Sep 26 2016 21:17:15) starting
mDNSResponder: 8: Listening for incoming Unix Domain Socket client requests
mDNSResponder: mDNS_AddDNSServer: Lock not held! mDNS_busy (0) mDNS_reentrancy (0)
mDNSResponder: CheckNATMappings: Failed to allocate port 5350 UDP multicast socket for PCP & NAT-PMP announcements
mDNSResponder: mDNS_Register_internal: ERROR!! Tried to register AuthRecord 0000000801406D60 squidnas.local. (Addr) that's already in the list
mDNSResponder: mDNS_Register_internal: ERROR!! Tried to register AuthRecord 0000000801407180 37.0.168.192.in-addr.arpa. (PTR) that's already in the list

kernel: ng_ether_ifnet_arrival_event: can't re-name node epair0b
kernel: ng_ether_ifnet_arrival_event: can't re-name node epair0b

I have to go work for a few hours, but if it's helpful let me know what logs to collect and attach and I'll do o when I get back. Sorry, not sure what info will be helpful and drowning you in log files seems counterproductive. Also, my administration skills are not fully competent, and that doesn't help me isolate what is relevant here. I just follow the advice of leave freenas settings at default if you don't know what you are doing and only mes around in jails so you don't bring the whole thing down with one typo.
Also, keyboard has solder bits in it, so typos are unavoidable, I apologize if anything i imposile to decypher. "s" and "b" are the most impaired if you haven't guessed.

#22 Updated by Alex Jarvis about 4 years ago

Same problem as well, also had a media user prior to upgrading and seeing the same errors mentioned here.

#23 Updated by David Kornalijnslijper about 4 years ago

Same situation!

#24 Updated by William Grzybowski about 4 years ago

Anybody else unable to browse to shared directories remotely? If so, there is probably another issue here that should be investigated.

#25 Updated by Rudi Pittman about 4 years ago

William Grzybowski wrote:

Anybody else unable to browse to shared directories remotely? If so, there is probably another issue here that should be investigated.

I'm on linux using smb://xxx.xxx.xxx.xxx in krusader (dual pane file explorer) and I'm able to browse without issue on my system.

#26 Updated by Greg Ledet about 4 years ago

No issues viewing shares...

#27 Updated by William Grzybowski about 4 years ago

Ok, do you guys see any issue apart from the alert error?

I guess it is safe to say at this point that this error can be ignored for now if the answer is yes. Nothing to worry about this time.

#28 Updated by Rudi Pittman about 4 years ago

I did a rollback so I'm not having that issue but if media was world accessible before it might not be NOW which would prevent you from browsing unless you did so as a user. smb://user:

#29 Updated by Casey Hancock about 4 years ago

  • File freenas_9.10.1-u1_update_failed.txt added

I have the same issue here. I just updated about 20 minutes ago though. I am able to access SMB shares but I would not say that I have test all functionality to say there are no other problems. All together I have tested the WebUI, SSH access, several media automation plugins, and SMB shares from a windows client with no known issues aside from the warning that the upgrade failed. the error report from my system can be found here http://pastebin.com/EiQrM2T1

#30 Updated by Adam Lewis about 4 years ago

Have rebooted into 9.10-U1 again as a test. This time everything runs well but I swear I had more file shared in my media user's shared directory (but to be honest, perhaps not. Only ever had certain music and video redundantly in there, so may have gotten rid of them for some reason and forgotten. No real loss as all backup storage intact).
Would not claim that beyond same warnings returning that there were any real consequence at this time.
Reverted back to 9.10.1 boot environment anyway for now. If I can help, let me know.

#31 Updated by Sean Fagan about 4 years ago

  • Has duplicate Bug #17818: Update Failed - Check /data/update.failed for further details added

#32 Updated by Vaibhav Chauhan about 4 years ago

  • Status changed from Reviewed to Ready For Release

#33 Updated by Sean Fagan about 4 years ago

  • Has duplicate Bug #17820: Update fails if media group already exists added

#34 Updated by William Elwood about 4 years ago

Does the failure of this bit of migration mean that later migration code has not executed and thus the system is in an inconsistent state? In other words, is it safe to ignore this error or should we be rolling back to before the update and waiting for the fix to be released?

#35 Updated by Alex Jarvis about 4 years ago

Unfortunately looks like even if you rollback you can't re-run the update since it already sees it as installed. Seems -U2 will need to check for an incomplete migration and finish it.

#36 Updated by Tony Scicchitano about 4 years ago

  • Seen in changed from 9.10.1 to 9.10-U1

I have the same error and can't start VirtualBox anymore. Rolling back fixes that.

#37 Updated by William Grzybowski about 4 years ago

Tony Scicchitano wrote:

I have the same error and can't start VirtualBox anymore. Rolling back fixes that.

Create another ticket for virtualbox with details.

#38 Updated by William Grzybowski about 4 years ago

  • Is duplicate of Bug #17824: Update to FreeNAS-9.10.1-U1 failed added

#39 Updated by Nicholas Essner about 4 years ago

William Elwood wrote:

Does the failure of this bit of migration mean that later migration code has not executed and thus the system is in an inconsistent state? In other words, is it safe to ignore this error or should we be rolling back to before the update and waiting for the fix to be released?

This is my concern as well. Things seem to be functioning normally at this point. But I would like to know if it's OK to proceed with the system in the state it's in, or if I need to rollback and wait for a fix.

Alex Jarvis wrote:

Unfortunately looks like even if you rollback you can't re-run the update since it already sees it as installed.

I notice this on my system as well.

#40 Updated by Gairy Spiers about 4 years ago

I just had a failure as well, updating from 9.10.1 (d989edd) to 9.10.1-U1 (ff51a5d). Rebooting to old environment brought me back up, but a second attempt to update yielded the same result.

Error in migration: account:0024_add_media_user_and_group

~% cat /etc/passwd | grep media
media:*:816:1001:Media for SickRage:/nonexistent:/bin/csh

Running migrations for api:
- Nothing to migrate.
- Loading initial data for api.
Installed 0 object(s) from 0 fixture(s)
Running migrations for freeadmin:
- Nothing to migrate.
- Loading initial data for freeadmin.
Installed 0 object(s) from 0 fixture(s)
Running migrations for directoryservice:
- Nothing to migrate.
- Loading initial data for directoryservice.
Installed 0 object(s) from 0 fixture(s)
Running migrations for services:
- Migrating forwards to 0198_iscsi_expunge_lun_auto.
> services:0198_iscsi_expunge_lun_auto
- Migration 'services:0198_iscsi_expunge_lun_auto' is marked for no-dry-run.
- Loading initial data for services.
Installed 0 object(s) from 0 fixture(s)
Running migrations for support:
- Nothing to migrate.
- Loading initial data for support.
Installed 0 object(s) from 0 fixture(s)
Running migrations for vcp:
- Nothing to migrate.
- Loading initial data for vcp.
Installed 0 object(s) from 0 fixture(s)
Running migrations for account:
- Migrating forwards to 0024_add_media_user_and_group.
> account:0024_add_media_user_and_group
- Migration 'account:0024_add_media_user_and_group' is marked for no-dry-run.
! Error found during real run of migration! Aborting.

! Since you have a database that does not support running
! schema-altering statements in transactions, we have had
! to leave it in an interim state between migrations.

! You might be able to recover with: (migration cannot be dry-run; cannot discover commands)
! The South developers regret this has happened, and would
! like to gently persuade you to consider a slightly
! easier-to-deal-with DBMS (one that supports DDL transactions)
! NOTE: The error which caused the migration to fail is further up.
Error in migration: account:0024_add_media_user_and_group
Traceback (most recent call last):
File "/usr/local/www/freenasUI/manage.py", line 42, in <module>
execute_from_command_line(sys.argv)
File "/usr/local/lib/python2.7/site-packages/django/core/management/__init__.py", line 399, in execute_from_command_line
utility.execute()
File "/usr/local/lib/python2.7/site-packages/django/core/management/__init__.py", line 392, in execute
self.fetch_command(subcommand).run_from_argv(self.argv)
File "/usr/local/lib/python2.7/site-packages/django/core/management/base.py", line 242, in run_from_argv
self.execute(*args, **options.__dict__)
File "/usr/local/lib/python2.7/site-packages/django/core/management/base.py", line 285, in execute
output = self.handle(*args, **options)
File "/usr/local/lib/python2.7/site-packages/south/management/commands/migrate.py", line 111, in handle
ignore_ghosts = ignore_ghosts,
File "/usr/local/lib/python2.7/site-packages/south/migration/__init__.py", line 220, in migrate_app
success = migrator.migrate_many(target, workplan, database)
File "/usr/local/lib/python2.7/site-packages/south/migration/migrators.py", line 256, in migrate_many
result = migrator.__class__.migrate_many(migrator, target, migrations, database)
File "/usr/local/lib/python2.7/site-packages/south/migration/migrators.py", line 331, in migrate_many
result = self.migrate(migration, database)
File "/usr/local/lib/python2.7/site-packages/south/migration/migrators.py", line 133, in migrate
result = self.run(migration, database)
File "/usr/local/lib/python2.7/site-packages/south/migration/migrators.py", line 114, in run
return self.run_migration(migration, database)
File "/usr/local/lib/python2.7/site-packages/south/migration/migrators.py", line 84, in run_migration
migration_function()
File "/usr/local/lib/python2.7/site-packages/south/migration/migrators.py", line 60, in <lambda>
return (lambda: direction(orm))
File "/usr/local/www/freenasUI/../freenasUI/account/migrations/0024_add_media_user_and_group.py", line 26, in forwards
user.save()
File "/usr/local/lib/python2.7/site-packages/django/db/models/base.py", line 545, in save
force_update=force_update, update_fields=update_fields)
File "/usr/local/lib/python2.7/site-packages/django/db/models/base.py", line 573, in save_base
updated = self._save_table(raw, cls, force_insert, force_update, using, update_fields)
File "/usr/local/lib/python2.7/site-packages/django/db/models/base.py", line 654, in _save_table
result = self._do_insert(cls._base_manager, using, fields, update_pk, raw)
File "/usr/local/lib/python2.7/site-packages/django/db/models/base.py", line 687, in _do_insert
using=using, raw=raw)
File "/usr/local/lib/python2.7/site-packages/django/db/models/manager.py", line 232, in _insert
return insert_query(self.model, objs, fields, **kwargs)
File "/usr/local/lib/python2.7/site-packages/django/db/models/query.py", line 1514, in insert_query
return query.get_compiler(using=using).execute_sql(return_id)
File "/usr/local/lib/python2.7/site-packages/django/db/models/sql/compiler.py", line 903, in execute_sql
cursor.execute(sql, params)
File "/usr/local/lib/python2.7/site-packages/django/db/backends/util.py", line 53, in execute
return self.cursor.execute(sql, params)
File "/usr/local/lib/python2.7/site-packages/django/db/utils.py", line 99, in exit
six.reraise(dj_exc_type, dj_exc_value, traceback)
File "/usr/local/lib/python2.7/site-packages/django/db/backends/util.py", line 53, in execute
return self.cursor.execute(sql, params)
File "/usr/local/www/freenasUI/../freenasUI/freeadmin/sqlite3_ha/base.py", line 376, in execute
execute = Database.Cursor.execute(self, query, params)
django.db.utils.IntegrityError: UNIQUE constraint failed: account_bsdusers.bsdusr_username

#41 Updated by William Grzybowski about 4 years ago

  • Seen in changed from 9.10-U1 to 9.10.1-U1

Ok, I think we have enough reports, thanks everybody.

#42 Updated by Sean Fagan about 4 years ago

  • Has duplicate Bug #17897: Upgrading problem with account added

#43 Updated by Sean Fagan about 4 years ago

#44 Updated by Vaibhav Chauhan about 4 years ago

  • Status changed from Ready For Release to Resolved

#45 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug-freenas-20160927031742.tgz)

#46 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug-freenas-20160927081558.tgz)

#47 Updated by Dru Lavigne over 2 years ago

  • File deleted (update.failed)

#48 Updated by Dru Lavigne over 2 years ago

  • File deleted (freenas_9.10.1-u1_update_failed.txt)

Also available in: Atom PDF