Project

General

Profile

Bug #17872

Domain controller is not working

Added by Jakub Klama almost 3 years ago. Updated over 2 years ago.

Status:
Closed: Cannot reproduce
Priority:
Expected
Assignee:
Erin Clark
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

My DC configuration: http://imgur.com/EDu6jM6

Issues:
1) Need to click service enable switch 3-4 times before domain controller service transitions to "on" state
2) Internal DNS server doesn't work - FreeNAS is not responding to DNS queries
3) FreeNAS box itself loses DNS access, because 127.0.0.1 is now configured as DNS server in resolv.conf

I'm not able to do any further testing due to DNS server not working - my workstation can't even find the DC.

History

#1 Updated by William Grzybowski almost 3 years ago

  • Status changed from Unscreened to Screened
  • Target version set to 9.10.1-U3

#2 Updated by William Grzybowski almost 3 years ago

  • Assignee changed from William Grzybowski to Erin Clark

This is beyond me and my time available. Erin, is this something you can look at?

#3 Updated by William Grzybowski almost 3 years ago

  • Status changed from Screened to Unscreened

#4 Updated by Erin Clark almost 3 years ago

  • Status changed from Unscreened to Screened

#5 Updated by Erin Clark almost 3 years ago

I did notice the thing with the server not starting instantaneously when I clicked the button but I was able to get it to start and local dns worked for me, I was also able to get a windows box to bind to the domain on my test system

#6 Updated by William Grzybowski almost 3 years ago

Erin Clark wrote:

I did notice the thing with the server not starting instantaneously when I clicked the button but I was able to get it to start and local dns worked for me, I was also able to get a windows box to bind to the domain on my test system

I see, did you test on nightly or stable?

#7 Updated by Erin Clark almost 3 years ago

I tested on stable

#8 Updated by Wojciech Kloska almost 3 years ago

I just did a fresh install of 9.10.1 from stable branch and tried to reproduce Jakub's example with the same parameters.

Although I had no problems with starting the service itself I also cannot join the created domain using my Mac.

#9 Updated by Dru Lavigne almost 3 years ago

Will this make it into U3?

#10 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 3 years ago

  • Target version changed from 9.10.1-U3 to 9.10.2

#11 Updated by Calvin Levy almost 3 years ago

  • Seen in changed from 9.10.1-U1 to 9.10.1-U4
Confirming issues #2 and #3 still exist.
  • DOMAIN CONTROLLER IS WORKING ***
  • INTERNAL DNS IS NOT WORKING ***

Issues Originally Reported:
1) Need to click service enable switch 3-4 times before domain controller service transitions to "on" state
Response: Using version FreeNAS-9.10.1-U4 (ec9a7d3) & previous versions, the Domain Controller service toggles to "On" and "Off" positions with ease on the first click. Using Domain Forest Level: 2008_R2.
2) Internal DNS server doesn't work - FreeNAS is not responding to DNS queries
Response 1: DNS forwarder on Domain Controller service does not forward queries to internal BIND dns server.
Response 2: Configuring Nameserver 1 & 2 with internal DNS servers have no effect. Using Shell option in FreeNAS to test internal LAN pings all fail 100%.
Response 3: Using Shell option in FreeNAS to test internal LAN pings that are entered in the Host Name Data Base fails 100% of the time. Only the internal FreeNAS PDC hostname is pingable. It returns a ping 100% of the time.
3) FreeNAS box itself loses DNS access, because 127.0.0.1 is now configured as DNS server in resolv.conf
Response: Confirmed local loopback IP in the /etc/resolv.conf file. Cannot make permanent changes using cli. Interesting though, 127.0.0.1 is not allowed as a Nameserver option but is in the resolv.conf file.

#12 Updated by Calvin Levy almost 3 years ago

Additionally, from LAN client using only IP of FreeNAS device as DNS server, I can ping external sites such as google.com without issue...works 100% of the time. All while using my internal DNS servers as DNS forwarder and Nameservers on FreeNAS.

Same results as above while using the Shell option on FreeNAS. Pinging external sites works 100% of the time, while pinging internal LAN devices does not work 100% of the time.

No external DNS servers are configured on FreeNAS. The internal DNS servers forwards to external DNS servers.

#13 Updated by Calvin Levy almost 3 years ago

Okay...so...I was over thinking it. In my humble opinion, all three issues presented here are no longer issues. My problem with issues #2 & #3 turned out to be simple. Since working in an Active Directory environment, one cannot think Linux/Unix. One must think like a Windows guy. So, using RSAT to manage DNS is the way to go. No other internal DNS servers are required.

#14 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 3 years ago

Jakub / Wojciech you guys still running into this with latest nightly?

#15 Avatar?id=14398&size=24x24 Updated by Kris Moore over 2 years ago

  • Status changed from Screened to Closed: Cannot reproduce

Also available in: Atom PDF