Project

General

Profile

Bug #17875

Specify a quota per time machine backup

Added by Stuart Espey about 2 years ago. Updated 11 months ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
Vladimir Vinogradenko
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Mac OS X Server can specify a quota per time machine backup. All backups to the same share have the same quota, but they don't share a quota.

As opposed to setting a quota on the entire timemachine dataset/share which is shared amongst all backups.

Its actually very simple syste.

tank/tm_backups is my time machine dataset, shared via AFP.

[root@titan] /mnt/tank/server/scripts# cd /mnt/tank/tm_backups
[root@titan] /mnt/tank/tm_backups# ls alt
total 160
drwxrwx--
2 tm_user wheel 6 Sep 30 01:33 .AppleDB/
drwxrwx--- 9 tm_user wheel 14 Sep 30 01:23 ./
drwxrwx--- 3 tm_user wheel 10 Sep 30 01:23 redact.sparsebundle/
drwxrwx--- 3 tm_user wheel 10 Sep 30 01:18 redact2.sparsebundle/
drwxrwx--- 3 tm_user wheel 10 Sep 30 00:53 redact3.sparsebundle/
drwxrwx--- 3 tm_user wheel 10 Sep 30 00:22 redact4.sparsebundle/
drwxr-xr-x 9 root wheel 9 Sep 28 17:24 ../
drwxrwx--- 3 tm_user wheel 9 Sep 23 16:17 redact5.sparsebundle/
rwxrwx-- 1 tm_user wheel 6148 Sep 21 23:23 .DS_Store*
rw-r--r- 1 root wheel 0 Sep 21 22:43 .com.apple.timemachine.supported
rw-r--r- 1 root wheel 246 Sep 21 22:43 .com.apple.TimeMachine.quota.plist
rwxrwx-- 1 tm_user wheel 0 Jun 10 15:22 .apple*
drwxrwx--- 2 tm_user wheel 2 Jun 10 15:21 Backups.backupdb/
rwxrwx-- 1 tm_user wheel 0 Jun 10 14:56 .mac*

The ".com.apple.TimeMachine.quota.plist" is a plist which specifies the quota

  1. cat .com.apple.TimeMachine.quota.plist

    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    <key>GlobalQuota</key>
    <integer>2000000000000</integer>
    </dict>
    </plist>

Here I have the per backup quota set to 2000000000000, ie 2TB.

This means I can leave the tm_backups data set quota free. There are benefits to this.

I'm not 100% certain if the .com.apple.timemachine.supported file is needed. but its zero bytes.

The permissions are the same as what my OSX server uses.

When a Mac OS X client connects, the osx log shows the below when the quota is enabled:

30/09/2016 1:14:11.522 AM com.apple.backupd17374: Disk image /Volumes/Titan Time Machine/redact2.sparsebundle mounted at: /Volumes/Time Machine Backups
30/09/2016 1:14:11.720 AM com.apple.backupd17374: Network destination already mounted at: /Volumes/Titan Time Machine
30/09/2016 1:14:40.006 AM com.apple.backupd17374: Quota in effect for '/Volumes/Titan Time Machine': 2 TB (2,000,000,000,000 bytes)

And it will then behave as if it has a 2TB quota, trimming the backups as necessary, but utilizing up to 2TB.

Without this support, you are limited to either having your full pool available for time machine, and the first mac client that connects will grow its sparsebundle to the size of the pool... which could be massive... OR you set a quota on the dataset, and then the macs will all attempt to share that space, but you will have issues as one greedy mac can use up all the backup quota.

I suggest a neat feature in the dataset gui, where if you enable time machine, then you can also enter an optional Time Machine Quota. You could then re-generate the quota file in the dataset when ever it was changed in the gui, or delete it if it was removed.

It would also be sensible to regenerate it when enabling AFP, specifically at startup.

According to apple's documentation, this will apply to Mavericks and newer. I recall previous documentation stating that it worked with 10.5+.

The GUI from the OSX server can be seen in this ars technica article:
http://arstechnica.com/apple/2013/12/a-power-users-guide-to-os-x-server-mavericks-edition/5/

I've attached the relevant png from the article, time-machine-2.png

I've also attached the plist, but in the tar.gz, with the prefixed period removed

This would be a really useful feature, as I'm sure you know there are a lot of Mac people using FreeNAS as a backup target for Time Machine.

Time-Machine-2.png (117 KB) Time-Machine-2.png Stuart Espey, 09/29/2016 09:11 AM
timemachine checkbox.png (21.8 KB) timemachine checkbox.png Stuart Espey, 09/29/2016 11:55 PM
Screen Shot 2017-11-21 at 9.58.39 AM.png (30.2 KB) Screen Shot 2017-11-21 at 9.58.39 AM.png Bonnie Follweiler, 11/21/2017 07:00 AM
Screen Shot 2017-11-21 at 9.58.17 AM.png (119 KB) Screen Shot 2017-11-21 at 9.58.17 AM.png Bonnie Follweiler, 11/21/2017 07:00 AM
Capto_Capture 2018-01-02_11-53-11_PM.png (29.6 KB) Capto_Capture 2018-01-02_11-53-11_PM.png 256 GiB entered as 262,144 MiB Harry Weppner, 01/03/2018 12:08 AM
Capto_Capture 2018-01-02_11-54-03_PM.png (35.4 KB) Capto_Capture 2018-01-02_11-54-03_PM.png Generated quota plist Harry Weppner, 01/03/2018 12:08 AM
7283
7299
13117
13118
13724
13725

Related issues

Has duplicate FreeNAS - Bug #27672: TimeMachine quota value is taken as MB, not GBClosed: Duplicate2018-01-07

Associated revisions

Revision 84c1c6cc (diff)
Added by Vladimir Vinogradenko over 1 year ago

feat(gui): Time Machine Quotas (OSX Server Style)

Ticket: #17875

Revision 959e41fc (diff)
Added by Vladimir Vinogradenko over 1 year ago

feat(gui): Time Machine Quotas (OSX Server Style)

Ticket: #17875

Revision 77fe5ec5 (diff)
Added by Vladimir Vinogradenko over 1 year ago

feat(gui): Time Machine Quotas (OSX Server Style)

Ticket: #17875

Revision 5fb54a28 (diff)
Added by Vladimir Vinogradenko over 1 year ago

feat(gui): Time Machine Quotas (OSX Server Style)

Ticket: #17875

Revision bb247ed1 (diff)
Added by Vladimir Vinogradenko about 1 year ago

fix(gui): Add forgotten templates for Time Machine Quotas (OSX Server Style)

Ticket: #17875

Revision 8a41efe2 (diff)
Added by Vladimir Vinogradenko about 1 year ago

feat(gui): Time Machine Quotas (OSX Server Style)

Ticket: #17875

Revision 1cdfbf87 (diff)
Added by Vladimir Vinogradenko about 1 year ago

fix(gui): Add forgotten templates for Time Machine Quotas (OSX Server Style)

Ticket: #17875

Revision d314d6b1 (diff)
Added by Dru Lavigne about 1 year ago

Mention Time Machine Quota. Still need to update Time Machine example.
Ticket: #17875

Revision b5706609 (diff)
Added by Vladimir Vinogradenko about 1 year ago

fix(gui): Allow IEC-suffixed input for afp_timemachine_quota

Ticket: #17875

Revision fdee0cbd (diff)
Added by Vladimir Vinogradenko about 1 year ago

fix(gui): Allow IEC-suffixed input for afp_timemachine_quota

Ticket: #17875

Revision 826f71ec (diff)
Added by Vladimir Vinogradenko about 1 year ago

fix(afp): Make AFP share TimeMachine quota to be specified in GiB

Ticket: #17875

Revision 33261e57 (diff)
Added by Vladimir Vinogradenko about 1 year ago

fix(afp): Make AFP share TimeMachine quota to be specified in GiB

Ticket: #17875

Revision ae3b07ec (diff)
Added by Vladimir Vinogradenko 11 months ago

fix(afp): Make AFP share TimeMachine quota to be specified in GiB instead of MiB

Ticket: #17875

Revision 17935a62 (diff)
Added by Vladimir Vinogradenko 11 months ago

fix(afp): Make AFP share TimeMachine quota to be specified in GiB instead of MiB

Ticket: #17875

Revision d218e687 (diff)
Added by Vladimir Vinogradenko 11 months ago

fix(afp): Make AFP share TimeMachine quota to be specified in GiB instead of MiB

Ticket: #17875

Revision b22adecd (diff)
Added by Vladimir Vinogradenko 11 months ago

Merge migration cherry-picked to stable

Ticket: #17875

Revision 22374713 (diff)
Added by Vladimir Vinogradenko 10 months ago

Merge migration cherry-picked to stable

Ticket: #17875
(cherry picked from commit b22adecd8010fe238e949349f428aec68b2f72ba)
Signed-off-by: Timur I. Bakeyev <>

Revision b08bbb9f (diff)
Added by Vladimir Vinogradenko 10 months ago

Merge migration cherry-picked to stable

Ticket: #17875
(cherry picked from commit b22adecd8010fe238e949349f428aec68b2f72ba)
Signed-off-by: Timur I. Bakeyev <>

History

#1 Updated by Bonnie Follweiler about 2 years ago

  • Assignee set to Kris Moore

#2 Avatar?id=14398&size=24x24 Updated by Kris Moore about 2 years ago

  • Assignee changed from Kris Moore to Suraj Ravichandran
  • Priority changed from No priority to Nice to have
  • Target version set to 9.10.3

Suraj, looks like a possibly neat feature to include for a future point release.

#3 Updated by Suraj Ravichandran about 2 years ago

  • Status changed from Unscreened to Screened

#4 Updated by Stuart Espey about 2 years ago

7299

Based on the current GUI, I would suggest adding a Quota field next to the Time Machine checkbox in the AFP share config panel

I imagine the sensible thing to do would be to generate/destroy the quota plist whenever this panel is closed in the affirmative, and when starting AFP.

#5 Avatar?id=14398&size=24x24 Updated by Kris Moore over 1 year ago

  • Target version changed from 9.10.3 to 9.10.4

#6 Avatar?id=14398&size=24x24 Updated by Kris Moore over 1 year ago

  • Target version changed from 9.10.4 to 11.1

#8 Updated by Dru Lavigne over 1 year ago

  • Assignee changed from Suraj Ravichandran to William Grzybowski

William: please load balance between Vladimir and Nikola.

#9 Updated by William Grzybowski over 1 year ago

  • Status changed from Screened to Unscreened
  • Assignee changed from William Grzybowski to Vladimir Vinogradenko
  • Target version changed from 11.1 to 11.2-BETA1

Another one for you to look at Vladimir. This is also low priority for now though.

Thanks!

#10 Updated by Vladimir Vinogradenko over 1 year ago

  • Status changed from Unscreened to Screened

#11 Updated by Vladimir Vinogradenko over 1 year ago

  • Status changed from Screened to Needs Developer Review
  • Assignee changed from Vladimir Vinogradenko to William Grzybowski

#12 Updated by William Grzybowski about 1 year ago

  • Status changed from Needs Developer Review to Reviewed by Developer
  • Target version changed from 11.2-BETA1 to 11.1

LGTM

#13 Updated by Vladimir Vinogradenko about 1 year ago

  • Status changed from Reviewed by Developer to Ready For Release

#14 Updated by Dru Lavigne about 1 year ago

  • Subject changed from Time Machine Quotas (OSX Server Style) to Specify a quota per time machine backup
  • Target version changed from 11.1 to 11.1-BETA1

#15 Updated by Dru Lavigne about 1 year ago

  • Status changed from Ready For Release to Resolved

#16 Updated by Bonnie Follweiler about 1 year ago

  • QA Status Test Fails FreeNAS added
  • QA Status deleted (Not Tested)

We need to properly format the Time Machine Quota: We need to specify the value (ie, there is no GiB, etc) but the field only accepts numeric entries
The quota isn't functioning as described

#17 Updated by Bonnie Follweiler about 1 year ago

  • Status changed from Resolved to Unscreened

#18 Updated by William Grzybowski about 1 year ago

  • Assignee changed from William Grzybowski to Vladimir Vinogradenko

#19 Updated by Vladimir Vinogradenko about 1 year ago

  • Status changed from Unscreened to 15
  • Assignee changed from Vladimir Vinogradenko to William Grzybowski

William, how should I handle this? I have not found any ready-to-use solution in legacy UI. We may:

  • Ignore this (legacy UI is going to die)
  • Parse strings like 10 GiB and store them in existing integer field like 10000000000
  • Convert integer field to string and parse it in generate_afpd_conf.py

#20 Updated by William Grzybowski about 1 year ago

  • Status changed from 15 to Screened
  • Assignee changed from William Grzybowski to Vladimir Vinogradenko

I dont think we can ignore it, old UI is going to live for a while still and people may need it meanwhile.

I think the most user-friendly option is #2.

We could also change the field to be a string.

#21 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.1-BETA1 to 11.1

#22 Updated by William Grzybowski about 1 year ago

OTOH, we dont want parsed values in the database, so ignore that last phrase :)

#23 Updated by Vladimir Vinogradenko about 1 year ago

  • Status changed from Screened to Needs Developer Review
  • Assignee changed from Vladimir Vinogradenko to William Grzybowski

#

#24 Updated by Nick Wolff about 1 year ago

Bonnie, Did this end up functionally working? I know it wasn't taking formatted input but last time I looked at this with you it also wasn't registering with the mac at all as a quota for the time machine backup even though the files appeared to be correct. Were we just doing something wrong at the time or are there additional problems here that need looked at?

Thanks,

#25 Updated by William Grzybowski about 1 year ago

  • Tracker changed from Feature to Bug
  • Status changed from Needs Developer Review to Reviewed by Developer
  • Assignee changed from William Grzybowski to Vladimir Vinogradenko
  • Seen in set to 11.1-RC1
  • ChangeLog Required set to No
  • QA Status Not Tested added
  • QA Status deleted (Test Fails FreeNAS)

#26 Updated by Vladimir Vinogradenko about 1 year ago

  • Status changed from Reviewed by Developer to Ready For Release

#27 Updated by Bonnie Follweiler about 1 year ago

William and Vladimir
After reading through this ticket - I need clear up some confusion caused by my notes.
The test failed because the quota didn't limit the size of a Time Machine backup when tested on the Mac Mini.

There also was the issue that the field for entering the size was confusing since it wasn't formatted which I see you are already working on.

#28 Updated by Dru Lavigne about 1 year ago

  • Status changed from Ready For Release to Unscreened

#29 Updated by Vladimir Vinogradenko about 1 year ago

  • Status changed from Unscreened to 15
  • Assignee changed from Vladimir Vinogradenko to Bonnie Follweiler

I currently do not possess any Mac OS X devices, so I can't test whether this is working or not. I was only able to verify that needed .com.apple.TimeMachine.quota.plist file was created/updated/deleted in AFP share. I'll be able to fix this if you reproduce the case where file is not created or has invalid contents. Also, some helpful information may be extracted from OS X logs.

#30 Updated by Stuart Espey about 1 year ago

Vladimir Vinogradenko wrote:

I currently do not possess any Mac OS X devices, so I can't test whether this is working or not. I was only able to verify that needed .com.apple.TimeMachine.quota.plist file was created/updated/deleted in AFP share. I'll be able to fix this if you reproduce the case where file is not created or has invalid contents. Also, some helpful information may be extracted from OS X logs.

Apple updated the way timemachine writes its logs in Sierra, and also seems to have broken it, I go into it a little bit in this post:
https://forums.freenas.org/index.php?threads/how-to-set-up-time-machine-for-multiple-machines-with-osx-server-style-quotas.47173/#post-353739

Which links to a Stackoverflow post which has a number of methods to get around the timemachine logging bug in Sierra. I'm not currently sure on the status of High Sierra, but will be installing High Sierra today, and will check.

In my testing, the method documented originally works with Sierra. Will check with High Sierra later today... after my backup finishes!

#31 Updated by Stuart Espey about 1 year ago

So, on macos 10.12 Sierra, the following command will output the TM log

log show --style syslog  --predicate 'senderImagePath contains[cd] "TimeMachine"' --info

And this command will stream it, much like tail

log stream --style syslog  --predicate 'senderImagePath contains[cd] "TimeMachine"' --info

Doing that when my Time Machine backup is running to a FreeNAS AFP share, with the documented above quota method I see this

2017-11-15 11:27:07.946018+1100  localhost backupd[1817]: (TimeMachine) [com.apple.TimeMachine.TMLogInfo] Quota in effect for '/Volumes/Titan Time Machine': 4 TB (4,000,000,000,000 bytes)

Which is what I have the quote set to (via manually editing the files)

#32 Updated by Dru Lavigne about 1 year ago

  • Status changed from 15 to Screened
  • Assignee changed from Bonnie Follweiler to Vladimir Vinogradenko

#33 Updated by Vladimir Vinogradenko about 1 year ago

  • Status changed from Screened to 15
  • Assignee changed from Vladimir Vinogradenko to Bonnie Follweiler

Bonnie, did you have AFP service "Start on boot" checkbox checked?

If no, please check it and restart service/re-save AFP share, then try testing quota again.

If yes, then it's sadly not the issue, can you please use information above to check logs? Or reassign this to someone who has OS X devices.

#34 Updated by Bonnie Follweiler about 1 year ago

13117
13118

Ok AFP is running
Here is some output and screen shots for you to check. It is still backing up so, if more shows in the terminal I will report that and I will take a screenshot of how much data is in the backup dataset

#35 Updated by Vladimir Vinogradenko about 1 year ago

2017-11-21 00:07:19.214814-0500  localhost backupd[2257]: (TimeMachine) [com.apple.TimeMachine.TMLogInfo] Quota in effect for '/Volumes/tm_backup': 100 bytes
2017-11-21 01:07:25.233181-0500  localhost backupd[2347]: (TimeMachine) [com.apple.TimeMachine.TMLogInfo] Quota in effect for '/Volumes/tm_backup': 100 bytes
2017-11-21 02:17:25.588479-0500  localhost backupd[2432]: (TimeMachine) [com.apple.TimeMachine.TMLogInfo] Quota in effect for '/Volumes/tm_backup': 100 bytes
2017-11-21 03:07:24.636363-0500  localhost backupd[2517]: (TimeMachine) [com.apple.TimeMachine.TMLogInfo] Quota in effect for '/Volumes/tm_backup': 100 bytes
2017-11-21 04:07:26.783771-0500  localhost backupd[2632]: (TimeMachine) [com.apple.TimeMachine.TMLogInfo] Quota in effect for '/Volumes/tm_backup': 100 bytes
2017-11-21 05:07:27.714287-0500  localhost backupd[2719]: (TimeMachine) [com.apple.TimeMachine.TMLogInfo] Quota in effect for '/Volumes/tm_backup': 100 bytes
2017-11-21 06:11:19.640750-0500  localhost backupd[2808]: (TimeMachine) [com.apple.TimeMachine.TMLogInfo] Quota in effect for '/Volumes/tm_backup': 100 bytes
2017-11-21 07:15:42.901872-0500  localhost backupd[2895]: (TimeMachine) [com.apple.TimeMachine.TMLogInfo] Quota in effect for '/Volumes/tm_backup': 100 bytes
2017-11-21 08:07:03.846632-0500  localhost backupd[2975]: (TimeMachine) [com.apple.TimeMachine.TMLogInfo] Quota in effect for '/Volumes/tm_backup': 100 bytes
2017-11-21 09:07:16.718577-0500  localhost backupd[3137]: (TimeMachine) [com.apple.TimeMachine.TMLogInfo] Quota in effect for '/Volumes/tm_backup': 100 bytes
2017-11-21 09:11:25.400587-0500  localhost backupd[3137]: (TimeMachine) [com.apple.TimeMachine.TMLogInfo] Quota in effect for '/Volumes/tm_backup': 100 bytes
2017-11-21 09:41:45.063193-0500  localhost backupd[3411]: (TimeMachine) [com.apple.TimeMachine.TMLogInfo] Quota in effect for '/Volumes/tm_backup-1': 10 bytes

I don't know if it should be backing up, 10 bytes quota is enabled...

#36 Updated by Bonnie Follweiler about 1 year ago

  • Assignee changed from Bonnie Follweiler to Vladimir Vinogradenko

I reset the Quota and it didn't back up because the quota was less than the required amount for back up.
2017-11-21 10:46:49.460501-0500 localhost backupd3946: (TimeMachine) [com.apple.TimeMachine.TMLogInfo] Total content size: 448.3 MB excluded items size: 983 KB for volume Storage
2017-11-21 10:46:52.957667-0500 localhost backupd3946: (TimeMachine) [com.apple.TimeMachine.TMLogInfo] Total content size: 84.99 GB excluded items size: 8.83 GB for volume Macintosh HD
2017-11-21 10:46:52.958168-0500 localhost backupd3946: (TimeMachine) [com.apple.TimeMachine.TMLogInfo] Found 759362 files (76.61 GB) needing backup
2017-11-21 10:46:52.959079-0500 localhost backupd3946: (TimeMachine) [com.apple.TimeMachine.TMLogInfo] 91.93 GB required (including padding), 101.8 MB available
2017-11-21 10:46:52.967601-0500 localhost backupd3946: (TimeMachine) [com.apple.TimeMachine.TMLogError] Backup failed with error 7: Not enough available disk space on the target volume.
2017-11-21 10:46:53.794340-0500 localhost backupd3946: (TimeMachine) [com.apple.TimeMachine.TMLogInfo] Ejected Time Machine disk image: /Volumes/tm_backup/Bonnie’s Mac mini.sparsebundle
2017-11-21 10:46:54.137577-0500 localhost backupd3946: (TimeMachine) [com.apple.TimeMachine.TMLogInfo] Ejected Time Machine network volume.

#37 Updated by Bonnie Follweiler about 1 year ago

I reset the quota to less than needed for the full back up (100 MB) and Time Machine didn't back up at all.
2017-11-21 10:46:52.957667-0500 localhost backupd3946: (TimeMachine) [com.apple.TimeMachine.TMLogInfo] Total content size: 84.99 GB excluded items size: 8.83 GB for volume Macintosh HD
2017-11-21 10:46:52.958168-0500 localhost backupd3946: (TimeMachine) [com.apple.TimeMachine.TMLogInfo] Found 759362 files (76.61 GB) needing backup
2017-11-21 10:46:52.959079-0500 localhost backupd3946: (TimeMachine) [com.apple.TimeMachine.TMLogInfo] 91.93 GB required (including padding), 101.8 MB available
2017-11-21 10:46:52.967601-0500 localhost backupd3946: (TimeMachine) [com.apple.TimeMachine.TMLogError] Backup failed with error 7: Not enough available disk space on the target volume.
2017-11-21 10:46:53.794340-0500 localhost backupd3946: (TimeMachine) [com.apple.TimeMachine.TMLogInfo] Ejected Time Machine disk image: /Volumes/tm_backup/Bonnie’s Mac mini.sparsebundle
2017-11-21 10:46:54.137577-0500 localhost backupd3946: (TimeMachine) [com.apple.TimeMachine.TMLogInfo] Ejected Time Machine network volume.

resetting to 100 GIB and will let you know how that goes

#38 Updated by Bonnie Follweiler about 1 year ago

As discussed with Vladimir:
If the quota is less than the needed space to back up it will fail.
If the Quota is reset to accommodate the space required to back up then a volume remount is required to update the new Quota on the Mac
If the Quota is large enough to accommodate the back up it backs up using the Quota amount

The Quota field is still accepting only numeric values so the size is set in Bytes in FreeNAS-11.1-RC1

#39 Updated by Vladimir Vinogradenko about 1 year ago

  • Assignee changed from Vladimir Vinogradenko to William Grzybowski

If the quota is less than the needed space to back up it will fail.

I think, this is perfectly expected behavior.

If the Quota is reset to accommodate the space required to back up then a volume remount is required to update the new Quota on the Mac

Maybe we need to show some pop-up in GUI when quota is changed? Like «Quota changes will take effect only after volume remount or reboot»

We've also discovered that very small quota values (like 100 bytes) do not have any effect. Maybe we should discover what this threshold is and disallow setting quota to such values?

#40 Updated by William Grzybowski about 1 year ago

  • Status changed from 15 to Screened
  • Assignee changed from William Grzybowski to Vladimir Vinogradenko

Agreed on all points. If you dont think thats going to take too much time, lets do it!

#41 Updated by Stuart Espey about 1 year ago

William Grzybowski wrote:

Agreed on all points. If you dont think thats going to take too much time, lets do it!

As shown in the original screenshot, the OSX Server UI accepts input in GB only, thus limiting the minimum to 1GB.

I would suggest that implementing the quota in terms of GB in the UI would not be such a bad compromise. Obviously it still needs to be represented as bytes in the config file.

#42 Updated by Vladimir Vinogradenko about 1 year ago

  • Status changed from Screened to Needs Developer Review
  • Assignee changed from Vladimir Vinogradenko to William Grzybowski

#43 Updated by William Grzybowski about 1 year ago

  • Status changed from Needs Developer Review to Reviewed by Developer
  • Assignee changed from William Grzybowski to Vladimir Vinogradenko

#44 Updated by Vladimir Vinogradenko about 1 year ago

  • Status changed from Reviewed by Developer to Ready For Release

#45 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.1 to 11.1-RC2

#46 Updated by Dru Lavigne about 1 year ago

  • File deleted (com.apple.TimeMachine.quota.plist.tar.gz)

#47 Updated by Dru Lavigne about 1 year ago

  • File deleted (Terminal Time Machine Output)

#48 Updated by Bonnie Follweiler about 1 year ago

  • Needs QA changed from Yes to No
  • QA Status Test Passes FreeNAS added
  • QA Status deleted (Not Tested)

#49 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.1-RC2 to 11.1-RC3

#50 Updated by Dru Lavigne about 1 year ago

  • Status changed from Ready For Release to Resolved

#51 Updated by Harry Weppner 11 months ago

13724
13725

Hi,

I believe this issue may need to be re-opened as the calculation appears to assume MiB (not GiB). To configure 256 GiB I had to enter 262,144 to yield the correct generated value in the quota property list. Either the doc/tooltip are now out of sync (and should read MiB) or the conversion from GiB to bytes is incorrect.

Cheerio, Harry.

#52 Updated by Dru Lavigne 11 months ago

  • Status changed from Resolved to Unscreened
  • Target version changed from 11.1-RC3 to 11.1-U1

#53 Updated by Roger Hayter 11 months ago

I put '500' in the dialogue box and got "<integer>524288000</integer>" in the .plist file. Since my Mac interprets this as 537GB, I wonder if the format of the .plist file is an integer number of kB? If so, panic over.

#54 Updated by Harry Weppner 11 months ago

No, still treats it as bytes. I've only stumbled across this as my time machine backup attempt failed because the disk size was insufficient. When I chased down the root cause I came across this issue to report there's a bug.

#55 Updated by Vladimir Vinogradenko 11 months ago

  • Status changed from Unscreened to Needs Developer Review
  • Assignee changed from Vladimir Vinogradenko to William Grzybowski

Harry, you are right, conversion from GiB is incorrect (converts from MiB instead).

#56 Updated by William Grzybowski 11 months ago

  • Status changed from Needs Developer Review to Reviewed by Developer
  • Assignee changed from William Grzybowski to Vladimir Vinogradenko

#57 Updated by Dru Lavigne 11 months ago

  • Has duplicate Bug #27672: TimeMachine quota value is taken as MB, not GB added

#58 Updated by iXsystems Bot 11 months ago

Commit: d218e6875bbb844685d0861c1c15e3e74795745b
https://github.com/freenas/freenas/commit/d218e6875bbb844685d0861c1c15e3e74795745b
Author: themylogin <>
Date: 2018-01-08 (Mon, 08 Jan 2018)

Log Message:
-----------
fix(afp): Make AFP share TimeMachine quota to be specified in GiB instead of MiB

Ticket: #17875

#59 Avatar?id=14398&size=24x24 Updated by Kris Moore 11 months ago

  • Status changed from Reviewed by Developer to Ready For Release

#60 Updated by Dru Lavigne 11 months ago

  • Status changed from Ready For Release to Resolved

Also available in: Atom PDF