Project

General

Profile

Feature #18071

Add support for PMC Adaptec HBAs

Added by Josh Paetzel almost 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
Alexander Motin
Category:
OS
Target version:
Estimated time:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Screenshot_7.png (28.8 KB) Screenshot_7.png Freeze with FreeNAS-11-MASTER-201705120409 + PMC 1000-8i IT IGP, 05/12/2017 01:37 PM
11093

Associated revisions

Revision a95288b0 (diff)
Added by Alexander Motin over 4 years ago

Slightly update kernel configs to 11-STABLE GENERIC. This readds pmspcv(4) driver, adds NUMA and new PCI features. Ticket: #18071

Revision 21e130f7 (diff)
Added by Warren Block over 4 years ago

Mention support for pmspcv(4) Adaptec HBAs. Ticket: #18071

History

#1 Updated by Josh Paetzel almost 5 years ago

#XXX PCI ID conflicts with ahd(4) and mvs(4)
#device pmspcv # PMC-Sierra SAS/SATA Controller driver

Oh No!

#2 Updated by Josh Paetzel almost 5 years ago

  • Status changed from Fix In Progress to Investigation

#3 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 5 years ago

  • Target version changed from 9.10.1-U3 to 9.10.2

#4 Updated by Josh Paetzel over 4 years ago

What if we moved all three of these to modules, then at least you could use loader tunables to select what you wanted.

#5 Updated by Josh Paetzel over 4 years ago

  • Target version changed from 9.10.2 to 9.10.3

#6 Updated by Alexander Motin over 4 years ago

Moving mvs(4) to module may still probably surprise some people using it, even though the hardware is 3Gbps SATA at most. ahd(4) is parallel SCSI, so I doubt any FreeNAS user should really bother about either the driver or the conflict, especially since ahd(4) driver seems pas some exclusions especially for this conflict.

Actually looking on sources I can not find a conflict between mvs(4) and pms(4). So either I miss something obvious or the comment is not exactly correct.

#7 Updated by Josh Paetzel over 4 years ago

  • Status changed from Investigation to Unscreened
  • Assignee changed from Josh Paetzel to Kris Moore

#8 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Assignee changed from Kris Moore to Alexander Motin

#9 Updated by Alexander Motin over 4 years ago

  • Status changed from Unscreened to Screened

#10 Updated by Alexander Motin over 4 years ago

  • Status changed from Screened to 19

It seems conflict was caused by broken probe code and was fixed quite some time ago. Re-added the driver back to kernel.

#11 Updated by Alexander Motin over 4 years ago

  • Status changed from 19 to Resolved

#12 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Target version changed from 9.10.3 to 11.0

#13 Updated by Vaibhav Chauhan about 4 years ago

  • Target version changed from 11.0 to 11.0-RC

#14 Updated by IT IGP about 4 years ago

11093

I tried installing with FreeNAS-11-MASTER-201705120409 from USB on some Asus KGPE-D16 (Bios 3309). As soon as I have plugged in an Adaptec PMC 1000-8i (FW 2.50) during boot/installation it freezes after

run_interrupt_driven_hooks: still waiting after xx seconds for xpt_config" 
...
random:unblocking device.

Shouldn't the current snapshot I used already include the driver for this adapter?!
I also tried BIOS default settings with no change. Any setting I should watch out for in particular or might try?

#15 Updated by Dru Lavigne about 4 years ago

  • Status changed from Resolved to Unscreened

#16 Updated by Alexander Motin about 4 years ago

  • Status changed from Unscreened to Screened

Unfortunately I am not sure we can do much about it without having the respective hardware. The questions should be addressed to the driver authors. Generally such behavior usually mean that some HBA driver can not complete the device scan. You may try to disconnect all devices from it and see whether it boot after that.

#17 Updated by IT IGP about 4 years ago

Reply from Microsemi regarding my inquiry:

Currently, there is no plan to continue FreeBSD or Solaris support. It is possible the project manager may include FreeBSD drivers but given the additional test time and low demand it's not likely. You can check with the next update due late June or July but don't expect. No final decision is made but currently no further FreeBSD support is planned.

IMO this is a really nice adapter and its just sad there is no driver support, if anyone has some connections and help persuade them... ;)

#18 Updated by Alexander Motin about 4 years ago

  • Status changed from Screened to Resolved

That's a pity it is no longer officially supported. I can't do anything about it without the hardware, and I have no motivation to buy it. If somebody wish to donate me one, I could possibly look on it in my free time, though no guaranties.

Also available in: Atom PDF