Project

General

Profile

Bug #18137

[Regression] Update Broke AD

Added by Jeremy Robertson almost 4 years ago. Updated about 3 years ago.

Status:
Closed: Behaves correctly
Priority:
Important
Assignee:
Erin Clark
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

After being heckeled for a week about installing updates I finally did and after the updates installed freenas will no longer connect to Active Directory and I can't access the share.

History

#1 Updated by Jeremy Robertson almost 4 years ago

  • File debug-cobnas1-20161010090539.txz added

#2 Updated by Heather Ownby almost 4 years ago

  • Assignee set to Erin Clark

#3 Updated by Erin Clark almost 4 years ago

  • Status changed from Unscreened to Screened

#4 Updated by Erin Clark almost 4 years ago

What happens if you go to Kerberos Realms under Directory Service and delete the Realm for your domain and try to rejoin?

#5 Updated by Jeremy Robertson almost 4 years ago

Jeremy Robertson wrote:

After being heckeled for a week about installing updates I finally did and after the updates installed freenas will no longer connect to Active Directory and I can't access the share.

After I did as requested and removed the kurberos Realm and re-added back to AD I got an error that the service could not be started.

#6 Updated by Jeremy Robertson almost 4 years ago

I also get 2 alerts
WARNING: Oct. 11, 2016, 7:32 a.m. - ActiveDirectory did not bind to the domain
WARNING: Oct. 10, 2016, 8:58 a.m. - smartd is not running.

#7 Updated by Erin Clark almost 4 years ago

Did you make sure your clock was synchronized?

#8 Updated by Jeremy Robertson almost 4 years ago

Erin Clark wrote:

Did you make sure your clock was synchronized?

I checked and the time is synchronized with the rest of the domain

#9 Updated by Jeremy Robertson almost 4 years ago

This morning I am no longer getting the error that active directory did not bind, so I am unsure is AD is working now, but I am still unable to access the share.
when I browse to the freenas by name or IP I get windows cannot access.

#10 Updated by Erin Clark almost 4 years ago

Do the users appear now in either the drop down or in wbinfo -u? Also can you rebind if you boot into a known good boot environment?

#11 Updated by Jeremy Robertson almost 4 years ago

Erin Clark wrote:

Do the users appear now in either the drop down or in wbinfo -u? Also can you rebind if you boot into a known good boot environment?

I am not sure what you mean by users appearing in any drop down or in wbinfo -u.

I opened the shell and ran the command wbinfo -u and got nothing. I have not tried to boot into any other boot environment, since booting the system has not been the problem. I can try that.

#12 Updated by Jeremy Robertson almost 4 years ago

Jeremy Robertson wrote:

Erin Clark wrote:

Do the users appear now in either the drop down or in wbinfo -u? Also can you rebind if you boot into a known good boot environment?

I am not sure what you mean by users appearing in any drop down or in wbinfo -u.

I opened the shell and ran the command wbinfo -u and got nothing. I have not tried to boot into any other boot environment, since booting the system has not been the problem. I can try that.

The system works fine when booted to the previous boot environment.

#13 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 4 years ago

  • Priority changed from No priority to Important
  • Target version set to 9.10.2

#14 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 4 years ago

  • Subject changed from Update Broke AD to [Regression] Update Broke AD

#15 Updated by Erin Clark almost 4 years ago

alright well is there sometime in the near future we could do a teamviewer so I can see if I can figure out anything with this?

#16 Updated by Jeremy Robertson almost 4 years ago

Erin Clark wrote:

alright well is there sometime in the near future we could do a teamviewer so I can see if I can figure out anything with this?

Yes I can do this today just let me know when.

#17 Updated by Erin Clark almost 4 years ago

would you be available either nowish before 3:00 PDT or sometime after 4:30 PDT?

#18 Updated by Jeremy Robertson almost 4 years ago

Erin Clark wrote:

would you be available either nowish before 3:00 PDT or sometime after 4:30 PDT?

now is good

#19 Updated by Erin Clark almost 4 years ago

alright if you could email me your creds for teamviewer erin 'at' ixsystems.com I'll hop on and take a look

#20 Updated by Jeremy Robertson almost 4 years ago

Erin Clark wrote:

alright if you could email me your creds for teamviewer erin 'at' ixsystems.com I'll hop on and take a look

Email sent. Did you receive it?

#21 Updated by Erin Clark almost 4 years ago

I did and I just replied, need the correct password :)

#22 Updated by Erin Clark almost 4 years ago

  • Status changed from Screened to Closed: Behaves correctly

We booted the FreeNAS box into the new boot environment and AD decided to just work this time, must have just been some kind of unhappiness between FreeNAS and the AD server. Going to close the ticket for now, feel free to open a new ticket if you have any further issues.

#23 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Seen in changed from Unspecified to N/A

#24 Updated by Dru Lavigne about 3 years ago

  • File deleted (debug-cobnas1-20161010090539.txz)

#25 Updated by Dru Lavigne about 3 years ago

  • Target version changed from 9.10.2 to N/A
  • Private changed from Yes to No

Also available in: Atom PDF