Project

General

Profile

Bug #18228

Console Menu: System Update fails

Added by Steve Schultheis about 3 years ago. Updated about 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
No priority
Assignee:
Sean Fagan
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I just did a fresh installation to a USB stick from the FreeNAS-9.10.1-U2.iso. After booting the USB stick, I tried "System Update" (item 10) from the console menu, since I wanted to check for newer updates that weren't on the ISO before going any further. Some error messages were printed that scrolled off the screen before I could capture them, but I believe something complained about URLs that could not be found. So I launched the GUI and checked for updates; indeed there are updates available that are newer than the ISO.

Actually I'm not really sure what this menu option is supposed to do. The manual says "If any new updates are available, they are automatically be downloaded and applied. [sic]" It also says that "Updates are applied immediately for the currently selected train ..." although there is no menu option to select a train (perhaps I would have been prompted for one had the update continued.) I assume the appropriate 'stable' train would be the default, although I anticipate some might want to select a 'nightlies' train here instead.

History

#1 Updated by Bonnie Follweiler about 3 years ago

  • Assignee set to Sean Fagan

#2 Updated by Sean Fagan about 3 years ago

  • Status changed from Unscreened to Closed: Insufficient Info

Insufficient information.

But since you did a fresh installation and immediately tried to update, I'm going to guess you did not set up networking, or, well, anything.

Set the box up before doing an update.

#3 Updated by Steve Schultheis about 3 years ago

The default installation enables DHCP, so I get an IP address. I can launch a shell from the console menu and ping out to the world, so networking appears to be set up. What else is needed?

I did manage to snag the messages I get:

Oct 13 18:26:10 freenas netcli: [freenasOS.Update:1495] Could not open sequence file in cache directory /var/tmp/update: [Errno 2] No such file or directory:'/var/tmp/update/SEQUENCE'
Oct 13 18:26:11 freenas netcli: [freenasOS.configuration:652] Got http error HTTP Error 404: Not Found
Oct 13 18:26:11 freenas netcli: [freenasOS.configuration:652] Got http error HTTP Error 404: Not Found
Oct 13 18:26:11 freenas netcli: [freenasOS.configuration:669] Unable to load ['http://update.ixsystems.com/FreeNAS/None/ChangeLog.txt', 'http://update-master.ixsystems.com/FreeNAS/None/Changelog.txt']: HTTP Error 404: Not Found

FreeBSD/amd64 (freenas.local) (ttyv0)

#4 Updated by Sean Fagan about 3 years ago

  • Status changed from Closed: Insufficient Info to 15

Oh, well, that's special: http://update.ixsystems.com/FreeNAS/None/ChangeLog.txt

That should be the name of your train. Please do "manifest_util train", and/or get /data/manifest off the system and attached here.

#5 Updated by Steve Schultheis about 3 years ago

The output of 'manifest_util train' is:

FreeNAS-9.10-STABLE

The manifest file is:

{
    "BuildTime": "1475479821",
    "Packages": [
        {
            "Checksum": "1a027772465e66adae0e36f39219b914207a1a4d1e9b860df93f319
4800dccb7",
            "FileSize": 397387379,
            "Name": "base-os",
            "RequiresReboot": true,
            "Version": "9.10.1-U2-b4dd4ba2806e14bf8fc4ce58d78d22cf" 
        },
        {
            "Checksum": "e5861a59a88abbc0bf8bca1241b1ad3d02bc4bfb30ff6729a3fbe4b
0ebaea1d8",
            "FileSize": 8021370,
            "Name": "docs",
            "RequiresReboot": false,
            "Version": "9.10.1-U2-b4dd4ba2806e14bf8fc4ce58d78d22cf" 
        },
        {
            "Checksum": "9c06439d5f9d0481e10d20216fa54dea2666875179da91b0783eabe
e84cb4b2f",
            "FileSize": 4437650,
            "Name": "freebsd-pkgdb",
            "RequiresReboot": false,
            "Version": "9.10.1-U2-b4dd4ba2806e14bf8fc4ce58d78d22cf" 
        },
        {
            "Checksum": "835583eda47870f27e200f46044c3d7dc83340d855c11b241f2a4f41e902dd20",
            "FileSize": 62311,
            "Name": "freenas-pkg-tools",
            "RequiresReboot": false,
            "Version": "9.10.1-U2-b4dd4ba2806e14bf8fc4ce58d78d22cf" 
        },
        {
            "Checksum": "1916fda269e7503f626fb83290c58a4019b621831fc9a598176565a9f0f80d64",
            "FileSize": 5822458,
            "Name": "FreeNASUI",
            "RequiresReboot": false,
            "RestartServices": [
                "WebUI" 
            ],
            "Version": "9.10.1-U2-b4dd4ba2806e14bf8fc4ce58d78d22cf" 
        }
    ],
    "Sequence": "b4dd4ba2806e14bf8fc4ce58d78d22cf",
    "Train": "FreeNAS-9.10-STABLE",
    "Version": "FreeNAS-9.10.1-U2" 
}

#6 Updated by Sean Fagan about 3 years ago

Which means that shouldn't be happening -- the 'None' component in the URL it tried should have been 'FreeNAS-9.10-STABLE'.

#7 Updated by Vaibhav Chauhan about 3 years ago

  • Target version set to 9.10.2

BRB: any update on this item ?

#8 Updated by Sean Fagan about 3 years ago

Nope. I cannot reproduce this, or explain why it's happening. Note that the console menu has not received a great deal of attention.

Let's ask for one more thing that I apparently forgot to ask about:

In the shell, please run "freenas-update -v check" and include the output

#9 Updated by Steve Schultheis about 3 years ago

OK, I just installed 9.10.1-U4 to a fresh USB stick. Sorry, I don't have the -U2 ISO anymore, and I've since updated my -U2 system from the GUI. On my first run of "freenas-update -v check" using -U4 I got this:

Script started on Thu Nov 10 15:22:40 2016
[root@freenas] ~# freenas-update -v check [freenasOS.Configuration:635] TryGetNetworkFile([u'http://update-master.ixsystems.com/FreeNAS/FreeNAS-9.10-STABLE/LATEST'])
[freenasOS.Configuration:755] TryGetNetworkFile([u'http://update-master.ixsystems.com/FreeNAS/FreeNAS-9.10-STABLE/LATEST']):  Read 3828 bytes total
[freenasOS.Configuration:635] TryGetNetworkFile(['http://update-master.ixsystems.com/updates/ix_crl.pem'])
[freenasOS.Configuration:83] CheckFreeSpace(path=/tmp/tmpnnX91N.pem, pool=None, required=1028)
[freenasOS.Configuration:755] TryGetNetworkFile(['http://update-master.ixsystems.com/updates/ix_crl.pem']):  Read 1028 bytes total
[freenasOS.Manifest:448] Verify command = ['/usr/local/libexec/verify_signature', '-K', '/usr/local/share/certs/Production.pem', '-C', '/usr/local/share/certs/iX-CA.pem', '-S', u'KwATf0UJhVrQonQof5n8KJcOr5p5gUC7GmsjwAwdaMhMcZobrfKvmKWLcj1uisdJgFTBWk8fFkFXqNCAMUDi7Zcim9xYKbh7X4Wm4g9d/8o7xtr59HhfjWnHrqp4Nc5AIziUChh+XAptekwfSU7xTt4wZaMeScKs+IGR6GB39nQiq0gPQzNqiFjHeKjtg0mgtLl4GCEkK/wysuIgEWodLSUSUNh0W3FfdOZxSkJ2dbsRs9BxE6wH6kxDr9oNqiEkRm+rsUT6YG/7LV8bsPe5DGLW7ekFEaqm5BJxb+xNMhgsRSi4QZlWQxPVxMFN5r8/AbdLQ255Clem40et4WCBdA==', '-R', '/tmp/tmpnnX91N.pem']
[freenasOS.Manifest:464] Signature check succeeded
[freenasOS.Update:933] Going to try checking cached manifest /var/db/system/update/MANIFEST
[freenasOS.Update:957] Got this exception: [Errno 2] No such file or directory: '/var/db/system/update/MANIFEST'
[freenasOS.Configuration:635] TryGetNetworkFile([u'http://update.ixsystems.com/FreeNAS/Validators/ValidateUpdate-dAn5lU.txt', u'http://update-master.ixsystems.com/FreeNAS/Validators/ValidateUpdate-dAn5lU.txt'])
[freenasOS.Configuration:83] CheckFreeSpace(path=/var/db/system/update/ValidateUpdate, pool=None, required=187)
[freenasOS.Configuration:755] TryGetNetworkFile([u'http://update.ixsystems.com/FreeNAS/Validators/ValidateUpdate-dAn5lU.txt', u'http://update-master.ixsystems.com/FreeNAS/Validators/ValidateUpdate-dAn5lU.txt']):  Read 187 bytes total
[freenasOS.Update:995] DownloadUpdate:  diffs = {'Packages': [(<freenasOS.Package.Package object at 0x8098bf590>, 'upgrade', <freenasOS.Package.Package object at 0x8098bf390>), (<freenasOS.Package.Package object at 0x8098bf2d0>, 'upgrade', <freenasOS.Package.Package object at 0x8098bf4d0>)], 'Reboot': False}
[freenasOS.Update:1006] DownloadUpdate:  Will upgrade package docs
[freenasOS.Update:1006] DownloadUpdate:  Will upgrade package freenas-pkg-tools
[freenasOS.Update:1009]  not
[freenasOS.Configuration:1179] Searching for docs-9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075.tgz
[freenasOS.Configuration:635] TryGetNetworkFile([u'http://update.ixsystems.com/FreeNAS/Packages/docs-9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075.tgz', u'http://update-master.ixsystems.com/FreeNAS/Packages/docs-9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075.tgz'])
[freenasOS.Configuration:83] CheckFreeSpace(path=/var/db/system/update/docs-9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075.tgz, pool=None, required=8022804)
[freenasOS.Configuration:759] TryGetNetworkFile([u'http://update.ixsystems.com/FreeNAS/Packages/docs-9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075.tgz', u'http://update-master.ixsystems.com/FreeNAS/Packages/docs-9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075.tgz']):  Read 1048576 bytes
[freenasOS.Configuration:759] TryGetNetworkFile([u'http://update.ixsystems.com/FreeNAS/Packages/docs-9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075.tgz', u'http://update-master.ixsystems.com/FreeNAS/Packages/docs-9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075.tgz']):  Read 2097152 bytes
[freenasOS.Configuration:759] TryGetNetworkFile([u'http://update.ixsystems.com/FreeNAS/Packages/docs-9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075.tgz', u'http://update-master.ixsystems.com/FreeNAS/Packages/docs-9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075.tgz']):  Read 3145728 bytes
[freenasOS.Configuration:759] TryGetNetworkFile([u'http://update.ixsystems.com/FreeNAS/Packages/docs-9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075.tgz', u'http://update-master.ixsystems.com/FreeNAS/Packages/docs-9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075.tgz']):  Read 4194304 bytes
[freenasOS.Configuration:759] TryGetNetworkFile([u'http://update.ixsystems.com/FreeNAS/Packages/docs-9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075.tgz', u'http://update-master.ixsystems.com/FreeNAS/Packages/docs-9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075.tgz']):  Read 5242880 bytes
[freenasOS.Configuration:759] TryGetNetworkFile([u'http://update.ixsystems.com/FreeNAS/Packages/docs-9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075.tgz', u'http://update-master.ixsystems.com/FreeNAS/Packages/docs-9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075.tgz']):  Read 6291456 bytes
[freenasOS.Configuration:759] TryGetNetworkFile([u'http://update.ixsystems.com/FreeNAS/Packages/docs-9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075.tgz', u'http://update-master.ixsystems.com/FreeNAS/Packages/docs-9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075.tgz']):  Read 7340032 bytes
[freenasOS.Configuration:755] TryGetNetworkFile([u'http://update.ixsystems.com/FreeNAS/Packages/docs-9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075.tgz', u'http://update-master.ixsystems.com/FreeNAS/Packages/docs-9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075.tgz']):  Read 8022804 bytes total
[freenasOS.Configuration:1179] Searching for freenas-pkg-tools-9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075.tgz
[freenasOS.Configuration:635] TryGetNetworkFile([u'http://update.ixsystems.com/FreeNAS/Packages/freenas-pkg-tools-9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075.tgz', u'http://update-master.ixsystems.com/FreeNAS/Packages/freenas-pkg-tools-9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075.tgz'])
[freenasOS.Configuration:83] CheckFreeSpace(path=/var/db/system/update/freenas-pkg-tools-9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075.tgz, pool=None, required=63477)
[freenasOS.Configuration:755] TryGetNetworkFile([u'http://update.ixsystems.com/FreeNAS/Packages/freenas-pkg-tools-9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075.tgz', u'http://update-master.ixsystems.com/FreeNAS/Packages/freenas-pkg-tools-9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075.tgz']):  Read 63477 bytes total
[freenasOS.Configuration:635] TryGetNetworkFile([u'http://update.ixsystems.com/FreeNAS/FreeNAS-9.10-STABLE/ChangeLog.txt', u'http://update-master.ixsystems.com/FreeNAS/FreeNAS-9.10-STABLE/ChangeLog.txt'])
[freenasOS.Configuration:83] CheckFreeSpace(path=/var/db/system/update/ChangeLog.txt, pool=None, required=38946)
[freenasOS.Configuration:755] TryGetNetworkFile([u'http://update.ixsystems.com/FreeNAS/FreeNAS-9.10-STABLE/ChangeLog.txt', u'http://update-master.ixsystems.com/FreeNAS/FreeNAS-9.10-STABLE/ChangeLog.txt']):  Read 38946 bytes total
[freenasOS.Configuration:635] TryGetNetworkFile(['http://update-master.ixsystems.com/updates/ix_crl.pem'])
[freenasOS.Configuration:83] CheckFreeSpace(path=/tmp/tmpIEchhd.pem, pool=None, required=1028)
[freenasOS.Configuration:755] TryGetNetworkFile(['http://update-master.ixsystems.com/updates/ix_crl.pem']):  Read 1028 bytes total
[freenasOS.Manifest:448] Verify command = ['/usr/local/libexec/verify_signature', '-K', '/usr/local/share/certs/Production.pem', '-C', '/usr/local/share/certs/iX-CA.pem', '-S', u'KwATf0UJhVrQonQof5n8KJcOr5p5gUC7GmsjwAwdaMhMcZobrfKvmKWLcj1uisdJgFTBWk8fFkFXqNCAMUDi7Zcim9xYKbh7X4Wm4g9d/8o7xtr59HhfjWnHrqp4Nc5AIziUChh+XAptekwfSU7xTt4wZaMeScKs+IGR6GB39nQiq0gPQzNqiFjHeKjtg0mgtLl4GCEkK/wysuIgEWodLSUSUNh0W3FfdOZxSkJ2dbsRs9BxE6wH6kxDr9oNqiEkRm+rsUT6YG/7LV8bsPe5DGLW7ekFEaqm5BJxb+xNMhgsRSi4QZlWQxPVxMFN5r8/AbdLQ255Clem40et4WCBdA==', '-R', '/tmp/tmpIEchhd.pem']
[freenasOS.Manifest:464] Signature check succeeded
[freenasOS.Configuration:635] TryGetNetworkFile(['http://update-master.ixsystems.com/updates/ix_crl.pem'])
[freenasOS.Configuration:83] CheckFreeSpace(path=/tmp/tmpkanb94.pem, pool=None, required=1028)
[freenasOS.Configuration:755] TryGetNetworkFile(['http://update-master.ixsystems.com/updates/ix_crl.pem']):  Read 1028 bytes total
[freenasOS.Manifest:448] Verify command = ['/usr/local/libexec/verify_signature', '-K', '/usr/local/share/certs/Production.pem', '-C', '/usr/local/share/certs/iX-CA.pem', '-S', u'KwATf0UJhVrQonQof5n8KJcOr5p5gUC7GmsjwAwdaMhMcZobrfKvmKWLcj1uisdJgFTBWk8fFkFXqNCAMUDi7Zcim9xYKbh7X4Wm4g9d/8o7xtr59HhfjWnHrqp4Nc5AIziUChh+XAptekwfSU7xTt4wZaMeScKs+IGR6GB39nQiq0gPQzNqiFjHeKjtg0mgtLl4GCEkK/wysuIgEWodLSUSUNh0W3FfdOZxSkJ2dbsRs9BxE6wH6kxDr9oNqiEkRm+rsUT6YG/7LV8bsPe5DGLW7ekFEaqm5BJxb+xNMhgsRSi4QZlWQxPVxMFN5r8/AbdLQ255Clem40et4WCBdA==', '-R', '/tmp/tmpkanb94.pem']
[freenasOS.Manifest:464] Signature check succeeded
Upgrade package docs 9.10.1-U4-d61691852044f7425790380209f30ef9->9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075
Upgrade package freenas-pkg-tools 9.10.1-U4-d61691852044f7425790380209f30ef9->9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075
Reboot is (conditionally) required
[root@freenas] ~# ^Dexit

Script done on Thu Nov 10 15:23:16 2016

I don't know why there were "update" references to -U3, so I ran it again and got different results:

Script started on Thu Nov 10 15:26:46 2016
[root@freenas] ~# freenas-update -v check [freenasOS.Configuration:635] TryGetNetworkFile([u'http://update-master.ixsystems.com/FreeNAS/FreeNAS-9.10-STABLE/LATEST'])
[freenasOS.Configuration:755] TryGetNetworkFile([u'http://update-master.ixsystems.com/FreeNAS/FreeNAS-9.10-STABLE/LATEST']):  Read 3828 bytes total
[freenasOS.Configuration:635] TryGetNetworkFile(['http://update-master.ixsystems.com/updates/ix_crl.pem'])
[freenasOS.Configuration:83] CheckFreeSpace(path=/tmp/tmpdBmVdp.pem, pool=None, required=1028)
[freenasOS.Configuration:755] TryGetNetworkFile(['http://update-master.ixsystems.com/updates/ix_crl.pem']):  Read 1028 bytes total
[freenasOS.Manifest:448] Verify command = ['/usr/local/libexec/verify_signature', '-K', '/usr/local/share/certs/Production.pem', '-C', '/usr/local/share/certs/iX-CA.pem', '-S', u'KwATf0UJhVrQonQof5n8KJcOr5p5gUC7GmsjwAwdaMhMcZobrfKvmKWLcj1uisdJgFTBWk8fFkFXqNCAMUDi7Zcim9xYKbh7X4Wm4g9d/8o7xtr59HhfjWnHrqp4Nc5AIziUChh+XAptekwfSU7xTt4wZaMeScKs+IGR6GB39nQiq0gPQzNqiFjHeKjtg0mgtLl4GCEkK/wysuIgEWodLSUSUNh0W3FfdOZxSkJ2dbsRs9BxE6wH6kxDr9oNqiEkRm+rsUT6YG/7LV8bsPe5DGLW7ekFEaqm5BJxb+xNMhgsRSi4QZlWQxPVxMFN5r8/AbdLQ255Clem40et4WCBdA==', '-R', '/tmp/tmpdBmVdp.pem']
[freenasOS.Manifest:464] Signature check succeeded
[freenasOS.Configuration:635] TryGetNetworkFile(['http://update-master.ixsystems.com/updates/ix_crl.pem'])
[freenasOS.Configuration:83] CheckFreeSpace(path=/tmp/tmpHblOPB.pem, pool=None, required=1028)
[freenasOS.Configuration:755] TryGetNetworkFile(['http://update-master.ixsystems.com/updates/ix_crl.pem']):  Read 1028 bytes total
[freenasOS.Manifest:448] Verify command = ['/usr/local/libexec/verify_signature', '-K', '/usr/local/share/certs/Production.pem', '-C', '/usr/local/share/certs/iX-CA.pem', '-S', u'KwATf0UJhVrQonQof5n8KJcOr5p5gUC7GmsjwAwdaMhMcZobrfKvmKWLcj1uisdJgFTBWk8fFkFXqNCAMUDi7Zcim9xYKbh7X4Wm4g9d/8o7xtr59HhfjWnHrqp4Nc5AIziUChh+XAptekwfSU7xTt4wZaMeScKs+IGR6GB39nQiq0gPQzNqiFjHeKjtg0mgtLl4GCEkK/wysuIgEWodLSUSUNh0W3FfdOZxSkJ2dbsRs9BxE6wH6kxDr9oNqiEkRm+rsUT6YG/7LV8bsPe5DGLW7ekFEaqm5BJxb+xNMhgsRSi4QZlWQxPVxMFN5r8/AbdLQ255Clem40et4WCBdA==', '-R', '/tmp/tmpHblOPB.pem']
[freenasOS.Manifest:464] Signature check succeeded
[freenasOS.Configuration:635] TryGetNetworkFile(['http://update-master.ixsystems.com/updates/ix_crl.pem'])
[freenasOS.Configuration:83] CheckFreeSpace(path=/tmp/tmpw5TIRw.pem, pool=None, required=1028)
[freenasOS.Configuration:755] TryGetNetworkFile(['http://update-master.ixsystems.com/updates/ix_crl.pem']):  Read 1028 bytes total
[freenasOS.Manifest:448] Verify command = ['/usr/local/libexec/verify_signature', '-K', '/usr/local/share/certs/Production.pem', '-C', '/usr/local/share/certs/iX-CA.pem', '-S', u'KwATf0UJhVrQonQof5n8KJcOr5p5gUC7GmsjwAwdaMhMcZobrfKvmKWLcj1uisdJgFTBWk8fFkFXqNCAMUDi7Zcim9xYKbh7X4Wm4g9d/8o7xtr59HhfjWnHrqp4Nc5AIziUChh+XAptekwfSU7xTt4wZaMeScKs+IGR6GB39nQiq0gPQzNqiFjHeKjtg0mgtLl4GCEkK/wysuIgEWodLSUSUNh0W3FfdOZxSkJ2dbsRs9BxE6wH6kxDr9oNqiEkRm+rsUT6YG/7LV8bsPe5DGLW7ekFEaqm5BJxb+xNMhgsRSi4QZlWQxPVxMFN5r8/AbdLQ255Clem40et4WCBdA==', '-R', '/tmp/tmpw5TIRw.pem']
[freenasOS.Manifest:464] Signature check succeeded
[freenasOS.Update:910] DownloadUpdate:  Cache directory has latest manifest
[freenasOS.Configuration:635] TryGetNetworkFile(['http://update-master.ixsystems.com/updates/ix_crl.pem'])
[freenasOS.Configuration:83] CheckFreeSpace(path=/tmp/tmp0bKH1z.pem, pool=None, required=1028)
[freenasOS.Configuration:755] TryGetNetworkFile(['http://update-master.ixsystems.com/updates/ix_crl.pem']):  Read 1028 bytes total
[freenasOS.Manifest:448] Verify command = ['/usr/local/libexec/verify_signature', '-K', '/usr/local/share/certs/Production.pem', '-C', '/usr/local/share/certs/iX-CA.pem', '-S', u'KwATf0UJhVrQonQof5n8KJcOr5p5gUC7GmsjwAwdaMhMcZobrfKvmKWLcj1uisdJgFTBWk8fFkFXqNCAMUDi7Zcim9xYKbh7X4Wm4g9d/8o7xtr59HhfjWnHrqp4Nc5AIziUChh+XAptekwfSU7xTt4wZaMeScKs+IGR6GB39nQiq0gPQzNqiFjHeKjtg0mgtLl4GCEkK/wysuIgEWodLSUSUNh0W3FfdOZxSkJ2dbsRs9BxE6wH6kxDr9oNqiEkRm+rsUT6YG/7LV8bsPe5DGLW7ekFEaqm5BJxb+xNMhgsRSi4QZlWQxPVxMFN5r8/AbdLQ255Clem40et4WCBdA==', '-R', '/tmp/tmp0bKH1z.pem']
[freenasOS.Manifest:464] Signature check succeeded
[freenasOS.Configuration:635] TryGetNetworkFile(['http://update-master.ixsystems.com/updates/ix_crl.pem'])
[freenasOS.Configuration:83] CheckFreeSpace(path=/tmp/tmpnEx7GI.pem, pool=None, required=1028)
[freenasOS.Configuration:755] TryGetNetworkFile(['http://update-master.ixsystems.com/updates/ix_crl.pem']):  Read 1028 bytes total
[freenasOS.Manifest:448] Verify command = ['/usr/local/libexec/verify_signature', '-K', '/usr/local/share/certs/Production.pem', '-C', '/usr/local/share/certs/iX-CA.pem', '-S', u'KwATf0UJhVrQonQof5n8KJcOr5p5gUC7GmsjwAwdaMhMcZobrfKvmKWLcj1uisdJgFTBWk8fFkFXqNCAMUDi7Zcim9xYKbh7X4Wm4g9d/8o7xtr59HhfjWnHrqp4Nc5AIziUChh+XAptekwfSU7xTt4wZaMeScKs+IGR6GB39nQiq0gPQzNqiFjHeKjtg0mgtLl4GCEkK/wysuIgEWodLSUSUNh0W3FfdOZxSkJ2dbsRs9BxE6wH6kxDr9oNqiEkRm+rsUT6YG/7LV8bsPe5DGLW7ekFEaqm5BJxb+xNMhgsRSi4QZlWQxPVxMFN5r8/AbdLQ255Clem40et4WCBdA==', '-R', '/tmp/tmpnEx7GI.pem']
[freenasOS.Manifest:464] Signature check succeeded
Upgrade package docs 9.10.1-U4-d61691852044f7425790380209f30ef9->9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075
Upgrade package freenas-pkg-tools 9.10.1-U4-d61691852044f7425790380209f30ef9->9.10.1-U3-8b3f08f46416c0be9315277f6fb8f075
Reboot is (conditionally) required
[root@freenas] ~# ^Dexit

Script done on Thu Nov 10 15:26:59 2016

When I tried to update from the menu (option 10) I got some sort of error or message the first time, but was unable to capture it. On subsequent tries I didn't see the message flash by- I just returned to the menu. I assume this is expected since there shouldn't be any updates to -U4 yet.

#10 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

Sean - He replied with the info, anything else to glean from this, or close it out?

#11 Updated by Sean Fagan about 3 years ago

  • Status changed from 15 to Screened

I still have no idea how it would be happening. As I said, it didn't when I tried it.

#12 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Status changed from Screened to Closed: Cannot reproduce

Afirm - Marking it as Cannot Reproduce then

Also available in: Atom PDF