Project

General

Profile

Bug #18455

dhcpd fails to get ip address after applying U2 changes and rebooting

Added by Rudi Pittman almost 4 years ago. Updated over 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
Nice to have
Assignee:
William Grzybowski
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Codegen Server 9011-C10 ATX case with power supply. [ http://www.pc-experience.de/wbb2/thread.php?threadid=18342 ]
GIGABYTE GA-Z87-DS3H LGA 1150 Intel Z87 HDMI SATA 6Gb/s USB 3.0 ATX Intel Motherboard
LGA3220T cpu
Ballistix Tactical 16GB Kit 8GBx2 DDR3 1600 MT/s PC3-12800 CL8 at 1.5V UDIMM 240-Pin Memory BLT2KIT8G3D1608DT1TX0
G.Skill F3-1600C9D-16GAR Ares 16GB (2x8GB) DDR3-1600Mhz Memory RAM
SYBA SI-PEX40064 PCI-Express 2.0 Low Profile Ready SATA III (6.0 Gb/s) Controller Card
SYBA SI-PEX40094 PCI Express Low Profile Ready SATA SATA III 2 Internal 6Gbps Ports PCI-e Controller Card
4 x Seagate ST5000DM000-1FK178 (5TB)
2 x TOSHIBA MD04ACA500 (5TB)
16 GB Flashdrive
1 x iStarUSA BPN-DE110SS-BLUE Trayless 5.25" to 3.5" SATA SAS 6 Gbps HDD Hot-swap Rack
2 x iStarUSA BPN-DE340SS-BLACK 3 x 5.25" to 4 x 3.5" SAS / SATA 6.0 Gb/s Trayless Hot-Swap Cage - Black Handle - OEM

LSPCI shows:
00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06)
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 05)
00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d5)
00:1c.2 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 (rev d5)
00:1c.3 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d5)
00:1c.4 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #5 (rev d5)
00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation Z87 Express LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] (rev 05)
00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 05)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
03:00.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 41)
05:00.0 SATA controller: Marvell Technology Group Ltd. Device 9215 (rev 11)

ChangeLog Required:
No

Description

I posted about this issue here: https://forums.freenas.org/index.php?threads/update-to-u2-no-ip-for-dhcpd.46972

I'll attempt to recap. My freenas server has been running for a little over 10 months now. In the most recent U1 changes I received a warning because I already had a media user. I reverted back to 9.10.1 and reported the bug. The fix for that issue was rolled out in U2. Upon rebooting today into U2 dhcpd failed to get an ip address. A few reboots failed to resolve the issue so I rolled back to 9.10.1 again and it worked as expected.

I'll attempt to recap from the posted thread.

My server specs are:
Codegen Server 9011-C10 ATX case with power supply. [ http://www.pc-experience.de/wbb2/thread.php?threadid=18342 ]
GIGABYTE GA-Z87-DS3H LGA 1150 Intel Z87 HDMI SATA 6Gb/s USB 3.0 ATX Intel Motherboard
LGA3220T cpu
Ballistix Tactical 16GB Kit 8GBx2 DDR3 1600 MT/s PC3-12800 CL8 at 1.5V UDIMM 240-Pin Memory BLT2KIT8G3D1608DT1TX0
G.Skill F3-1600C9D-16GAR Ares 16GB (2x8GB) DDR3-1600Mhz Memory RAM
SYBA SI-PEX40064 PCI-Express 2.0 Low Profile Ready SATA III (6.0 Gb/s) Controller Card
SYBA SI-PEX40094 PCI Express Low Profile Ready SATA SATA III 2 Internal 6Gbps Ports PCI-e Controller Card
4 x Seagate ST5000DM000-1FK178 (5TB)
2 x TOSHIBA MD04ACA500 (5TB)
16 GB Flashdrive
1 x iStarUSA BPN-DE110SS-BLUE Trayless 5.25" to 3.5" SATA SAS 6 Gbps HDD Hot-swap Rack
2 x iStarUSA BPN-DE340SS-BLACK 3 x 5.25" to 4 x 3.5" SAS / SATA 6.0 Gb/s Trayless Hot-Swap Cage - Black Handle - OEM

LSPCI shows:
00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06)
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 05)
00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d5)
00:1c.2 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 (rev d5)
00:1c.3 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d5)
00:1c.4 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #5 (rev d5)
00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation Z87 Express LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] (rev 05)
00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 05)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
03:00.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 41)
05:00.0 SATA controller: Marvell Technology Group Ltd. Device 9215 (rev 11)

The log for 10/22 is available at http://pastebin.com/AjQ4eLqE and I've attached it here in zip format. Starting at "Oct 22 03:31:48" I note some mDNSResponder errors that may or may not be relevant.

The u2 changelog (https://download.freenas.org/9.10/STABLE/9.10.1-U2/ChangeLog) lists nothing appearing related to lan at least at first glance.

#17908 Bug Ready For Release Expected EFI install fails with complaint about more than one boot device
#17904 Bug Ready For Release Expected Failed to report when snapshot failed to create
#17869 Bug Ready For Release Critical Virtualbox cannot run any VMachine after upgrade to 9.10.1-U1
#17826 Bug Ready For Release Critical Errors reported during replication
#17819 Bug Ready For Release Critical iSCSI LUN ID's all set to 0
#17809 Bug Ready For Release Important GRUB needs modules specified for improved reliability
#17789 Bug Ready For Release Critical Bug from latest updates for 9.10.1 on 09/27/2016
#17787 Bug Ready For Release Expected OpenSSL Fix Use After Free for large message sizes (CVE-2016-6309)

History

#1 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 4 years ago

  • Assignee set to Suraj Ravichandran
  • Priority changed from No priority to Nice to have
  • Target version set to 9.10.2

#2 Updated by Suraj Ravichandran almost 4 years ago

  • Status changed from Unscreened to Closed: Cannot reproduce

None of us can reproduce this issue.

I am sorry but I have to close this as cannot reproduce.

Also, nothing in the direct network stack was altered for U2 so I am at a loss for why you are seeing this.

#3 Updated by Suraj Ravichandran almost 4 years ago

  • Status changed from Closed: Cannot reproduce to Screened
  • Assignee changed from Suraj Ravichandran to William Grzybowski

William has some questions he would like to ask the user on this ticket, so re-opening.

#4 Updated by William Grzybowski almost 4 years ago

  • Status changed from Screened to 15

I am having trouble with what you said.

Logs says re0 got address:

Oct 22 04:44:30 freenas kernel: re0: link state changed to UP
Oct 22 04:44:37 freenas dhclient: New IP Address (re0): 192.168.3.116
Oct 22 04:44:37 freenas dhclient: New Subnet Mask (re0): 255.255.255.0
Oct 22 04:44:37 freenas dhclient: New Broadcast Address (re0): 192.168.3.255
Oct 22 04:44:37 freenas dhclient: New Routers (re0): 192.168.3.1

So how can say it did not get an IP?

Can you paste output of "dmesg -a" and "ifconfig -a" ?

#5 Updated by William Grzybowski almost 4 years ago

Ping

#6 Updated by Rudi Pittman almost 4 years ago

William Grzybowski wrote:

Ping

Sorry I missed the initial message. I ordered a different network card (HP that uses an intel chipset) in case it was related to the Realtek chipset of the built in network card. It just came today. I'll be dropping that in this evening then will attempt to boot U2 using both network ports.

The ip address I received at at 04:44 was when I went into the boot menu and selected 9.10.1 instead of 9.10.1 U2.

#7 Updated by William Grzybowski almost 4 years ago

Rudi Pittman wrote:

William Grzybowski wrote:

Ping

Sorry I missed the initial message. I ordered a different network card (HP that uses an intel chipset) in case it was related to the Realtek chipset of the built in network card. It just came today. I'll be dropping that in this evening then will attempt to boot U2 using both network ports.

The ip address I received at at 04:44 was when I went into the boot menu and selected 9.10.1 instead of 9.10.1 U2.

There are several messages about it getting IP, and not saying otherwise.
Can you get logs where it is not working? Also output of "dhclient re0" ?

#8 Updated by Rudi Pittman almost 4 years ago

  • File log.txt added

William Grzybowski wrote:

Rudi Pittman wrote:

William Grzybowski wrote:

Ping

Sorry I missed the initial message. I ordered a different network card (HP that uses an intel chipset) in case it was related to the Realtek chipset of the built in network card. It just came today. I'll be dropping that in this evening then will attempt to boot U2 using both network ports.

The ip address I received at at 04:44 was when I went into the boot menu and selected 9.10.1 instead of 9.10.1 U2.

There are several messages about it getting IP, and not saying otherwise.
Can you get logs where it is not working? Also output of "dhclient re0" ?

Attached is a log where I did the following..I hit ctrl alt del on the main keyboard causing a shutdown..upon reboot I let it boot up under U2 all the way to the options menu but could not actually select an option as it kept saying something about it restarting to fast then sleeping for 30 seconds....I shut it down again via ctrl-alt-del and let it boot back up under 9.10.1

#9 Updated by Rudi Pittman almost 4 years ago

The failed boot isn't in the messages...you'll note the time gap between when I shutdown and when it booted up.....that was on the "failed boot".

Oct 26 18:19:17 freenas syslog-ng49379: syslog-ng shutting down; version='3.6.4'
Oct 26 19:03:01 freenas syslog-ng1472: syslog-ng starting up; version='3.6.4'

You tell me how to get you the messages from the failed boot and I'll upload them.

#10 Updated by William Grzybowski almost 4 years ago

Can't you manually configure the IP and grab them on that boot?

#11 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 4 years ago

  • Target version changed from 9.10.2 to 9.10.2-U1

#12 Updated by Rudi Pittman almost 4 years ago

William Grzybowski wrote:

Can't you manually configure the IP and grab them on that boot?

I ended up fixing this issue by creating a fresh boot usb and uploading the config to it after booting. Obviously the update to U1 or U2 hosed something. In any case fresh boot media resolved things and I'll be sure to have a backup usb drive handy in future whenever doing updates.

#13 Updated by William Grzybowski almost 4 years ago

  • Status changed from 15 to Closed: Cannot reproduce

#14 Updated by Suraj Ravichandran almost 4 years ago

  • Related to Bug #18826: Jails not restarting after update 10/08/16 added

#15 Updated by Suraj Ravichandran almost 4 years ago

  • Status changed from Closed: Cannot reproduce to Closed: Duplicate
  • Assignee changed from William Grzybowski to Suraj Ravichandran

William Grzybowski I a couple of issues exhibiting this behaviour and am marking this as a duplicate of the same

#16 Updated by Suraj Ravichandran almost 4 years ago

  • Status changed from Closed: Duplicate to Closed: Cannot reproduce
  • Assignee changed from Suraj Ravichandran to William Grzybowski

Err that was a total brainfart on my side (this is the host dhcpd and not the jail one!!!) setting back as cannot repro.

#17 Updated by Suraj Ravichandran almost 4 years ago

  • Related to deleted (Bug #18826: Jails not restarting after update 10/08/16)

#18 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Target version changed from 9.10.2-U1 to N/A

#19 Updated by Dru Lavigne almost 3 years ago

  • File deleted (log.zip)

#20 Updated by Dru Lavigne almost 3 years ago

  • File deleted (log.txt)

Also available in: Atom PDF