Project

General

Profile

Bug #18468

Avatar?id=14398&size=22x22

vmware sync does not work when VMs have VMDKs attached from different datastores

Added by Reqlez Guy almost 4 years ago. Updated over 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
Important
Assignee:
Kris Moore
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hello.

So i had vmware sync working fine with my snapshots ... but then, i decided that I need to add a temporary files VMDK datastore to place page file and other temp files that i dont want snapshotted or replicated, and I added it to a few VMs and set it as "independent-persistent" disks so that snapshots don't affect those disks.

This is what I get now when i try to do a vmware aware snapshot ( and in vmware logs I see a bunch of "find virtual machine by datastore path" but no snapshots happening and frreenas doesnt create a snapshot either and there is no error message via email about snapshot failing ):

Request Method: POST
Request URL: http://10.0.0.8/storage/snapshot/create/zroot01/nfsds01/
Software Version: FreeNAS-9.10.1-U2 (f045a8b)
Exception Type: KeyError
Exception Value:
2001
Exception Location: /usr/local/lib/python2.7/site-packages/pysphere/vi_virtual_machine.py in update_disks, line 1773
Server time: Sun, 23 Oct 2016 12:07:07 -0600
Traceback

Environment:

Software Version: FreeNAS-9.10.1-U2 (f045a8b)
Request Method: POST
Request URL: http://10.0.0.8/storage/snapshot/create/zroot01/nfsds01/

Traceback:
File "/usr/local/lib/python2.7/site-packages/django/core/handlers/base.py" in get_response
105. response = middleware_method(request, callback, callback_args, callback_kwargs)
File "/usr/local/www/freenasUI/../freenasUI/freeadmin/middleware.py" in process_view
156. return login_required(view_func)(request, *view_args, **view_kwargs)
File "/usr/local/lib/python2.7/site-packages/django/contrib/auth/decorators.py" in wrapped_view
22. return view_func(request, *args, **kwargs)
File "/usr/local/www/freenasUI/../freenasUI/storage/views.py" in manualsnap
754. form.commit(fs)
File "/usr/local/www/freenasUI/../freenasUI/storage/forms.py" in commit
1793. vm1 = server.get_vm_by_path(vm)
File "/usr/local/lib/python2.7/site-packages/pysphere/vi_server.py" in get_vm_by_path
286. return VIVirtualMachine(self, vm)
File "/usr/local/lib/python2.7/site-packages/pysphere/vi_virtual_machine.py" in init
55. self.
_update_properties()
File "/usr/local/lib/python2.7/site-packages/pysphere/vi_virtual_machine.py" in __update_properties
1845. update_disks(self.properties.layoutEx.disk)
File "/usr/local/lib/python2.7/site-packages/pysphere/vi_virtual_machine.py" in update_disks
1773. dev = self._devices[disk.key]

Exception Type: KeyError at /storage/snapshot/create/zroot01/nfsds01/
Exception Value: 2001

Request information

GET

No GET data
POST

Variable Value
vmwaresync u'on'
form_id u'form_ManualSnapshotForm'
ms_name u'manual-20161023'
__all
u''
FILES

No FILES data
COOKIES

Variable Value
sessionid 'pvxk4mltqty8bvyw57mmi7gzqw6xibde'
csrftoken 'Gj8gyAtsI0x6tbpX3RJ5HxXRd1m65mTY'
fntreeSaveStateCookie 'root%2Croot%2F9%2Croot%2F23%2Croot%2F23%2F27%2Croot%2F9%2F16%2Croot%2F53%2Croot%2F53%2F54%2Croot%2F106%2Croot%2F106%2F110'
META

Variable Value
CONTENT_LENGTH '80'
HTTP_X_CSRFTOKEN 'Gj8gyAtsI0x6tbpX3RJ5HxXRd1m65mTY'
wsgi.url_scheme 'http'
HTTP_ORIGIN 'http://10.0.0.8'
PATH_INFO u'/storage/snapshot/create/zroot01/nfsds01/'
HTTP_ACCEPT_LANGUAGE 'en-US,en;q=0.8'
HTTP_REFERER 'http://10.0.0.8/'
REDIRECT_STATUS '200'
wsgi.input <flup.server.fcgi_base.InputStream object at 0x815efe4d0>
DOCUMENT_URI '/storage/snapshot/create/zroot01/nfsds01/'
SERVER_PROTOCOL 'HTTP/1.1'
HTTPS ''
REQUEST_URI '/storage/snapshot/create/zroot01/nfsds01/'
CONTENT_TYPE 'application/x-www-form-urlencoded'
HTTP_USER_AGENT 'Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.71 Safari/537.36'
GATEWAY_INTERFACE 'CGI/1.1'
SERVER_NAME 'localhost'
HTTP_CONNECTION 'keep-alive'
wsgi.multiprocess False
wsgi.run_once False
SERVER_PORT '80'
REMOTE_ADDR '172.31.1.6'
QUERY_STRING ''
SERVER_ADDR '10.0.0.8'
HTTP_CONTENT_TYPE 'application/x-www-form-urlencoded'
HTTP_ACCEPT '*/*'
REMOTE_PORT '64486'
HTTP_X_REQUESTED_WITH 'XMLHttpRequest'
wsgi.version (1, 0)
wsgi.errors <flup.server.fcgi_base.TeeOutputStream object at 0x815efeed0>
SCRIPT_NAME u''
SERVER_SOFTWARE 'nginx/1.8.1'
REQUEST_METHOD 'POST'
wsgi.multithread True
HTTP_CONTENT_LENGTH '80'
HTTP_COOKIE 'sessionid=pvxk4mltqty8bvyw57mmi7gzqw6xibde; fntreeSaveStateCookie=root%2Croot%2F9%2Croot%2F23%2Croot%2F23%2F27%2Croot%2F9%2F16%2Croot%2F53%2Croot%2F53%2F54%2Croot%2F106%2Croot%2F106%2F110; csrftoken=Gj8gyAtsI0x6tbpX3RJ5HxXRd1m65mTY'
HTTP_HOST '10.0.0.8'
DOCUMENT_ROOT '/usr/local/etc/nginx/html'
HTTP_ACCEPT_ENCODING 'gzip, deflate'
CSRF_COOKIE u'Gj8gyAtsI0x6tbpX3RJ5HxXRd1m65mTY'

History

#1 Updated by Josh Paetzel almost 4 years ago

  • Status changed from Unscreened to Screened
  • Assignee set to Josh Paetzel
  • Priority changed from No priority to Important
  • Target version set to 9.10.1-U3

Ok, let me see if I can get this reprod with a fix in the next release.

#2 Updated by Reqlez Guy almost 4 years ago

Josh Paetzel wrote:

Ok, let me see if I can get this reprod with a fix in the next release.

Thanks for quick reply.

if you need additional information or help on how to reproduce this isssue and how I have the VMs configured ( or any log collection ) let me know as I am very available to help fix this issue as it is pretty important to have app level snapshots.

#3 Updated by Dru Lavigne almost 4 years ago

Will this make it into U3?

#4 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 4 years ago

  • Target version changed from 9.10.1-U3 to 9.10.2

#5 Updated by Josh Paetzel almost 4 years ago

  • Target version changed from 9.10.2 to 9.10.2-U1

#6 Updated by Reqlez Guy almost 4 years ago

I saw there was some modification to the snapshot script regarding snapshotting the root. I'm assuming that this was not fixed in that ticket. How is this going ? Have you been able to reproduce ? you can also remote into my system and see for yourself if that makes it easier.

#7 Updated by Reqlez Guy almost 4 years ago

So guess what ?

I did some maintenance today, updated the version to 9.10-U4

The only other thing i did was that I added ALL datastores even the one i'm not snapshotting ( the temp file one ) to the vmware sync screen ... and all of a sudden the snapshots with vmware sync are working now !!! THe problem is now i dont know what fixed it, U4 or me adding the temporary datastore to the vmware sync list... But I guess you could play around if you have time... the bug was definetly there, just hard to say what exactly triggers it now, I can only assume that all datastores have to be present in vmware sync options.

#8 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Target version changed from 9.10.2-U1 to 9.10.2-U2

#9 Updated by Josh Paetzel over 3 years ago

  • Status changed from Screened to Unscreened
  • Assignee changed from Josh Paetzel to Kris Moore

#10 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Status changed from Unscreened to Closed: Cannot reproduce

#11 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Target version changed from 9.10.2-U2 to N/A

Also available in: Atom PDF