Project

General

Profile

Bug #18742

IPv4 DHCP unselectable when creating new jail in 9.10-U2

Added by Alex Bodal about 3 years ago. Updated about 3 years ago.

Status:
Closed: Duplicate
Priority:
Important
Assignee:
William Grzybowski
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When creating a new jail via GUI (Jails -> Add Jail -> Advanced Mode), the option to select "IPv4 DHCP" cannot be selected.

I checked my javascript console and noticed this message:

VM709:201 Uncaught TypeError: Cannot read property 'parentNode' of null
at selectionCheck (eval at _functionFromScript (https://*ip redacted*/dojango/dojo-media/release/1.11.1/dojo/parser.js?7a70313fd57ae1018756e1e72e017bc9:60:8), <anonymous>:201:58)
at eval (eval at _functionFromScript (https://*ip redacted*/dojango/dojo-media/release/1.11.1/dojo/parser.js?7a70313fd57ae1018756e1e72e017bc9:60:8), <anonymous>:166:9)

VM709:201 showed this (surrounding lines included)

// Disable actionsPane if there are no selected rows
var actpane = query(".actionsPane", cpane.domNode.parentNode)[0];
var border = registry.getEnclosingWidget(actpane.parentNode.parentNode);
if(numselected > 0) {
domStyle.set(actpane.parentNode, "display", "block");
} else {
domStyle.set(actpane.parentNode, "display", "none");
}
border.layout();
};

The specific line reported as an error was:

var actpane = query(".actionsPane", cpane.domNode.parentNode)[0];

VM752:166 came up with (surrounding text included):

grid.on("dgrid-refresh-complete", function(evt) {
setTimeout(function() {
var selected = [];
var rows = [];
for(var id in grid.selection){
selected.push(id);
rows.push(grid.row(id));
}
grid.refresh();
grid.clearSelection();
for(var id in selected) {
grid.select(selected[id]);
}
selectionCheck({rows: rows, grid: grid});
}, 12000);
});

The specific line referenced was:

selectionCheck({rows: rows, grid: grid});

I've attached a copy of my parser.js referenced above, has not been edited from base install

Screenshot 2016-11-06 17.25.23.png (614 KB) Screenshot 2016-11-06 17.25.23.png Debug output of freeadmin.js Alex Bodal, 11/06/2016 05:25 PM
7655

Related issues

Has duplicate FreeNAS - Bug #17016: 9.10.1-U2 Jail Cannot Have DHCP SelectedResolved2016-08-25

History

#1 Updated by Alex Bodal about 3 years ago

  • File debug-jzgdev-20161105172811.txz added

#2 Updated by Alex Bodal about 3 years ago

  • File parser.js added

#3 Updated by Alex Bodal about 3 years ago

  • Seen in changed from Unspecified to 9.10.1-U2

#4 Updated by Alex Bodal about 3 years ago

  • Category changed from 38 to 2

#5 Updated by Alex Bodal about 3 years ago

  • Category changed from 2 to 38

#6 Updated by Alex Bodal about 3 years ago

  • Category changed from 38 to 2

#7 Updated by Alex Bodal about 3 years ago

  • Private changed from Yes to No

#8 Updated by Alex Bodal about 3 years ago

  • File Screenshot 2016-11-06 17.06.56.png added

#9 Updated by Alex Bodal about 3 years ago

  • File deleted (Screenshot 2016-11-06 17.06.56.png)

#10 Updated by Alex Bodal about 3 years ago

7655

I traced the error back to what I believe is it's source by step debugging the onClick event. I've included the debug output of freeadmin.js (un-minified) in the screenshot included.

I tested out deleting the portion

        if (!jail_ipv4_is_dhcp) {
            jail_ipv4_dhcp = "off";
            ipv4_dhcp.set("checked", false);
        }


Because it seems redundant/a bit unnecessary and seems to be causing the issue and everything works as intended.

This isn't perhaps the best solution, but I thought I'd include this additional research I've done to help pinpoint the issue.

#11 Updated by Heather Ownby about 3 years ago

  • Assignee set to William Grzybowski

#12 Updated by William Grzybowski about 3 years ago

  • Status changed from Unscreened to Screened
  • Priority changed from No priority to Nice to have
  • Target version set to 9.10.2

#13 Updated by William Grzybowski about 3 years ago

  • Priority changed from Nice to have to Important

#14 Updated by William Grzybowski about 3 years ago

  • Status changed from Screened to Closed: Duplicate

#15 Updated by William Grzybowski about 3 years ago

  • Has duplicate Bug #17016: 9.10.1-U2 Jail Cannot Have DHCP Selected added

#16 Updated by Dru Lavigne almost 2 years ago

  • File deleted (debug-jzgdev-20161105172811.txz)

#17 Updated by Dru Lavigne almost 2 years ago

  • File deleted (parser.js)

Also available in: Atom PDF