Project

General

Profile

Bug #19110

cons25 still used for TERM

Added by Warren Block over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
Sean Fagan
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

TERM is still being set to cons25 in /etc/ttys for the shell. This is a problem for some things, like the ee editor. The value should be xterm now.

https://svnweb.freebsd.org/base/head/etc/etc.amd64/ttys?r1=199242&r2=199243x%x%

Associated revisions

Revision c7059b6c (diff)
Added by Sean Fagan over 4 years ago

Use xterm instead of cons25, because we are now in the year 2001. Ticket: #19110

History

#1 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Assignee set to Sean Fagan
  • Priority changed from No priority to Nice to have
  • Target version set to 9.10.2-U1

Sef, will you be willing to do the honors?

#2 Updated by Warren Block over 4 years ago

  • Subject changed from cons25 still be used for TERM to cons25 still used for TERM

Me fail English? Unpossible!

#3 Updated by Sean Fagan over 4 years ago

  • Status changed from Unscreened to Screened

I disagree that it should be xterm, since the console is still the same console it has always been.

If you're using a serial console, you should set TERM to a different value if necessary.

#4 Updated by Warren Block over 4 years ago

That's just what I said, several years back. The console is the same, but /etc/ttys changed in FreeBSD in 2009. The first link explains the reasoning:
https://svnweb.freebsd.org/base/head/etc/etc.amd64/ttys?revision=199243&view=markup
https://svnweb.freebsd.org/base/head/etc/etc.amd64/ttys?r1=199242&r2=199243

The problem is not with a serial terminal, but that the actual FreeNAS console does not work correctly with TERM set to cons25 (the current default). This can be demonstrated with the ee editor, where the status bar that is supposed to be at the bottom of the screen overwrites the text, or even by running `less /etc/rc.conf` and pressing the Page Down and Page Up keys.

At the very least, we could set TERM=xterm in the shell startup.

#5 Updated by Sean Fagan over 4 years ago

Note that this would need to be changed in both fn9 and fn10, which have diverged a bit.

#6 Updated by Sean Fagan over 4 years ago

  • Status changed from Screened to 19

c7059b6c0299897d1acf5e45262736325c7dccaf and branch FIX-19110 in freenas

#7 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Target version changed from 9.10.2-U1 to 9.10.2-U2

#8 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Target version changed from 9.10.2-U2 to 9.10.3

#9 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Status changed from 19 to Resolved

#10 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Target version changed from 9.10.3 to 11.0

#12 Updated by Vaibhav Chauhan about 4 years ago

  • Target version changed from 11.0 to 11.0-RC

Also available in: Atom PDF