Project

General

Profile

Bug #19458

update-reboot issue

Added by Vaibhav Chauhan over 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Regression
Assignee:
William Grzybowski
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

so updating from 9.10.1-U4 to 9.10.2-INTERNAL2, presents you with following.
Machine in question,
https://stable-shark.ixsystems.com/ (root/meh)
mode of update: FreeNAS webui updater using update-int.ixsystems.com
IMPI: 10.212.3.8 (admin/ADMIN)

steps to reproduce:
rollback https://stable-shark.ixsystems.com/ to U4 release, apply update to FreeNAS using webui updater using update-int.ixsystems.com. you should keep IMPI session handy, IMPI: 10.212.3.8 (admin/ADMIN)

1. UI after applying an update FreeNAS machine does not go to the rebooting screen instead, it looks like reboot never took place however in the IMPI session as you can see jails and other services are shutting down.

trace_back.png (29.4 KB) trace_back.png Vaibhav Chauhan, 12/07/2016 12:15 PM
never_seen_this_before_during_shut_down.png (26.1 KB) never_seen_this_before_during_shut_down.png Vaibhav Chauhan, 12/07/2016 12:17 PM
during_update_process.png (32.3 KB) during_update_process.png Vaibhav Chauhan, 12/07/2016 12:17 PM
8027
8028
8029

Associated revisions

Revision 5da604e0 (diff)
Added by William Grzybowski over 2 years ago

fix(gui): stop nginx when rebooting

Ticket: #19458

Revision ec260dc6 (diff)
Added by William Grzybowski over 2 years ago

fix(gui): stop nginx when rebooting

Ticket: #19458

Revision fe25b59f (diff)
Added by William Grzybowski over 2 years ago

fix(gui): stop nginx when rebooting

Ticket: #19458
(cherry picked from commit ec260dc693504925ec1a87a8a8ea76b1ad761aa1)

Revision 5e613166 (diff)
Added by William Grzybowski over 2 years ago

fix(gui): stop nginx when rebooting

Ticket: #19458
(cherry picked from commit ec260dc693504925ec1a87a8a8ea76b1ad761aa1)

History

#1 Updated by William Grzybowski over 2 years ago

  • Status changed from Unscreened to Screened

There is no regression here.

There are different issues, they should be different tickets.

#2 Updated by William Grzybowski over 2 years ago

  • Status changed from Screened to Closed: Cannot reproduce

I could not reproduce the issue. I have booted 9.10.1-U4 and reapplied 9.10.2 INTERNAL2, reboot screen showed as expected.

I'll need a way to reproduce the issue since I could not.
I did that using Chrome 55.

#3 Updated by William Grzybowski over 2 years ago

  • Status changed from Closed: Cannot reproduce to Screened

New information came to light, it goes to the reboot screen but loads the UI again before reboot has happened.

#4 Updated by William Grzybowski over 2 years ago

  • Subject changed from 9.10.2 update-reboot issues to update-reboot issue
  • Description updated (diff)

#5 Updated by William Grzybowski over 2 years ago

  • Status changed from Screened to Needs Developer Review

#6 Updated by Alexander Motin over 2 years ago

  • Status changed from Needs Developer Review to Reviewed

#7 Updated by Vaibhav Chauhan over 2 years ago

  • Status changed from Reviewed to Ready For Release

#8 Updated by Dru Lavigne over 1 year ago

  • File deleted (debug-stable-shark-20161207120440.tgz)

#9 Updated by Dru Lavigne over 1 year ago

  • Status changed from Ready For Release to Resolved

Also available in: Atom PDF