Project

General

Profile

Feature #19572

Allow readonly attribute for datasets to be set/unset from the GUI

Added by Cyber Jock almost 2 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Expected
Assignee:
William Grzybowski
Category:
GUI (new)
Target version:
Estimated time:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Related projects 1 project

Description

This request is to add the ability to set/unset the readonly attribute of datasets from the WebGUI.


Related issues

Is duplicate of FreeNAS - Feature #22304: Add ability to change the readonly attribute on datasets from GUIClosed: Duplicate2017-03-16

Associated revisions

Revision 4dafb7d0 (diff)
Added by William Grzybowski over 1 year ago

feat(gui): add readonly field to dataset add/edit

Ticket: #19572

Revision e4c791f2 (diff)
Added by William Grzybowski over 1 year ago

feat(gui): add readonly field to dataset add/edit

Ticket: #19572

Revision cf53ab78 (diff)
Added by Dru Lavigne about 1 year ago

Add dataset Read-Only field.

Ticket: #19572

History

#1 Updated by William Grzybowski almost 2 years ago

  • Status changed from Unscreened to Screened
  • Target version set to TrueNAS-9.10.3

#2 Avatar?id=14398&size=24x24 Updated by Kris Moore over 1 year ago

  • Target version changed from TrueNAS-9.10.3 to 11.0

#3 Updated by William Grzybowski over 1 year ago

  • Project changed from TrueNAS to FreeNAS
  • Category changed from 42 to 2
  • Priority changed from Nice to have to Expected
  • Target version changed from 11.0 to 11.1
  • Private changed from No to Yes

Moving to FreeNAS since its not specific to make sure it gets implemented in the next feature set.

#4 Updated by William Grzybowski over 1 year ago

  • Private changed from Yes to No

#5 Updated by William Grzybowski over 1 year ago

  • Is duplicate of Feature #22304: Add ability to change the readonly attribute on datasets from GUI added

#6 Updated by William Grzybowski over 1 year ago

  • Status changed from Screened to Ready For Release

#7 Updated by Dru Lavigne over 1 year ago

  • Subject changed from Allow readonly attribute for datasets to be set/unset from the WebGUI. to Allow readonly attribute for datasets to be set/unset from the GUI

#8 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.1 to 11.1-BETA1

#9 Updated by Dru Lavigne about 1 year ago

  • Description updated (diff)

#10 Updated by Dru Lavigne about 1 year ago

  • 1 added project (TrueNAS)

#11 Updated by Bonnie Follweiler about 1 year ago

12691

Test Passes in FreeNAS-11-MASTER-201710120511
Screenshot Provided

#12 Updated by Bonnie Follweiler about 1 year ago

  • Needs QA changed from No to Yes

#13 Updated by Dru Lavigne about 1 year ago

  • Status changed from Ready For Release to Resolved

#14 Updated by Joe Maloney about 1 year ago

  • Needs QA changed from Yes to No

Also available in: Atom PDF