Project

General

Profile

Bug #19610

Configuration file contains no email password

Added by Gunther B. over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Important
Assignee:
William Grzybowski
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

today i reinstalled my Freenas (9.10.1-U4) on another usb device.
i think for this bug report only the steps 1, 6 and 8 are relevant. But who knows....

1. stored the configuration file (in German: system/Allgemein/Speichern der Einstellungen) on my pc.
2. shutdown freenas
3. unplugged boot device
4. insert new usb device for installation purpose
5. installed freenas from cd (9.10.1-U4)
6. uploaded the configuration file (the one created in step 1: System/Allgemein/Hochladen der Einstellungen)
... booted ...
7. set up a mirror for the boot device and then i saw an error in the log:

**
Dec 15 18:15:36 nas1 alert.py: [common.system:294] Failed to send email: (535, '5.7.0 Authentication rejected / Connection-failure. Username or password incorrect. Please be aware, that the e-mail password is mandatory here. E-Mail-Adresse oder Passwort ungueltig! Bitte beachten Sie, dass hier das E-Mail-Passwort notwendig ist: www.t-online.de/email-passwort')
Traceback (most recent call last):
File "/usr/local/www/freenasUI/common/system.py", line 275, in send_mail
server = _get_smtp_server(timeout, local_hostname=local_hostname)
File "/usr/local/www/freenasUI/common/system.py", line 208, in _get_smtp_server
em.em_pass.encode('utf-8'))
File "/usr/local/lib/python2.7/smtplib.py", line 622, in login
raise SMTPAuthenticationError(code, resp)
SMTPAuthenticationError: (535, '5.7.0 Authentication rejected / Connection-failure. Username or password incorrect. Please be aware, that the e-mail password is mandatory here. E-Mail-Adresse oder Passwort unguelt
Dec 15 18:15:36 nas1 alert.py: ig! Bitte beachten Sie, dass hier das E-Mail-Passwort notwendig ist: www.t-online.de/email-passwort') **

8. i checked the email configuration (System/E-Mail) Button "Send test mail" failed because of missing password. After entering the correct password all worked fine.

Associated revisions

Revision d5c68509 (diff)
Added by William Grzybowski over 4 years ago

feat(gui): add option to download secret file on save config Ticket: #19610

Revision dc148ec5 (diff)
Added by William Grzybowski over 4 years ago

feat(gui): allow upload config as a tar or raw db file Ticket: #19610

Revision 46636fd7 (diff)
Added by William Grzybowski over 4 years ago

feat(gui): change text warning about password reset Ticket: #19610

Revision 53158002 (diff)
Added by Warren Block over 4 years ago

Rewrite Save Config to explain new option to save encryption seed. Ticket: #19610

History

#1 Updated by Gunther B. over 4 years ago

  • Seen in changed from Unspecified to 9.10.1-U4

#2 Updated by Bonnie Follweiler over 4 years ago

  • Assignee set to Sean Fagan

#3 Updated by Sean Fagan over 4 years ago

  • Assignee changed from Sean Fagan to William Grzybowski

William, is this some migration that didn't happen?

#4 Updated by Gunther B. over 4 years ago

only for clarification: the problem was not the migration - it worked fine.
The problem is the missing e-mail password after loading the old configuration file.

#5 Updated by William Grzybowski over 4 years ago

  • Status changed from Unscreened to Screened
  • Priority changed from No priority to Important
  • Target version set to 9.10.3

That is by design. Configuration file itself does have encrypted passwords. The key for those password live in another location.

The issue here is that we do not provide a way to backup and import that key.

#6 Updated by William Grzybowski over 4 years ago

  • Status changed from Screened to Needs Developer Review

#7 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Assignee changed from William Grzybowski to Marcelo Araujo

Over to Marcelo for review

#8 Updated by Marcelo Araujo over 4 years ago

  • Status changed from Needs Developer Review to Reviewed

Looks good to me.

#9 Updated by William Grzybowski over 4 years ago

  • Assignee changed from Marcelo Araujo to William Grzybowski

#10 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Target version changed from 9.10.3 to 11.0

#12 Updated by Vaibhav Chauhan about 4 years ago

  • Status changed from Reviewed to Resolved

#13 Updated by Vaibhav Chauhan about 4 years ago

  • Target version changed from 11.0 to 11.0-RC

Also available in: Atom PDF