Project

General

Profile

Bug #19910

Bug when creating/deleting/configuring Link Aggregation interfaces

Added by Glenn Chee Jun Yuan over 3 years ago. Updated over 3 years ago.

Status:
Closed: Duplicate
Priority:
Critical
Assignee:
Sean Fagan
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

FreeNAS Version: 9.10.2

Hardware details:
Motherboard: ASUS P10S WS
Processor: Intel(R) Core(TM) i3-6100 CPU @ 3.70GHz
RAM: 2 × Kingston(R) ValueRAM(R) 8GB 2133 ECC

Pool configuration:
4 × Western Digital 4TB Red drives in RAIDZ2 configuration
1 × ADATA 240GB SSD for ZIL/ARC/Cache drive

ChangeLog Required:
No

Description

There is probably a bug somewhere in either the "Console setup" menu or the WebGUI when creating/deleting/configuring Link Aggregation interfaces

https://forums.freenas.org/index.php?threads/console-setup-loop-after-setting-up-lacp.48972/#post-336425

If you configure a LACP Link Aggregation in the WebGUI and proceed to delete the interface in the console menu then re-add the LACP Link Aggregation and restart the system, FreeNAS will crash as seen in the video in the thread above.


Related issues

Is duplicate of FreeNAS - Bug #19773: FreeNAS Mini Console Inaccessible If No Network Plugged InResolved2017-01-09

History

#1 Updated by Jakub Klama over 3 years ago

  • Project changed from 9 to FreeNAS
  • Category changed from 188 to 20
  • Assignee changed from Jakub Klama to Kris Moore
  • Priority changed from No priority to Critical

#2 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Assignee changed from Kris Moore to Sean Fagan
  • Target version set to 9.10.2-U2
  • Seen in changed from to 9.10.2

Sean,

I think this is related to #19773, but I wanted a second opinion before I mark it as a duplicate. Maybe bad network config causing console menu to loop again?

#3 Updated by Sean Fagan over 3 years ago

  • Is duplicate of Bug #19773: FreeNAS Mini Console Inaccessible If No Network Plugged In added

#4 Updated by Sean Fagan over 3 years ago

  • Status changed from Unscreened to Closed: Duplicate

Yeah seems to be.

#5 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Target version changed from 9.10.2-U2 to N/A

Also available in: Atom PDF