Project

General

Profile

Bug #19971

[regression] FreeNAS-9.10.2 update failed - cannot use GUI/web interface now

Added by Neil McCallum over 3 years ago. Updated over 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
No priority
Assignee:
Suraj Ravichandran
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I just applied the FreeNAS-9.10.2 update, but there seems to be a problem. Everything seemed to go OK, until I activated the new version and rebooted the system.

When it restarted, I am getting a critical alert. There is also the following message in the main window of the web interface:

{"events": [], "error": true, "message": "Error: no such column: system_advanced.adv_fqdn_syslog"}

Please see the following screenshot:


Subtasks

Bug #19974: [regression] Update gone wrong, a lot of columns missingClosed: Cannot reproduceSuraj Ravichandran

History

#1 Updated by Bonnie Follweiler over 3 years ago

  • Assignee set to Sean Fagan

#2 Updated by Neil McCallum over 3 years ago

  • Assignee deleted (Sean Fagan)

I cannot upload the 'update.failed' file here, for some reason. Please advise.

#3 Updated by Neil McCallum over 3 years ago

  • Assignee set to Sean Fagan

#4 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Subject changed from FreeNAS-9.10.2 update failed - cannot use GUI/web interface now to [regression] FreeNAS-9.10.2 update failed - cannot use GUI/web interface now
  • Assignee changed from Sean Fagan to Suraj Ravichandran
  • Priority changed from No priority to Critical
  • Target version set to 9.10.2-U1
  • Seen in changed from 9.10.2-U2 to 9.10.2

#5 Updated by Neil McCallum over 3 years ago

Please follow this link to get the 'update.failed' file:

https://drive.google.com/file/d/0B8lVkkWr6UBjTUpFVlNqaDU3am8/view?usp=sharing

#6 Updated by Sean Fagan over 3 years ago

While awaiting Suraj, can you log in via ssh and include the output of beadm list?

I'd also like to see if this was a result of the seeming GUI timeout issue, and go back to the previous boot environment (via "beadm activate" whatever it's name is), destroy the new one, and run "freenas-update -v update" (followed by a reboot assuming it succeeds), if you are willing to try.

#7 Updated by Suraj Ravichandran over 3 years ago

  • Status changed from Unscreened to 15

@Neil McCallum:
Did you ever switch trains in the past? like from stable to master, master to stable, or a combination of the above?

#8 Updated by Neil McCallum over 3 years ago

Hi

I'm sorry, I cant get access to the system at all now. Please see this thread for more info and a screenshot as to what is showing on the screen when the system is booted - https://forums.freenas.org/index.php?threads/freenas-9-10-2-update-failed-cannot-use-gui-interface-now.49153/#post-337496

@Suraj Ravichandran
To be honest, I'm not really sure. I have applied quite a few updates over maybe 2/3 years?

#9 Updated by Neil McCallum over 3 years ago

I ended up reinstalling FreeNAS on the flash drive, then restoring my config backup. Needed to get back up and running. Sorry I couldn't help with the issue more.

#10 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Status changed from 15 to Closed: Cannot reproduce

Closing this as cannot reproduce. Suraj, I've re-opened one of the duplicate tickets (#19974) with similar issues. Maybe we can investigate there. If we can't get more details from that one, go ahead and close it out also.

#11 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Target version changed from 9.10.2-U1 to N/A

Also available in: Atom PDF