Project

General

Profile

Bug #19974

Bug #19971: [regression] FreeNAS-9.10.2 update failed - cannot use GUI/web interface now

[regression] Update gone wrong, a lot of columns missing

Added by Eric Jonzeck over 3 years ago. Updated over 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
Important
Assignee:
Suraj Ravichandran
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hey guys,

we have a FreeNAS-9.10.1-U4 (ec9a7d3) running for some years now & I have to admit, I never really took care. I updated it from time to time & it showed me always the newest build, but Im afraid something gone wrong during an update.

For example, I cannot add a new NFS share, because Im getting that error:

Add Unix (NFS) Share {"error": true, "events": [], "message": "Error: no such column: services_nfs.nfs_srv_v4_v3owner"}

Same goes for the "Control Services" menu: {"error": true, "events": [], "message": "Error: no such column: directoryservice_activedirectory.ad_allow_dns_updates"}

Thats the update.failed file:

Running migrations for api:
- Nothing to migrate.
- Loading initial data for api.
Installed 0 object(s) from 0 fixture(s)
Running migrations for freeadmin:
- Nothing to migrate.
- Loading initial data for freeadmin.
Installed 0 object(s) from 0 fixture(s)
Running migrations for support:
- Nothing to migrate.
- Loading initial data for support.
Installed 0 object(s) from 0 fixture(s)
Running migrations for vcp:
- Nothing to migrate.
- Loading initial data for vcp.
Installed 0 object(s) from 0 fixture(s)
Running migrations for sharing:
- Nothing to migrate.
- Loading initial data for sharing.
Installed 0 object(s) from 0 fixture(s)
Running migrations for plugins:
- Nothing to migrate.
- Loading initial data for plugins.
Installed 0 object(s) from 0 fixture(s)
Running migrations for tasks:
- Nothing to migrate.
- Loading initial data for tasks.
Installed 0 object(s) from 0 fixture(s)
Running migrations for jails:
- Nothing to migrate.
- Loading initial data for jails.
Installed 0 object(s) from 0 fixture(s)
Running migrations for account:
- Nothing to migrate.
- Loading initial data for account.
Installed 0 object(s) from 0 fixture(s)
Running migrations for network:
- Nothing to migrate.
- Loading initial data for network.
Installed 0 object(s) from 0 fixture(s)
Running migrations for system:
- Nothing to migrate.
- Loading initial data for system.
Installed 0 object(s) from 0 fixture(s)
Running migrations for storage:
! Migration services:0181_auto__add_field_snmp_snmp_v3_authtype__add_field_snmp_snmp_v3_privprot should not have been applied before services:0180_auto__del_unique_iscsitargettoextent_iscsi_extent__add_unique_iscsitar but was.
! Migration services:0181_auto__add_field_snmp_snmp_v3_authtype__add_field_snmp_snmp_v3_privprot should not have been applied before services:0180_auto__del_unique_iscsitargettoextent_iscsi_extent__add_unique_iscsitar but was.
! Migration services:0181_auto__add_field_snmp_snmp_v3_authtype__add_field_snmp_snmp_v3_privprot should not have been applied before services:0180_auto__del_unique_iscsitargettoextent_iscsi_extent__add_unique_iscsitar but was.
! Migration services:0181_auto__add_field_snmp_snmp_v3_authtype__add_field_snmp_snmp_v3_privprot should not have been applied before services:0180_auto__del_unique_iscsitargettoextent_iscsi_extent__add_unique_iscsitar but was.
! Migration services:0181_auto__add_field_snmp_snmp_v3_authtype__add_field_snmp_snmp_v3_privprot should not have been applied before services:0180_auto__del_unique_iscsitargettoextent_iscsi_extent__add_unique_iscsitar but was.
! Migration services:0181_auto__add_field_snmp_snmp_v3_authtype__add_field_snmp_snmp_v3_privprot should not have been applied before services:0180_auto__del_unique_iscsitargettoextent_iscsi_extent__add_unique_iscsitar but was.
! Migration services:0181_auto__add_field_snmp_snmp_v3_authtype__add_field_snmp_snmp_v3_privprot should not have been applied before services:0180_auto__del_unique_iscsitargettoextent_iscsi_extent__add_unique_iscsitar but was.
! Migration services:0181_auto__add_field_snmp_snmp_v3_authtype__add_field_snmp_snmp_v3_privprot should not have been applied before services:0180_auto__del_unique_iscsitargettoextent_iscsi_extent__add_unique_iscsitar but was.
! Migration services:0181_auto__add_field_snmp_snmp_v3_authtype__add_field_snmp_snmp_v3_privprot should not have been applied before services:0180_auto__del_unique_iscsitargettoextent_iscsi_extent__add_unique_iscsitar but was.
- Migrating forwards to 0059_encrypted_disk_id_null.
> services:0172_auto__add_field_iscsitargetextent_iscsi_target_extent_serial
! Error found during real run of migration! Aborting.

! Since you have a database that does not support running
! schema-altering statements in transactions, we have had
! to leave it in an interim state between migrations.

! You *might* be able to recover with:
! The South developers regret this has happened, and would
! like to gently persuade you to consider a slightly
! easier-to-deal-with DBMS (one that supports DDL transactions)
! NOTE: The error which caused the migration to fail is further up.
Error in migration: services:0172_auto__add_field_iscsitargetextent_iscsi_target_extent_serial
Traceback (most recent call last):
  File "/usr/local/www/freenasUI/manage.py", line 42, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/local/lib/python2.7/site-packages/django/core/management/__init__.py", line 399, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/python2.7/site-packages/django/core/management/__init__.py", line 392, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/usr/local/lib/python2.7/site-packages/django/core/management/base.py", line 242, in run_from_argv
    self.execute(*args, **options.__dict__)
  File "/usr/local/lib/python2.7/site-packages/django/core/management/base.py", line 285, in execute
    output = self.handle(*args, **options)
  File "/usr/local/lib/python2.7/site-packages/south/management/commands/migrate.py", line 111, in handle
    ignore_ghosts = ignore_ghosts,
  File "/usr/local/lib/python2.7/site-packages/south/migration/__init__.py", line 220, in migrate_app
    success = migrator.migrate_many(target, workplan, database)
  File "/usr/local/lib/python2.7/site-packages/south/migration/migrators.py", line 256, in migrate_many
    result = migrator.__class__.migrate_many(migrator, target, migrations, database)
  File "/usr/local/lib/python2.7/site-packages/south/migration/migrators.py", line 331, in migrate_many
    result = self.migrate(migration, database)
  File "/usr/local/lib/python2.7/site-packages/south/migration/migrators.py", line 133, in migrate
    result = self.run(migration, database)
  File "/usr/local/lib/python2.7/site-packages/south/migration/migrators.py", line 114, in run
    return self.run_migration(migration, database)
  File "/usr/local/lib/python2.7/site-packages/south/migration/migrators.py", line 84, in run_migration
    migration_function()
  File "/usr/local/lib/python2.7/site-packages/south/migration/migrators.py", line 60, in <lambda>
    return (lambda: direction(orm))
  File "/usr/local/www/freenasUI/../freenasUI/services/migrations/0172_auto__add_field_iscsitargetextent_iscsi_target_extent_serial.py", line 23, in forwards
    for target in orm['services.iSCSITarget'].objects.all():
  File "/usr/local/lib/python2.7/site-packages/django/db/models/query.py", line 96, in __iter__
    self._fetch_all()
  File "/usr/local/lib/python2.7/site-packages/django/db/models/query.py", line 857, in _fetch_all
    self._result_cache = list(self.iterator())
  File "/usr/local/lib/python2.7/site-packages/django/db/models/query.py", line 220, in iterator
    for row in compiler.results_iter():
  File "/usr/local/lib/python2.7/site-packages/django/db/models/sql/compiler.py", line 713, in results_iter
    for rows in self.execute_sql(MULTI):
  File "/usr/local/lib/python2.7/site-packages/django/db/models/sql/compiler.py", line 786, in execute_sql
    cursor.execute(sql, params)
  File "/usr/local/lib/python2.7/site-packages/django/db/backends/util.py", line 53, in execute
    return self.cursor.execute(sql, params)
  File "/usr/local/lib/python2.7/site-packages/django/db/utils.py", line 99, in __exit__
    six.reraise(dj_exc_type, dj_exc_value, traceback)
  File "/usr/local/lib/python2.7/site-packages/django/db/backends/util.py", line 53, in execute
    return self.cursor.execute(sql, params)
  File "/usr/local/www/freenasUI/../freenasUI/freeadmin/sqlite3_ha/base.py", line 376, in execute
    execute = Database.Cursor.execute(self, query, params)
django.db.utils.OperationalError: no such column: services_iscsitarget.iscsi_target_portalgroup_id

History

#1 Updated by Bonnie Follweiler over 3 years ago

  • Assignee set to Sean Fagan

#2 Updated by Sean Fagan over 3 years ago

  • Assignee changed from Sean Fagan to William Grzybowski

#3 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Status changed from Unscreened to Closed: Duplicate

Looks like a dup of #19971 with more missing columns

#4 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Parent task set to #19971

#5 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Subject changed from Update gone wrong, a lot of columns missing to [regression] Update gone wrong, a lot of columns missing
  • Status changed from Closed: Duplicate to Unscreened
  • Assignee changed from William Grzybowski to Suraj Ravichandran
  • Priority changed from No priority to Important

#6 Updated by Suraj Ravichandran over 3 years ago

  • Status changed from Unscreened to 15
  • Target version set to 9.10.2-U3

Can you roll back to your known working boot env and then update to today's latest stable and see if that works.

Also did you ever switch branches (i.e. from stable to master and then back or some)?

If you have a /data/update.failed then please attach that too.

#7 Updated by Eric Jonzeck over 3 years ago

Unfortunately, this investigation took too long, that's why I had to reinstall the whole system. Now everythings is working as expected.

#8 Updated by Suraj Ravichandran over 3 years ago

  • Status changed from 15 to Closed: Cannot reproduce
  • Target version changed from 9.10.2-U3 to N/A

@Eric Jonzeck I am sorry for that.

At the same time I am glad that you have sorted your issues and have a working system again.

Closing as Cannot Reproduce.

Also available in: Atom PDF