Project

General

Profile

Bug #20055

AttributeError in notifier.py

Added by Vincent G over 3 years ago. Updated over 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
Important
Assignee:
Suraj Ravichandran
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

After updating via CLI from 9.10.1-U4 to 9.10.2 I got two or three tracebacks after rebooting was almost finished and before the console setup screen appeared. I only got to save one since I then got a call and some logrotate put the other logs somewhere else and I don´t even know where they went. They´re not in the same dir anymore (I did a grep Traceback over all files in the current log dir both times) and they´re not in the latest bz2 either.
I DO think the other´s were AttributeErrors too, but I´m not 100% sure.

So here´s the one that´s still available to me, from middleware.log

Traceback (most recent call last):
  File "/usr/local/lib/python2.7/site-packages/middlewared/main.py", line 157, in call_method
    'result': self.middleware.call_method(self, message),
  File "/usr/local/lib/python2.7/site-packages/middlewared/main.py", line 363, in call_method
    methodobj = getattr(self.get_service(service), method_name)
  File "/usr/local/lib/python2.7/site-packages/middlewared/plugins/notifier.py", line 59, in __getattr__
    return getattr(_n, attr)
AttributeError: 'notifier' object has no attribute 'failover_licensed'

History

#1 Updated by Bonnie Follweiler over 3 years ago

  • Assignee set to Sean Fagan

#2 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Assignee changed from Sean Fagan to Suraj Ravichandran
  • Priority changed from No priority to Important
  • Target version set to 9.10.2-U2

#3 Updated by Suraj Ravichandran over 3 years ago

  • Status changed from Unscreened to 15

@Vincent G is this issue no longer happening? This is what I interpreted from your description that it happened but is no longer happening.

Also, has this affected any of your functionality?

Thanks

#4 Updated by Vincent G over 3 years ago

Suraj Ravichandran wrote:

@Vincent G is this issue no longer happening? This is what I interpreted from your description that it happened but is no longer happening.

Also, has this affected any of your functionality?

Thanks

It happened on the second boot-up after updating, the first did, if plannend or not I do not know, seem to not finish entirely. It does not seem to have happened after that as far as I can tell, but I did not thoroughly test this.

#5 Updated by Suraj Ravichandran over 3 years ago

  • Status changed from 15 to Closed: Cannot reproduce

Hi @Vincent, I am very thankful of you to note and observe this and for being active in the freenas community and reporting it.

However, since I am not seeing this traceback and you cannot make it happen again, neither does it affect any functionality so I am going to close this out as "Cannot Reproduce"

If you do see it again then please reopen this ticket or another one.

Thanks and Regards,

Suraj Ravichandran

#6 Updated by Suraj Ravichandran over 3 years ago

  • Target version changed from 9.10.2-U2 to N/A

Also available in: Atom PDF