Project

General

Profile

Bug #20104

Multipath autocreation issues with ZeusRAM

Added by Andrey Matveev over 3 years ago. Updated about 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
No priority
Assignee:
Alexander Motin
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Just received new ZeusRAM drive to be used as ZIL
However after successful installation and server reboot new multipath device has not been created. Instead I can see two separates drives in "Disks" menu with the same serial number

[root@freenas] ~# camcontrol devlist | grep lun
<ATA INTEL SSDSC2CW06 400i> at scbus0 target 6 lun 0 (pass0)
<ATA INTEL SSDSC2CW06 400i> at scbus0 target 7 lun 0 (pass1)
<TOSHIBA MK2001TRKB 0106> at scbus2 target 8 lun 0 (pass2,da0)
<TOSHIBA MK2001TRKB 0106> at scbus2 target 9 lun 0 (pass3,da1)
<TOSHIBA MK2001TRKB 0106> at scbus2 target 10 lun 0 (pass4,da2)
<TOSHIBA MK2001TRKB 0106> at scbus2 target 11 lun 0 (pass5,da3)
<TOSHIBA MK2001TRKB 0106> at scbus2 target 12 lun 0 (pass6,da4)
<TOSHIBA MK2001TRKB 0106> at scbus2 target 13 lun 0 (pass7,da5)
<TOSHIBA MK2001TRKB 0106> at scbus2 target 14 lun 0 (pass8,da6)
<TOSHIBA MK2001TRKB 0106> at scbus2 target 15 lun 0 (pass9,da7)
<TOSHIBA MK2001TRKB 0106> at scbus2 target 16 lun 0 (pass10,da8)
<TOSHIBA MK2001TRKB 0106> at scbus2 target 17 lun 0 (pass11,da9)
<TOSHIBA MK2001TRKB 0106> at scbus2 target 18 lun 0 (pass12,da10)
<TOSHIBA MK2001TRKB 0106> at scbus2 target 19 lun 0 (pass13,da11)
<TOSHIBA MK2001TRKB 0106> at scbus2 target 20 lun 0 (pass14,da12)
<TOSHIBA MK2001TRKB 0106> at scbus2 target 21 lun 0 (pass15,da13)
<TOSHIBA MK2001TRKB 0106> at scbus2 target 22 lun 0 (pass16,da14)
<TOSHIBA MK2001TRKB 0106> at scbus2 target 23 lun 0 (pass17,da15)
<TOSHIBA MK2001TRKB 0106> at scbus2 target 24 lun 0 (pass18,da16)
<TOSHIBA MK2001TRKB 0106> at scbus2 target 25 lun 0 (pass19,da17)
<TOSHIBA MK2001TRKB 0105> at scbus2 target 26 lun 0 (pass20,da18)
<TOSHIBA MK2001TRKB 0105> at scbus2 target 27 lun 0 (pass21,da19)
<LSILOGIC SASX36 A.1 7017> at scbus2 target 28 lun 0 (pass22,ses0)
<STEC ZeusRAM C023> at scbus2 target 29 lun 0 (pass23,da20)
<TOSHIBA MK2001TRKB 0106> at scbus3 target 8 lun 0 (pass24,da21)
<TOSHIBA MK2001TRKB 0106> at scbus3 target 9 lun 0 (pass25,da22)
<TOSHIBA MK2001TRKB 0106> at scbus3 target 10 lun 0 (pass26,da23)
<TOSHIBA MK2001TRKB 0106> at scbus3 target 11 lun 0 (pass27,da24)
<TOSHIBA MK2001TRKB 0106> at scbus3 target 12 lun 0 (pass28,da25)
<TOSHIBA MK2001TRKB 0106> at scbus3 target 13 lun 0 (pass29,da26)
<TOSHIBA MK2001TRKB 0106> at scbus3 target 14 lun 0 (pass30,da27)
<TOSHIBA MK2001TRKB 0106> at scbus3 target 15 lun 0 (pass31,da28)
<TOSHIBA MK2001TRKB 0106> at scbus3 target 16 lun 0 (pass32,da29)
<TOSHIBA MK2001TRKB 0106> at scbus3 target 17 lun 0 (pass33,da30)
<TOSHIBA MK2001TRKB 0106> at scbus3 target 18 lun 0 (pass34,da31)
<TOSHIBA MK2001TRKB 0106> at scbus3 target 19 lun 0 (pass35,da32)
<TOSHIBA MK2001TRKB 0106> at scbus3 target 20 lun 0 (pass36,da33)
<TOSHIBA MK2001TRKB 0106> at scbus3 target 21 lun 0 (pass37,da34)
<TOSHIBA MK2001TRKB 0106> at scbus3 target 22 lun 0 (pass38,da35)
<TOSHIBA MK2001TRKB 0106> at scbus3 target 23 lun 0 (pass39,da36)
<TOSHIBA MK2001TRKB 0106> at scbus3 target 24 lun 0 (pass40,da37)
<TOSHIBA MK2001TRKB 0106> at scbus3 target 25 lun 0 (pass41,da38)
<TOSHIBA MK2001TRKB 0105> at scbus3 target 26 lun 0 (pass42,da39)
<TOSHIBA MK2001TRKB 0105> at scbus3 target 27 lun 0 (pass43,da40)
<LSILOGIC SASX36 A.1 7017> at scbus3 target 28 lun 0 (pass44,ses1)
<STEC ZeusRAM C023> at scbus3 target 29 lun 0 (pass45,da41)
[root@freenas] ~# gmultipath status
Name Status Components
multipath/disk24 OPTIMAL da40 (ACTIVE)
da19 (PASSIVE)
multipath/disk23 OPTIMAL da39 (ACTIVE)
da18 (PASSIVE)
multipath/disk15 OPTIMAL da38 (ACTIVE)
da17 (PASSIVE)
multipath/disk16 OPTIMAL da37 (ACTIVE)
da16 (PASSIVE)
multipath/disk14 OPTIMAL da36 (ACTIVE)
da15 (PASSIVE)
multipath/disk18 OPTIMAL da35 (ACTIVE)
da14 (PASSIVE)
multipath/disk17 OPTIMAL da34 (ACTIVE)
da13 (PASSIVE)
multipath/disk13 OPTIMAL da33 (ACTIVE)
da12 (PASSIVE)
multipath/disk12 OPTIMAL da32 (ACTIVE)
da11 (PASSIVE)
multipath/disk11 OPTIMAL da31 (ACTIVE)
da10 (PASSIVE)
multipath/disk6 OPTIMAL da30 (ACTIVE)
da9 (PASSIVE)
multipath/disk5 OPTIMAL da29 (ACTIVE)
da8 (PASSIVE)
multipath/disk8 OPTIMAL da28 (ACTIVE)
da7 (PASSIVE)
multipath/disk9 OPTIMAL da27 (ACTIVE)
da6 (PASSIVE)
multipath/disk7 OPTIMAL da26 (ACTIVE)
da5 (PASSIVE)
multipath/disk10 OPTIMAL da25 (ACTIVE)
da4 (PASSIVE)
multipath/disk4 OPTIMAL da24 (ACTIVE)
da3 (PASSIVE)
multipath/disk3 OPTIMAL da23 (ACTIVE)
da2 (PASSIVE)
multipath/disk2 OPTIMAL da22 (ACTIVE)
da1 (PASSIVE)
multipath/disk1 OPTIMAL da21 (ACTIVE)
da0 (PASSIVE)

Zeus drive is connected to the same backplain as all the others disks are.
Should I create multipath device manually or something is wrong here?

multipath_output.png (169 KB) multipath_output.png Andrey Matveev, 01/09/2017 11:06 AM
view_disks_output.png (159 KB) view_disks_output.png Andrey Matveev, 01/09/2017 11:06 AM
8377
8378

History

#1 Updated by Bonnie Follweiler over 3 years ago

  • Assignee set to Kris Moore

#2 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Assignee changed from Kris Moore to Alexander Motin

#3 Updated by Alexander Motin over 3 years ago

  • Status changed from Unscreened to Screened

This is odd. Multipath device should be created automatically on boot. Please attach debug information from the system to the ticket (System->Advanced->Save Debug).

#4 Updated by Andrey Matveev over 3 years ago

8377
8378

Here we go...

And please take a look at drive da40 (it's in multipath/disk24 with da19). It's used as hot spare drive but shown in drives output as standalone (see screenshots)

#5 Updated by Bonnie Follweiler over 3 years ago

  • Private changed from No to Yes

#6 Updated by Alexander Motin over 3 years ago

As I see in debug, multipath/disk24 does include both da19 and da40. So this seems to be a problem of middleware or UI.

What's about multipath for ZeusRAM, it is hard to diagnose it now, after you created one manually. May be disks are shown since middleware haven't noticed that you created multipath to exclude disks from the list. I see that before you manually created multipath named ZIL, there was one named disk2, that had some collisions with GPT labels, created before it. Could you try to redo everything from scratch: remove the multipath from ZFS pool, delete partition table on it (or better wipe it clean), delete existing multipath named ZIL, reboot or replug to see whether things happen properly, if not -- submit new debug info.

#7 Updated by Alexander Motin over 3 years ago

  • Category changed from 137 to 201

#8 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

Would you like to move this over to William to look at when he's back from VC, or do you handle the middleware side as well?

#9 Updated by Alexander Motin over 3 years ago

Kris Moore wrote:

Would you like to move this over to William to look at when he's back from VC, or do you handle the middleware side as well?

If he is out for another two weeks, then I may get to it first. I could probably handle it, I don't like it, but I had my hands there few times. But the main question is that I don't have much multipath disks in my lab, not sure William has more, especially with ZeusRAM.

#10 Updated by Alexander Motin about 3 years ago

  • Status changed from Screened to Closed: Cannot reproduce
  • Target version set to N/A

I'm sorry, but I can't reproduce this. I don't have ZeusRAM in system capable of multipath, while for regular disks I found no multipath problems.

#11 Updated by Dru Lavigne about 3 years ago

  • File deleted (debug-freenas-20170109215929.tgz)

#12 Updated by Dru Lavigne about 3 years ago

  • Private changed from Yes to No

Also available in: Atom PDF