Project

General

Profile

Bug #20485

Changelog email contains no changes

Added by Rod Hutson over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Expected
Assignee:
Sean Fagan
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Build FreeNAS-9.10.2 (a476f16)
Platform AMD FX(tm)-6300 Six-Core Processor
Memory 16252MB

ChangeLog Required:
No

Description

Same issue as reported in bug report #19835 by Marty Godsey on 27Dec16. My emailed update notifications contain no change log entries - reported changes listed as "None" ...

A new update is available for the FreeNAS-9.10-STABLE train.

Version: FreeNAS-9.10.2-U1
Changelog:
None

This has been going on for me since I updated to release of 9.10.2 prior to 20Dec16.


Related issues

Is duplicate of FreeNAS - Bug #19835: Changlog email is blankClosed: Behaves correctly2016-12-27

History

#1 Updated by Rod Hutson over 4 years ago

  • Hardware Configuration updated (diff)

#2 Updated by Rod Hutson over 4 years ago

  • Description updated (diff)

#3 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Assignee changed from Rod Hutson to Suraj Ravichandran
  • Priority changed from No priority to Nice to have
  • Target version set to 9.10.2-U3

#4 Updated by Suraj Ravichandran over 4 years ago

  • Status changed from Unscreened to Screened

I cannot get to this for the current week, will take a look next week.

#5 Updated by Rod Hutson over 4 years ago

Another datapoint - reading from the FreeNAS Menu terminal screen today, Jan 23 at 14:21, I see the following messages:

Jan 21 02:58:03 freenas update_check.py: [freenasOS.Configuration:710] Got http error HTTP Error 404: Not Found
Jan 22 14:28:52 freenas manage.py: [freenasOS.Configuration:713] Unable to load http://update-master.ixsystems.com/updates/ix_crl.pem: timed out
Jan 22 14:28:52 freenas manage.py: [freenasOS.Configuration:713] Unable to load ['http://update-master.ixsystems.com/updates/ix_crl.pem']: timed out
Jan 22 14:28:52 freenas manage.py: [freenasOS.Update:1554] Could not load cached manifest file: timed out
Jan 22 14:28:52 freenas manage.py: [freenasOS.Update:1114]

#6 Updated by Suraj Ravichandran over 4 years ago

  • Is duplicate of Bug #19835: Changlog email is blank added

#7 Updated by Suraj Ravichandran over 4 years ago

  • Status changed from Screened to Closed: Duplicate
  • Assignee changed from Suraj Ravichandran to Sean Fagan

AS this is the duplicate of #19835 and over there marty stated that this issue is resolved and is not longer happening I am going to close this as a duplicate of that one. Also, assigning to @sef since this is his area of expertise.

In case it still persists please comment back in here stating the same.

#8 Updated by Rod Hutson over 4 years ago

Um, did you read Marty's "resolution"? All he posted was, "You can close this.. It showed up.. Thank you.". No solution provided, nothing that anybody can use in the same situation. If something was shared by Marty with your team that wasn't included in his brief post, then I'm all ears.

I am still getting a new report every day around 3AM just like what I originally posted, including this morning:

A new update is available for the FreeNAS-9.10-STABLE train.

Version: FreeNAS-9.10.2-U1
Changelog:
None

I expect another report just like this tomorrow morning and so on.

So, no its not resolved, at least no in 9.10.2-U1. or at least not in a way I can apply to my situation. I'm willing to work with you to figure out what is causing this, but right now I'm caught with this bug, and updating to U2, etc just to see the bug continue to aggravate me isn't gonna happen.

What is the explanation for the messages from Jan 21-22 regarding the Configuration HTTP Error, and the update manifest file that couldn't be found? Those look like clues to me, but at your end, not mine.

#9 Updated by Dru Lavigne over 4 years ago

  • Status changed from Closed: Duplicate to Unscreened

#10 Updated by Sean Fagan over 4 years ago

  • Status changed from Unscreened to 15

Please do "manifest_util sequence" and "freenas-update -v check"

#11 Updated by Rod Hutson over 4 years ago

Logged into FreeNAS, then launched Shell from the Menu ... ran the two commands as root:

[root@freenas ~]# manifest_util sequence
e7d5dd8c7c17f6250fc99a66b8133eb0

[root@freenas] ~# freenas-update -v check
[freenasOS.Configuration:637] TryGetNetworkFile([u'http://update-master.ixsystems.com/FreeNAS/FreeNAS-9.10-STABLE/LATEST'])
[freenasOS.Configuration:763] TryGetNetworkFile([u'http://update-master.ixsystems.com/FreeNAS/FreeNAS-9.10-STABLE/LATEST']): Read 3813 bytes total
[freenasOS.Configuration:637] TryGetNetworkFile(['http://update-master.ixsystems.com/updates/ix_crl.pem'])
[freenasOS.Configuration:83] CheckFreeSpace(path=/tmp/tmpqCyl6j.pem, pool=None, required=1028)
[freenasOS.Configuration:763] TryGetNetworkFile(['http://update-master.ixsystems.com/updates/ix_crl.pem']): Read 1028 bytes total
[freenasOS.Manifest:448] Verify command = ['/usr/local/libexec/verify_signature', '-K', '/usr/local/share/certs/Production.pem', '-C', '/usr/local/share/certs/iX-CA.pem', '-S', u'vidvtjN30wiH5aX1Q9PX3UJM90H9AWU3ns4H6qwZm1aSHQH791a+/I3PR16Z81wan/7wPiLUzIZDz3FzMMkTPcxZwgT+72V/Kutd+b04i0APjuHc2pwS4+zD3PaDeYTA0HzUL9fgHkX7+sndTEaUZjMlANvp2kpZuRB17cG/enOSJCK7PW+5o5/kHUQBaioRXyI6WJx7/ybMZHywXKp8F3jpRIPG2JUI5mstKHvp8XB2mP74Hr7BK1g1TI6jp7iR3sEeS6bmLFEqm3CVKHi/HefhUye+qER3xjnkkIYNGYkR5Tmc9Pp3DX1TaYS5egR7lVV7d4YxbdtHFj0l6V53sw==', '-R', '/tmp/tmpqCyl6j.pem']
[freenasOS.Manifest:464] Signature check succeeded
[freenasOS.Configuration:637] TryGetNetworkFile(['http://update-master.ixsystems.com/updates/ix_crl.pem'])
[freenasOS.Configuration:83] CheckFreeSpace(path=/tmp/tmpMkeeHa.pem, pool=None, required=1028)
[freenasOS.Configuration:763] TryGetNetworkFile(['http://update-master.ixsystems.com/updates/ix_crl.pem']): Read 1028 bytes total
[freenasOS.Manifest:448] Verify command = ['/usr/local/libexec/verify_signature', '-K', '/usr/local/share/certs/Production.pem', '-C', '/usr/local/share/certs/iX-CA.pem', '-S', u'vidvtjN30wiH5aX1Q9PX3UJM90H9AWU3ns4H6qwZm1aSHQH791a+/I3PR16Z81wan/7wPiLUzIZDz3FzMMkTPcxZwgT+72V/Kutd+b04i0APjuHc2pwS4+zD3PaDeYTA0HzUL9fgHkX7+sndTEaUZjMlANvp2kpZuRB17cG/enOSJCK7PW+5o5/kHUQBaioRXyI6WJx7/ybMZHywXKp8F3jpRIPG2JUI5mstKHvp8XB2mP74Hr7BK1g1TI6jp7iR3sEeS6bmLFEqm3CVKHi/HefhUye+qER3xjnkkIYNGYkR5Tmc9Pp3DX1TaYS5egR7lVV7d4YxbdtHFj0l6V53sw==', '-R', '/tmp/tmpMkeeHa.pem']
[freenasOS.Manifest:464] Signature check succeeded
[freenasOS.Configuration:637] TryGetNetworkFile(['http://update-master.ixsystems.com/updates/ix_crl.pem'])
[freenasOS.Configuration:83] CheckFreeSpace(path=/tmp/tmpKlkv8z.pem, pool=None, required=1028)
[freenasOS.Configuration:763] TryGetNetworkFile(['http://update-master.ixsystems.com/updates/ix_crl.pem']): Read 1028 bytes total
[freenasOS.Manifest:448] Verify command = ['/usr/local/libexec/verify_signature', '-K', '/usr/local/share/certs/Production.pem', '-C', '/usr/local/share/certs/iX-CA.pem', '-S', u'vidvtjN30wiH5aX1Q9PX3UJM90H9AWU3ns4H6qwZm1aSHQH791a+/I3PR16Z81wan/7wPiLUzIZDz3FzMMkTPcxZwgT+72V/Kutd+b04i0APjuHc2pwS4+zD3PaDeYTA0HzUL9fgHkX7+sndTEaUZjMlANvp2kpZuRB17cG/enOSJCK7PW+5o5/kHUQBaioRXyI6WJx7/ybMZHywXKp8F3jpRIPG2JUI5mstKHvp8XB2mP74Hr7BK1g1TI6jp7iR3sEeS6bmLFEqm3CVKHi/HefhUye+qER3xjnkkIYNGYkR5Tmc9Pp3DX1TaYS5egR7lVV7d4YxbdtHFj0l6V53sw==', '-R', '/tmp/tmpKlkv8z.pem']
[freenasOS.Manifest:464] Signature check succeeded
[freenasOS.Update:935] DownloadUpdate: Cache directory has latest manifest
[freenasOS.Configuration:637] TryGetNetworkFile(['http://update-master.ixsystems.com/updates/ix_crl.pem'])
[freenasOS.Configuration:83] CheckFreeSpace(path=/tmp/tmppLCRqb.pem, pool=None, required=1028)
[freenasOS.Configuration:763] TryGetNetworkFile(['http://update-master.ixsystems.com/updates/ix_crl.pem']): Read 1028 bytes total
[freenasOS.Manifest:448] Verify command = ['/usr/local/libexec/verify_signature', '-K', '/usr/local/share/certs/Production.pem', '-C', '/usr/local/share/certs/iX-CA.pem', '-S', u'vidvtjN30wiH5aX1Q9PX3UJM90H9AWU3ns4H6qwZm1aSHQH791a+/I3PR16Z81wan/7wPiLUzIZDz3FzMMkTPcxZwgT+72V/Kutd+b04i0APjuHc2pwS4+zD3PaDeYTA0HzUL9fgHkX7+sndTEaUZjMlANvp2kpZuRB17cG/enOSJCK7PW+5o5/kHUQBaioRXyI6WJx7/ybMZHywXKp8F3jpRIPG2JUI5mstKHvp8XB2mP74Hr7BK1g1TI6jp7iR3sEeS6bmLFEqm3CVKHi/HefhUye+qER3xjnkkIYNGYkR5Tmc9Pp3DX1TaYS5egR7lVV7d4YxbdtHFj0l6V53sw==', '-R', '/tmp/tmppLCRqb.pem']
[freenasOS.Manifest:464] Signature check succeeded
[freenasOS.Configuration:637] TryGetNetworkFile(['http://update-master.ixsystems.com/updates/ix_crl.pem'])
[freenasOS.Configuration:83] CheckFreeSpace(path=/tmp/tmpKgirMW.pem, pool=None, required=1028)
[freenasOS.Configuration:763] TryGetNetworkFile(['http://update-master.ixsystems.com/updates/ix_crl.pem']): Read 1028 bytes total
[freenasOS.Manifest:448] Verify command = ['/usr/local/libexec/verify_signature', '-K', '/usr/local/share/certs/Production.pem', '-C', '/usr/local/share/certs/iX-CA.pem', '-S', u'vidvtjN30wiH5aX1Q9PX3UJM90H9AWU3ns4H6qwZm1aSHQH791a+/I3PR16Z81wan/7wPiLUzIZDz3FzMMkTPcxZwgT+72V/Kutd+b04i0APjuHc2pwS4+zD3PaDeYTA0HzUL9fgHkX7+sndTEaUZjMlANvp2kpZuRB17cG/enOSJCK7PW+5o5/kHUQBaioRXyI6WJx7/ybMZHywXKp8F3jpRIPG2JUI5mstKHvp8XB2mP74Hr7BK1g1TI6jp7iR3sEeS6bmLFEqm3CVKHi/HefhUye+qER3xjnkkIYNGYkR5Tmc9Pp3DX1TaYS5egR7lVV7d4YxbdtHFj0l6V53sw==', '-R', '/tmp/tmpKgirMW.pem']
[freenasOS.Manifest:464] Signature check succeeded
Upgrade package base-os 9.10.2-e7d5dd8c7c17f6250fc99a66b8133eb0->9.10.2-U1-1e055f208642fd566b9f569d31cd01a9
Upgrade package docs 9.10.2-e7d5dd8c7c17f6250fc99a66b8133eb0->9.10.2-U1-1e055f208642fd566b9f569d31cd01a9
Upgrade package freebsd-pkgdb 9.10.2-e7d5dd8c7c17f6250fc99a66b8133eb0->9.10.2-U1-1e055f208642fd566b9f569d31cd01a9
Upgrade package freenas-pkg-tools 9.10.2-e7d5dd8c7c17f6250fc99a66b8133eb0->9.10.2-U1-1e055f208642fd566b9f569d31cd01a9
Upgrade package FreeNASUI 9.10.2-e7d5dd8c7c17f6250fc99a66b8133eb0->9.10.2-U1-1e055f208642fd566b9f569d31cd01a9
Reboot is (conditionally) required
Sequence e7d5dd8c7c17f6250fc99a66b8133eb0 -> 1e055f208642fd566b9f569d31cd01a9

#12 Updated by Sean Fagan over 4 years ago

  • Assignee changed from Sean Fagan to Vaibhav Chauhan

There are no ChangeLog.txt entries for either 1e055f208642fd566b9f569d31cd01a9 or e7d5dd8c7c17f6250fc99a66b8133eb0 on the update server. What's going on there?

#13 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Target version changed from 9.10.2-U3 to 9.10.3

#14 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Status changed from 15 to Closed

#15 Updated by Rod Hutson over 4 years ago

How did this issue get closed? The feedback you were waiting for was to come from internal sources after your question about there being no Changelog.txt entries on the update server - two months ago. Seriously?

#16 Updated by Dru Lavigne over 4 years ago

  • Status changed from Closed to Unscreened
  • Assignee changed from Vaibhav Chauhan to Kris Moore

Kris, can you double-check this one? It is showing up on the forums as well: https://forums.freenas.org/index.php?threads/freenas-9-10-2-u2-blank-changelog.51982/.

#17 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Assignee changed from Kris Moore to Vaibhav Chauhan
  • Priority changed from Nice to have to Expected

Ok, I thought I heard from VB that this was resolved, guess not. Back over to VB to see why that file isn't updated...

#18 Updated by Rod Hutson over 4 years ago

Thank you, Dru and Kris - much appreciated !!

#19 Updated by Steve Snodgrass over 4 years ago

Dru Lavigne wrote:

Kris, can you double-check this one? It is showing up on the forums as well: https://forums.freenas.org/index.php?threads/freenas-9-10-2-u2-blank-changelog.51982/.

As Dru pointed out, I have this problem too. If there are any troubleshooting steps you would like me to take, please let me know.

#20 Updated by Vaibhav Chauhan over 4 years ago

  • Status changed from Unscreened to Screened

#21 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Assignee changed from Vaibhav Chauhan to Sean Fagan

Sean - Can you confirm if this is still an issue and investigate?

#22 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Target version changed from 9.10.3 to 11.0

#23 Updated by Sean Fagan over 4 years ago

  • Status changed from Screened to Resolved

As I stated, this was do to build/release process. The most recent 9.10 release has a changelog entry (a single entry, but there it is). If updating from a release that doesn't exist in the ChangeLog.txt file, nothing will be shown. (The reason for that is because if you update by switching trains, it would show everything in the new train's changelog, which was decided to be too overwhelming.)

#24 Updated by Rod Hutson over 4 years ago

Thanks for your efforts, everyone. I am indeed now getting a meaningful Changelog : a single line in today's update notification:

Version: FreeNAS-9.10.2-U3
Changelog:
#23459    Bug      Regression    SMB slow listing directories with large file numbers.

Thanks again!

#27 Updated by Vaibhav Chauhan about 4 years ago

  • Target version changed from 11.0 to 11.0-RC

Also available in: Atom PDF