Project

General

Profile

Bug #2084

Cannot remove AFP share password once set

Added by Anonymous over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Important
Assignee:
William Grzybowski
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

As a result of various changes to the AFP Share password field handling, it is no longer possible to remove a share password once set. Editing a share with one set presents a blank field, and clicking OK does not remove it.

See r8013 for the latest commit and ticket #837 for some history.

Reproduction:
1. Create AFP share, set volume password.
2. Restart AFP, test that volume password is checked for and accepted on client.
3. Edit AFP share, click OK without changing anything (since the Share Password field is blank).
4. Restart AFP, test that volume password is still being prompted for. Verify that old password is still valid.

Associated revisions

Revision 8b942dc6 (diff)
Added by William Grzybowski over 6 years ago

Cannot remove AFP share password once set It was no longer possible to remove a share password once set. Editing a share with one set presents a blank field, and clicking OK does not remove it. ticket: #2084

Revision 355bb827 (diff)
Added by William Grzybowski over 6 years ago

Cannot remove AFP share password once set It was no longer possible to remove a share password once set. Editing a share with one set presents a blank field, and clicking OK does not remove it. ticket: #2084

History

#1 Updated by William Grzybowski over 6 years ago

Should be fixed in r13444

Also available in: Atom PDF