Project

General

Profile

Bug #20999

NFS mountd request denied after bootup

Added by Richard Kojedzinszky over 3 years ago. Updated over 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
Nice to have
Assignee:
William Grzybowski
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

It happened sometimes, that after a reboot mountd denies mount requests, and an nfs service restart solves the issue.

History

#1 Updated by Bonnie Follweiler over 3 years ago

  • Assignee set to William Grzybowski

#2 Updated by William Grzybowski over 3 years ago

  • Status changed from Unscreened to 15
  • Priority changed from No priority to Nice to have

You did not give me much to work with :)

#3 Updated by William Grzybowski over 3 years ago

  • Target version set to 9.10.3

#4 Updated by Richard Kojedzinszky over 3 years ago

Actually, because thats all.

One of our boxes sometimes boots up well with its nfs service configured right (accepts mount requests), sometimes boots up with mountd denying mount requests. In the latter case an nfs service stop/start solves the issue, but unfortunately our environment is very sensitive for denied mounts, and causes trouble. Of course, nfs share configuration is not changed between the restarts. The actual syslog entries look like.

Feb 9 05:12:02 dravanet-bix-nas mountd1956: mount request denied from 109.61.98.2 for /mnt/vol0/...

Unfortunately this behaviour is not constant as I wrote earlier, but in the case of the wrong state, the restart of the nfs service solves the problem.

And also, in 2-3 restarts on our lab freenas I could not reproduce the issue.

#5 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Status changed from 15 to Closed: Cannot reproduce

This is going to be a tough one. Without a specific repro case we don't have a lot to go on. If we can find a way to reproduce, we will re-open

#6 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Target version changed from 9.10.3 to N/A

Also available in: Atom PDF