Project

General

Profile

Bug #21158

Cannot import single encrypted backup disk connected to onboard SATA (X9SCM-F)

Added by Christian FitzGerald Forberg over 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Important
Assignee:
Alexander Motin
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hi,

From the hardware perspective I have two identical FreeNAS Systems at work and at home. (Supermicroboard, 32GB ECC Ram, 6x2TB-WDRed, E3-1230v, m1015 HBA)

At home I have 9.10.2-U1 and at the office FreeNAS-9.10.2 (a476f16).

I tried to import a single encrypted backup disc from the office at home but its just not listed. When I click on 'Import Volume' and check 'Decrypt Disc' the listbox on the next step stays empty.

I researched a bit and found:

[root@gaia] ~# camcontrol devlist
<ATA WDC WD20EFRX-68A 0A80> at scbus0 target 7 lun 0 (pass0,da0)
<ATA WDC WD20EFRX-68A 0A80> at scbus0 target 8 lun 0 (pass1,da1)
<ATA WDC WD20EFRX-68A 0A80> at scbus0 target 9 lun 0 (pass2,da2)
<ATA WDC WD20EFRX-68E 0A82> at scbus0 target 10 lun 0 (pass3,da3)
<ATA WDC WD20EFRX-68E 0A82> at scbus0 target 11 lun 0 (pass4,da4)
<ATA WDC WD20EFRX-68E 0A82> at scbus0 target 12 lun 0 (pass5,da5)
<INTEL SSDSA2M080G2GC 2CV102M3> at scbus1 target 0 lun 0 (pass6,ada0)
<ST4000VN000-2AH166 SC60> at scbus2 target 0 lun 0 (pass7,ada1)

[root@gaia] ~# gpart show
=> 34 156301421 ada0 GPT (75G)
34 6 - free - (3.0K)
40 1024 1 bios-boot (512K)
1064 156300384 2 freebsd-zfs (75G)
156301448 7 - free - (3.5K)

=> 34 7814037101 ada1 GPT (3.6T)
34 94 - free - (47K)
128 4194304 1 freebsd-swap (2.0G)
4194432 7809842696 2 freebsd-zfs (3.6T)
7814037128 7 - free - (3.5K)

=> 34 3907029101 da0 GPT (1.8T)
34 94 - free - (47K)
128 4194304 1 freebsd-swap (2.0G)
4194432 3902834696 2 freebsd-zfs (1.8T)
3907029128 7 - free - (3.5K)

=> 34 3907029101 da1 GPT (1.8T)
34 94 - free - (47K)
128 4194304 1 freebsd-swap (2.0G)
4194432 3902834696 2 freebsd-zfs (1.8T)
3907029128 7 - free - (3.5K)
...

[root@gaia] ~# zpool status
pool: freenas-boot
state: ONLINE
scan: scrub repaired 0 in 0h1m with 0 errors on Tue Jan 24 03:46:44 2017
config:

NAME        STATE     READ WRITE CKSUM
freenas-boot ONLINE 0 0 0
ada0p2 ONLINE 0 0 0

errors: No known data errors

pool: tank
state: ONLINE
scan: scrub repaired 0 in 12h14m with 0 errors on Sun Jan 29 12:14:32 2017
config:
NAME                                                STATE     READ WRITE CKSUM
tank ONLINE 0 0 0
raidz2-0 ONLINE 0 0 0
gptid/4c932da8-921c-11e4-b24c-0cc47a401407.eli ONLINE 0 0 0
gptid/4cfac3a5-921c-11e4-b24c-0cc47a401407.eli ONLINE 0 0 0
gptid/4d6213c8-921c-11e4-b24c-0cc47a401407.eli ONLINE 0 0 0
gptid/4e20f238-921c-11e4-b24c-0cc47a401407.eli ONLINE 0 0 0
gptid/4ee52fdb-921c-11e4-b24c-0cc47a401407.eli ONLINE 0 0 0
gptid/4f9f84fd-921c-11e4-b24c-0cc47a401407.eli ONLINE 0 0 0

errors: No known data errors

But the problem seems to be that 'zpool import' does not return anything.
Besides, the same disk works fine at the office but I did not import it there cause its already 'known' to the system.

I am not sure if the problem has anything todo with the freenas-version mismatch?

Anyhow, thanks for your help!
Christian

Associated revisions

Revision 4387cec9 (diff)
Added by Alexander Motin over 4 years ago

Fix incorrect comparison, which counted ada0 equal to da0. Ticket: #21158

History

#1 Updated by Christian FitzGerald Forberg over 4 years ago

  • File debug-gaia-20170214214652.txz added

#2 Updated by Bonnie Follweiler over 4 years ago

  • Assignee set to William Grzybowski

#3 Updated by William Grzybowski over 4 years ago

  • Status changed from Unscreened to 15
  • Target version set to 9.10.3

What is this disk you're talking about? ST4000VN000-2AH166?

#4 Updated by Christian FitzGerald Forberg over 4 years ago

Yes, thats the external backup disk, Seagate 4TB

I just found a workaround. If I connect the Disc to the m1015 the problem's gone and the disc appears in the listbox.
My mainboard is a Supermicro X9SCM-F, the one that Cyberjock recommended in his slideshow.
Is it that this mainboard is maybe too old by now, should one always connect to m1015 or other HBAs and leave the onboard Sata-connectors alone?

I am a bit puzzled now.

#5 Updated by William Grzybowski over 4 years ago

Christian FitzGerald Forberg wrote:

Yes, thats the external backup disk, Seagate 4TB

I just found a workaround. If I connect the Disc to the m1015 the problem's gone and the disc appears in the listbox.
My mainboard is a Supermicro X9SCM-F, the one that Cyberjock recommended in his slideshow.
Is it that this mainboard is maybe too old by now, should one always connect to m1015 or other HBAs and leave the onboard Sata-connectors alone?

I am a bit puzzled now.

That should not have made a difference. Can you post "camcontrol devlist" after reattaching the disk to the other controller?

#6 Updated by Christian FitzGerald Forberg over 4 years ago

[root@gaia] ~# camcontrol devlist
<ATA WDC WD20EFRX-68A 0A80> at scbus0 target 7 lun 0 (pass0,da0)
<ATA WDC WD20EFRX-68A 0A80> at scbus0 target 8 lun 0 (pass1,da1)
<ATA WDC WD20EFRX-68A 0A80> at scbus0 target 9 lun 0 (pass2,da2)
<ATA WDC WD20EFRX-68E 0A82> at scbus0 target 10 lun 0 (pass3,da3)
<ATA WDC WD20EFRX-68E 0A82> at scbus0 target 11 lun 0 (pass4,da4)
<ATA WDC WD20EFRX-68E 0A82> at scbus0 target 12 lun 0 (pass5,da5)
<ST4000VN000-2AH166 SC60> at scbus0 target 15 lun 0 (pass6,da6)
<INTEL SSDSA2M080G2GC 2CV102M3> at scbus1 target 0 lun 0 (pass7,ada0)

#7 Updated by Christian FitzGerald Forberg over 4 years ago

Besides, FreeNAS version mismatch is probably out of the equation, because I could reproduce the problem with the same disk on my home-system. (I wiped the disc, recreated an encrypted volume with it, detached it and then tried to import it. As long as its connected to the onboard sata, it does not appear)

#8 Updated by Christian FitzGerald Forberg over 4 years ago

  • Subject changed from Cannot import single encrypted backup disk from another FreeNAS System to Cannot import single encrypted backup disk connected to onboard SATA (X9SCM-F)

#9 Updated by William Grzybowski over 4 years ago

Christian FitzGerald Forberg wrote:

Besides, FreeNAS version mismatch is probably out of the equation, because I could reproduce the problem with the same disk on my home-system. (I wiped the disc, recreated an encrypted volume with it, detached it and then tried to import it. As long as its connected to the onboard sata, it does not appear)

Well, that is weird. If that disk is on the onboard sata, are you able to see that disk in Storage -> Volume -> View Disks and in the Storage -> Volume -> Volume Manager?

#10 Updated by Christian FitzGerald Forberg over 4 years ago

Yes, it appears in both.

#11 Updated by William Grzybowski over 4 years ago

  • Assignee changed from William Grzybowski to Alexander Motin

Alexander, I am out of ideas here.

He does not seem to have a geli when plugged via onboard sata, but does when its in the dedicated "HBA". Any clues? Thank you.

Christian, do you happen to have your onboard controller configured as raid maybe?

#12 Updated by Alexander Motin over 4 years ago

I also don't see why it may work on SAS HBA, but not on SATA. Please attach outputs of both `geom disk list {device}` and `geom part list {device}` for both ways of attachment.

#13 Updated by Christian FitzGerald Forberg over 4 years ago

This is the backup-disc at the m1015

[root@gaia] ~# geom disk list da6
Geom name: da6
Providers:
1. Name: da6
   Mediasize: 8001563222016 (7.3T)
   Sectorsize: 512
   Stripesize: 4096
   Stripeoffset: 0
   Mode: r2w2e5
   descr: ATA ST8000AS0002-1NA
   lunid: 5000c50091105847
   ident: Z840HLSM
   rotationrate: 5980
   fwsectors: 63
   fwheads: 255

[root@gaia] ~# geom part list da6
Geom name: da6
modified: false
state: OK
fwheads: 255
fwsectors: 63
last: 15628053134
first: 34
entries: 128
scheme: GPT                                                                                                                                                                   
Providers:                                                                                                                                                                    
1. Name: da6p1                                                                                                                                                                
   Mediasize: 2147483648 (2.0G)                                                                                                                                               
   Sectorsize: 512                                                                                                                                                            
   Stripesize: 4096                                                                                                                                                           
   Stripeoffset: 0                                                                                                                                                            
   Mode: r1w1e1                                                                                                                                                               
   rawuuid: c12c84b5-f304-11e6-98b6-0cc47a401407                                                                                                                              
   rawtype: 516e7cb5-6ecf-11d6-8ff8-00022d09712b                                                                                                                              
   label: (null)                                                                                                                                                              
   length: 2147483648                                                                                                                                                         
   offset: 65536                                                                                                                                                              
   type: freebsd-swap                                                                                                                                                         
   index: 1                                                                                                                                                                   
   end: 4194431                                                                                                                                                               
   start: 128                                                                                                                                                                 
2. Name: da6p2                                                                                                                                                                
   Mediasize: 7999415652352 (7.3T)                                                                                                                                            
   Sectorsize: 512                                                                                                                                                            
   Stripesize: 4096                                                                                                                                                           
   Stripeoffset: 0                                                                                                                                                            
   Mode: r1w1e2                                                                                                                                                               
   rawuuid: c13a910f-f304-11e6-98b6-0cc47a401407                                                                                                                              
   rawtype: 516e7cba-6ecf-11d6-8ff8-00022d09712b                                                                                                                              
   label: (null)                                                                                                                                                              
   length: 7999415652352                                                                                                                                                      
   offset: 2147549184                                                                                                                                                         
   type: freebsd-zfs                                                                                                                                                          
   index: 2                                                                                                                                                                   
   end: 15628053127                                                                                                                                                           
   start: 4194432                                                                                                                                                             
Consumers:                                                                                                                                                                    
1. Name: da6                                                                                                                                                                  
   Mediasize: 8001563222016 (7.3T)
   Sectorsize: 512
   Stripesize: 4096
   Stripeoffset: 0
   Mode: r2w2e5

The output from when its connected to onboard will follow. Need to find a timeframe to do it.

#14 Updated by Alexander Motin over 4 years ago

So what's about the requested data? Or we shall close this?

#15 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Status changed from 15 to Closed: Insufficient Info

We can re-open when requested data is attached.

#16 Updated by Christian FitzGerald Forberg over 4 years ago

Sorry, I was very busy lately. And everybody around my expects all FreeNAS servers to run 247, if you know what I mean. I will provide the other output as soon as possible.

#17 Updated by Christian FitzGerald Forberg over 4 years ago

Here we go ... I connected the backup disk with the mainboard again. And these are the outputs:

[root@gaia] ~# camcontrol devlist
<ATA WDC WD20EFRX-68A 0A80>        at scbus0 target 7 lun 0 (pass0,da0)
<ATA WDC WD20EFRX-68A 0A80>        at scbus0 target 8 lun 0 (pass1,da1)
<ATA WDC WD20EFRX-68A 0A80>        at scbus0 target 9 lun 0 (pass2,da2)
<ATA WDC WD20EFRX-68E 0A82>        at scbus0 target 10 lun 0 (pass3,da3)
<ATA WDC WD20EFRX-68E 0A82>        at scbus0 target 11 lun 0 (pass4,da4)
<ATA WDC WD20EFRX-68E 0A82>        at scbus0 target 12 lun 0 (pass5,da5)
<INTEL SSDSA2M080G2GC 2CV102M3>    at scbus1 target 0 lun 0 (pass6,ada0)
<ST4000VN000-2AH166 SC60>          at scbus2 target 0 lun 0 (pass7,ada1)
[root@gaia] ~# geom disk list ada1
Geom name: ada1
Providers:
1. Name: ada1
   Mediasize: 4000787030016 (3.6T)
   Sectorsize: 512
   Stripesize: 4096
   Stripeoffset: 0
   Mode: r0w0e0
   descr: ST4000VN000-2AH166
   lunid: 5000c500926b11c1                                                                                                                  
   ident: ZDH01H78                                                                                                                          
   rotationrate: 5980                                                                                                                       
   fwsectors: 63                                                                                                                            
   fwheads: 16                                                                                                                              

[root@gaia] ~# geom part list ada1
Geom name: ada1
modified: false
state: OK
fwheads: 16
fwsectors: 63
last: 7814037134
first: 34
entries: 128
scheme: GPT
Providers:
1. Name: ada1p1
   Mediasize: 2147483648 (2.0G)
   Sectorsize: 512
   Stripesize: 4096
   Stripeoffset: 0
   Mode: r0w0e0
   rawuuid: 86457f5c-f2f7-11e6-946c-0cc47a401407
   rawtype: 516e7cb5-6ecf-11d6-8ff8-00022d09712b
   label: (null)
   length: 2147483648
   offset: 65536
   type: freebsd-swap
   index: 1
   end: 4194431
   start: 128
2. Name: ada1p2
   Mediasize: 3998639460352 (3.6T)
   Sectorsize: 512
   Stripesize: 4096
   Stripeoffset: 0
   Mode: r0w0e0
   rawuuid: 865d93c0-f2f7-11e6-946c-0cc47a401407
   rawtype: 516e7cba-6ecf-11d6-8ff8-00022d09712b
   label: (null)
   length: 3998639460352
   offset: 2147549184
   type: freebsd-zfs
   index: 2
   end: 7814037127
   start: 4194432
Consumers:
1. Name: ada1
   Mediasize: 4000787030016 (3.6T)
   Sectorsize: 512
   Stripesize: 4096
   Stripeoffset: 0
   Mode: r0w0e0

Since I have rotating backup disks (one stays in the system and gets replicated, the second one is physically somewhere else. One time a week, i swap them. They are mounted under different names and I have to rename the replication tasks but thats a different story) ...
I happen to have the second one with me today which is smaller (only 4TB) as you can see from the ouput.

I am running FreeNAS U2 by now, but the problem stays the same. When importing the volume, the list to select drives from stays empty. (There should be ada1p2)
I am going to reconnect this backup drive now to the m1015 and provide the same output for it:

[root@gaia] ~# camcontrol devlist
<ATA WDC WD20EFRX-68A 0A80>        at scbus0 target 7 lun 0 (pass0,da0)
<ATA WDC WD20EFRX-68A 0A80>        at scbus0 target 8 lun 0 (pass1,da1)
<ATA WDC WD20EFRX-68A 0A80>        at scbus0 target 9 lun 0 (pass2,da2)
<ATA WDC WD20EFRX-68E 0A82>        at scbus0 target 10 lun 0 (pass3,da3)
<ATA WDC WD20EFRX-68E 0A82>        at scbus0 target 11 lun 0 (pass4,da4)
<ATA WDC WD20EFRX-68E 0A82>        at scbus0 target 12 lun 0 (pass5,da5)
<ATA ST4000VN000-2AH1 SC60>        at scbus0 target 14 lun 0 (pass6,da6)
<INTEL SSDSA2M080G2GC 2CV102M3>    at scbus1 target 0 lun 0 (pass7,ada0)
[root@gaia] ~# geom disk list da6
Geom name: da6
Providers:
1. Name: da6
   Mediasize: 4000787030016 (3.6T)
   Sectorsize: 512
   Stripesize: 4096
   Stripeoffset: 0
   Mode: r0w0e0
   descr: ATA ST4000VN000-2AH1
   lunid: 5000c500926b11c1
   ident: ZDH01H78
   rotationrate: 5980
   fwsectors: 63
   fwheads: 255

[root@gaia] ~# geom part list da6
Geom name: da6
modified: false
state: OK
fwheads: 255
fwsectors: 63
last: 7814037134
first: 34
entries: 128
scheme: GPT
Providers:
1. Name: da6p1
   Mediasize: 2147483648 (2.0G)
   Sectorsize: 512
   Stripesize: 4096
   Stripeoffset: 0
   Mode: r0w0e0
   rawuuid: 86457f5c-f2f7-11e6-946c-0cc47a401407
   rawtype: 516e7cb5-6ecf-11d6-8ff8-00022d09712b
   label: (null)
   length: 2147483648
   offset: 65536
   type: freebsd-swap
   index: 1
   end: 4194431
   start: 128
2. Name: da6p2
   Mediasize: 3998639460352 (3.6T)
   Sectorsize: 512
   Stripesize: 4096
   Stripeoffset: 0
   Mode: r0w0e0
   rawuuid: 865d93c0-f2f7-11e6-946c-0cc47a401407
   rawtype: 516e7cba-6ecf-11d6-8ff8-00022d09712b
   label: (null)
   length: 3998639460352
   offset: 2147549184
   type: freebsd-zfs
   index: 2
   end: 7814037127
   start: 4194432
Consumers:
1. Name: da6
   Mediasize: 4000787030016 (3.6T)
   Sectorsize: 512
   Stripesize: 4096
   Stripeoffset: 0
   Mode: r0w0e0

Now the disc appears as da6p2 and can be imported without any problems. (Btw, I still need to provide recovery key and password. Just the password seems not to be enough)

#18 Updated by Christian FitzGerald Forberg over 4 years ago

The onboard controller is not configured as RAID. I checked BIOS just now, the controller is in AHCI mode. Further modes for all onboard sata slots are: HotPlug Enabled, Staggered SpinUP: Disabled.

Aggressive Link Power Management is Enabled though. Since I don't have a clue what that is, I never touched it.

#19 Updated by Alexander Motin over 4 years ago

  • Category changed from 59 to 2
  • Status changed from Closed: Insufficient Info to 19
  • Priority changed from No priority to Important
  • Seen in changed from Unspecified to 9.10.2-U2

I was able to reproduce your problem. It has nothing to do with the HBA model. It is a trivial bug in UI code, that was not showing ada1 disk in the list, since it mixed it with da1 which you already had imported.

#20 Updated by Christian FitzGerald Forberg over 4 years ago

Perfect! These no brainer bugs are a salvation sometimes. Esp. in comparison to these mean, unpredictable and unreproducable problems developers have to face so often.
Thanks!

#21 Updated by Alexander Motin over 4 years ago

  • Status changed from 19 to Needs Developer Review

I tested the fix and it works.

#22 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Status changed from Needs Developer Review to Resolved

Lgtm! Thanks Sasha!

#23 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Target version changed from 9.10.3 to 11.0

#24 Updated by Christian FitzGerald Forberg over 4 years ago

Hey Kris,

since this bug was only trivial, is it really necessary to fix it in version 11 and not in 9.10.3? I understood that 9.10.3 will be maintained for some time now and I for example will wait quite a while before using version 10 or 11 in production systems. The learning curve for me with FreeBSD (ZFS, Jails, etc) was steep and it took me a while to have my systems running perfectly. I am not going to move to version 10 so soon - just out of pragmatism. Also the whole migration from Jails to docker or to a custom jail system under version 10 is something I need to warm up to first. Now my FreeNAS system just need to work for a while. And maybe I am not the only one taking these considerations.
Thanks!

#25 Updated by Alexander Motin over 4 years ago

FreeNAS 10 is discontinued. You may find details on the forum. FreeNAS 11.0 will be released in place of 9.10.3, using its code base and FreeBSD 11-STABLE OS. There should be no big churn from this migration.

#26 Updated by Christian FitzGerald Forberg over 4 years ago

Oh my gosh ... I was totally unaware of what happened. Just read the whole story in the forums.
Thanks Alex for clarifying.

#27 Updated by Vaibhav Chauhan about 4 years ago

  • Target version changed from 11.0 to 11.0-RC

#28 Updated by Dru Lavigne almost 4 years ago

  • File deleted (debug-gaia-20170214214652.txz)

#29 Updated by Dru Lavigne almost 4 years ago

  • Private changed from Yes to No

Also available in: Atom PDF