Project

General

Profile

Bug #21259

Send Test Mail: tries to use IPv6

Added by Rebecca Cran over 3 years ago. Updated about 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
Nice to have
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When sending a test email via the Email tab in FreeNAS 9.10.2-U1, if the hostname contains both IPv4 and IPv6 records it appears it tries to use the IPv6 one, resulting in an error "No route to host". Note that this is with the default FreeNAS configuration of the system only having an IPv4 and no IPv6 address configured on the interface.

The network the NAS machine is on supports IPv6, so I'm not sure if that's a compounding factor.

History

#1 Updated by Rebecca Cran over 3 years ago

  • File debug-freenas-20170217165948.txz added

#2 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Assignee set to William Grzybowski
  • Priority changed from No priority to Nice to have
  • Target version set to 9.10.3
  • Seen in changed from Unspecified to 9.10.2-U1

I'm not sure how possible this is. William, if we have an IPv6 hostname and network is using IPv6 is there any way to detect a failure and fallback to IPv4? I would assume this isn't in the FreeNAS code but some other sendmail functionality, no?

#3 Updated by Rebecca Cran over 3 years ago

[root@freenas ~]# host mail.bluestop.org
mail.bluestop.org has address 74.50.51.35
mail.bluestop.org has IPv6 address 2605:7700:0:8:1:0:4a32:3323

[root@freenas ~]# telnet mail.bluestop.org 587
Trying 74.50.51.35...
Connected to mail.bluestop.org.

If the FreeNAS machine only has an IPv4 address, sendmail etc. shouldn't even be trying to connect over IPv6 from what I understand.

#4 Updated by William Grzybowski over 3 years ago

  • Status changed from Unscreened to 15

How can you be sure its trying to use ipv6? I see no indications of that whatsoever.

#5 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Target version changed from 9.10.3 to 9.10.4

#6 Updated by Rebecca Cran over 3 years ago

I can't be sure it's trying to use IPv6 - that was an assumption.

#7 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Target version changed from 9.10.4 to 11.1

#8 Updated by William Grzybowski over 3 years ago

  • Status changed from 15 to Closed: Cannot reproduce
  • Target version changed from 11.1 to N/A

#9 Updated by Dru Lavigne about 3 years ago

  • File deleted (debug-freenas-20170217165948.txz)

#10 Updated by Dru Lavigne about 3 years ago

  • Private changed from Yes to No

Also available in: Atom PDF