Project

General

Profile

Bug #21605

reduce log volume, minimize pipe logging [patch]

Added by Ash Gokhale over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Logging all pipe open calls via syslog should be disabled by default.

-Save dom wear, lengthen system life
-this facility is available for debugging though OS/execsnoop/dtrace; is redundant here
-ease debugging of critical system issues
-never have to grep -v autorepl in /var/log/messages
-increase retention period
-save syslog to message bandwidth for actual system events

/usr/local/www/freenasUI/common/pipesubr.py:

/usr/local/www/freenasUI/common
#diff pipesubr.py pipesubr.py.v                                                           :root:freenasUI/common:6:33:22:535zoltan-b
62c62
< def pipeopen(command, important=True, logger=log, allowfork=False, quiet=True, close_fds=False):
---
> def pipeopen(command, important=True, logger=log, allowfork=False, quiet=False, close_fds=False):
Exit 1
#         

Related issues

Is duplicate of FreeNAS - Bug #24189: dmidecode throwing alerts frequentlyClosed: Duplicate2017-05-25

Associated revisions

Revision 74edd0f2 (diff)
Added by William Grzybowski over 4 years ago

feat(gui): set pipeopen to quite=True by default Ticket: #21605

Revision e407e2cd (diff)
Added by William Grzybowski over 4 years ago

fix(gui): inheritance class for Support Ticket: #21605

Revision c7b8b6ee (diff)
Added by William Grzybowski over 4 years ago

fix(gui): only show Proactive Support for silver/gold Ticket: #21605

Revision bc83907c (diff)
Added by William Grzybowski over 4 years ago

fix(gui): simplify check and add Proactive Support in tree menu Ticket: #21605

Revision 57343467 (diff)
Added by William Grzybowski over 4 years ago

feat(gui): add verbose name Ticket: #21605

Revision f3242475 (diff)
Added by William Grzybowski over 4 years ago

feat(gui): docstring support model methods Ticket: #21605

Revision 9fdaf94d (diff)
Added by William Grzybowski over 4 years ago

fix(gui): update whole system tabs when updating license Ticket: #21605

Revision 9c013a4d (diff)
Added by William Grzybowski over 4 years ago

fix(gui): update migrate93 fixing stupid typo Ticket: #21605

Revision 96db65e8 (diff)
Added by William Grzybowski over 4 years ago

fix(gui): stupid typo Ticket: #21605

Revision f59dc762 (diff)
Added by William Grzybowski over 4 years ago

feat(gui): make all proactive support fields mandatory if its enabled Ticket: #21605

Revision 4e5da49f (diff)
Added by William Grzybowski over 4 years ago

fix(gui): allow enabled to be null Ticket: #21605

Revision 77979c04 (diff)
Added by William Grzybowski over 4 years ago

feat(alert): try to add all proactive support fields in the ticket Ticket: #21605

Revision 34ddc91f (diff)
Added by William Grzybowski over 4 years ago

fix(alert): typo Ticket: #21605

Revision fd832ac5 (diff)
Added by William Grzybowski over 4 years ago

feat(gui): add text in case proactive support has never been saved. Ticket: #21605

Revision 24534d7b (diff)
Added by William Grzybowski over 4 years ago

fix(gui): let Support.enabled be a NullBooleanField Ticket: #21605

Revision af31cb52 (diff)
Added by William Grzybowski over 4 years ago

fix(gui): inheritance class for Support Ticket: #21605 (cherry picked from commit e407e2cda39f2014bc2bb89e4f43727133625e28)

Revision 19fe311a (diff)
Added by William Grzybowski over 4 years ago

fix(gui): only show Proactive Support for silver/gold Ticket: #21605 (cherry picked from commit c7b8b6ee386803f1db57c4f0839e3f48468fd120)

Revision c9bab33b (diff)
Added by William Grzybowski over 4 years ago

fix(gui): simplify check and add Proactive Support in tree menu Ticket: #21605 (cherry picked from commit bc83907c2d6842dec90dd9ef9e16a5e522cc6dc5)

Revision ec8efe5a (diff)
Added by William Grzybowski over 4 years ago

feat(gui): add verbose name Ticket: #21605 (cherry picked from commit 57343467c5493ea4cd781d0ec0992630e457fe92)

Revision c2ea49f4 (diff)
Added by William Grzybowski over 4 years ago

feat(gui): docstring support model methods Ticket: #21605 (cherry picked from commit f32424753d65b9f9b87b668c511b9fd2fc35a9e9)

Revision 166c735f (diff)
Added by William Grzybowski over 4 years ago

fix(gui): update whole system tabs when updating license Ticket: #21605 (cherry picked from commit 9fdaf94d578d4dae1016865a21a69358911e126d)

Revision 1e04302c (diff)
Added by William Grzybowski over 4 years ago

fix(gui): stupid typo Ticket: #21605 (cherry picked from commit 96db65e8af46fbe99402715534db028580c6121f)

Revision cabaf27d (diff)
Added by William Grzybowski over 4 years ago

feat(gui): make all proactive support fields mandatory if its enabled Ticket: #21605 (cherry picked from commit f59dc76259c77b7b1273bed5d745702a3bb9a0b4)

Revision e3cd7f32 (diff)
Added by William Grzybowski over 4 years ago

fix(gui): allow enabled to be null Ticket: #21605 (cherry picked from commit 4e5da49fcac0243e558ec71a0c6d4cc10220e4a7)

Revision e7b9feca (diff)
Added by William Grzybowski over 4 years ago

feat(alert): try to add all proactive support fields in the ticket Ticket: #21605 (cherry picked from commit 77979c04084a98f126d8c7862c1d216f59db5210)

Revision 8e80c8f7 (diff)
Added by William Grzybowski over 4 years ago

fix(alert): typo Ticket: #21605 (cherry picked from commit 34ddc91fdac568d9c9d807dd2a6021bd6d1afb0b)

Revision 510b107b (diff)
Added by William Grzybowski over 4 years ago

feat(gui): add text in case proactive support has never been saved. Ticket: #21605 (cherry picked from commit fd832ac5569943d249f1bd18909bb611ec791452)

Revision 16f96100 (diff)
Added by William Grzybowski over 4 years ago

fix(gui): let Support.enabled be a NullBooleanField Ticket: #21605 (cherry picked from commit 24534d7b98346938524919ff7e4d454fa632828e)

Revision 132766d5 (diff)
Added by William Grzybowski over 4 years ago

fix(gui): inheritance class for Support Ticket: #21605 (cherry picked from commit e407e2cda39f2014bc2bb89e4f43727133625e28)

Revision 052432bd (diff)
Added by William Grzybowski over 4 years ago

fix(gui): only show Proactive Support for silver/gold Ticket: #21605 (cherry picked from commit c7b8b6ee386803f1db57c4f0839e3f48468fd120)

Revision 87a0ea88 (diff)
Added by William Grzybowski over 4 years ago

fix(gui): simplify check and add Proactive Support in tree menu Ticket: #21605 (cherry picked from commit bc83907c2d6842dec90dd9ef9e16a5e522cc6dc5)

Revision 9197dd83 (diff)
Added by William Grzybowski over 4 years ago

feat(gui): add verbose name Ticket: #21605 (cherry picked from commit 57343467c5493ea4cd781d0ec0992630e457fe92)

Revision 15764b0b (diff)
Added by William Grzybowski over 4 years ago

feat(gui): docstring support model methods Ticket: #21605 (cherry picked from commit f32424753d65b9f9b87b668c511b9fd2fc35a9e9)

Revision e6629e0a (diff)
Added by William Grzybowski over 4 years ago

fix(gui): update whole system tabs when updating license Ticket: #21605 (cherry picked from commit 9fdaf94d578d4dae1016865a21a69358911e126d)

Revision 23e59b13 (diff)
Added by William Grzybowski over 4 years ago

fix(gui): stupid typo Ticket: #21605 (cherry picked from commit 96db65e8af46fbe99402715534db028580c6121f)

Revision a371a4bf (diff)
Added by William Grzybowski over 4 years ago

feat(gui): make all proactive support fields mandatory if its enabled Ticket: #21605 (cherry picked from commit f59dc76259c77b7b1273bed5d745702a3bb9a0b4)

Revision ce2c639a (diff)
Added by William Grzybowski over 4 years ago

fix(gui): allow enabled to be null Ticket: #21605 (cherry picked from commit 4e5da49fcac0243e558ec71a0c6d4cc10220e4a7)

Revision 4c03187b (diff)
Added by William Grzybowski over 4 years ago

feat(alert): try to add all proactive support fields in the ticket Ticket: #21605 (cherry picked from commit 77979c04084a98f126d8c7862c1d216f59db5210)

Revision 8603df8f (diff)
Added by William Grzybowski over 4 years ago

fix(alert): typo Ticket: #21605 (cherry picked from commit 34ddc91fdac568d9c9d807dd2a6021bd6d1afb0b)

Revision d027bca4 (diff)
Added by William Grzybowski over 4 years ago

feat(gui): add text in case proactive support has never been saved. Ticket: #21605 (cherry picked from commit fd832ac5569943d249f1bd18909bb611ec791452)

Revision 3d374e15 (diff)
Added by William Grzybowski over 4 years ago

fix(gui): let Support.enabled be a NullBooleanField Ticket: #21605 (cherry picked from commit 24534d7b98346938524919ff7e4d454fa632828e)

History

#1 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Assignee set to William Grzybowski
  • Target version set to 9.10.3

Over to William for comment!

#2 Updated by William Grzybowski over 4 years ago

  • Status changed from Unscreened to Screened

Oh, those people who do not use unified diff! :)

#3 Updated by William Grzybowski over 4 years ago

Are you aware this is only one of the few places who do system calls and log?

#4 Updated by Ash Gokhale over 4 years ago

yes; however get the worst offenders first; must start somewhere. Are there other things that log every pipe operation?

#5 Updated by William Grzybowski over 4 years ago

  • Status changed from Screened to Resolved

#6 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Target version changed from 9.10.3 to 11.0

#7 Updated by Vaibhav Chauhan about 4 years ago

  • Target version changed from 11.0 to 11.0-RC

#8 Updated by William Grzybowski about 4 years ago

  • Is duplicate of Bug #24189: dmidecode throwing alerts frequently added

Also available in: Atom PDF