Project

General

Profile

Bug #21915

dmidecode running every hour

Added by Dave F over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
William Grzybowski
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Build: FreeNAS-9.10.2-U2 (e1497f2)
Platform: Intel(R) Xeon(R) CPU E3-1220 v3 @ 3.10GHz
Memory: 16314MB

ChangeLog Required:
No

Description

Mar  7 04:46:48 tardis alert.py: [common.pipesubr:66] Popen()ing: /usr/local/sbin/dmidecode -s system-product-name
Mar  7 04:46:48 tardis alert.py: [common.pipesubr:66] Popen()ing: /usr/local/sbin/dmidecode -s baseboard-product-name
Mar  7 05:46:54 tardis alert.py: [common.pipesubr:66] Popen()ing: /usr/local/sbin/dmidecode -s system-product-name
Mar  7 05:46:54 tardis alert.py: [common.pipesubr:66] Popen()ing: /usr/local/sbin/dmidecode -s baseboard-product-name
Mar  7 06:47:00 tardis alert.py: [common.pipesubr:66] Popen()ing: /usr/local/sbin/dmidecode -s system-product-name
Mar  7 06:47:00 tardis alert.py: [common.pipesubr:66] Popen()ing: /usr/local/sbin/dmidecode -s baseboard-product-name
Mar  7 07:47:07 tardis alert.py: [common.pipesubr:66] Popen()ing: /usr/local/sbin/dmidecode -s system-product-name
Mar  7 07:47:07 tardis alert.py: [common.pipesubr:66] Popen()ing: /usr/local/sbin/dmidecode -s baseboard-product-name
Mar  7 08:47:13 tardis alert.py: [common.pipesubr:66] Popen()ing: /usr/local/sbin/dmidecode -s system-product-name
Mar  7 08:47:13 tardis alert.py: [common.pipesubr:66] Popen()ing: /usr/local/sbin/dmidecode -s baseboard-product-name
Mar  7 09:47:19 tardis alert.py: [common.pipesubr:66] Popen()ing: /usr/local/sbin/dmidecode -s system-product-name
Mar  7 09:47:19 tardis alert.py: [common.pipesubr:66] Popen()ing: /usr/local/sbin/dmidecode -s baseboard-product-name
Mar  7 10:47:26 tardis alert.py: [common.pipesubr:66] Popen()ing: /usr/local/sbin/dmidecode -s system-product-name
Mar  7 10:47:26 tardis alert.py: [common.pipesubr:66] Popen()ing: /usr/local/sbin/dmidecode -s baseboard-product-name

This appears in my logs every hour. I'm assuming it's for the ASRock C2x50D4I, which I do not have. Although my board is ASRock, it's a C224 chipset.

Does this have to run every hour, shouldn't it only run at boot?


Related issues

Is duplicate of FreeNAS - Feature #23777: Disable ASRock BMC firmware version check once version is not <0.30Closed: Duplicate2017-05-04

Associated revisions

Revision 2252611e (diff)
Added by William Grzybowski over 4 years ago

feat(alert): add fire_once attribute to alerts Ticket: #21915

Revision c09f29bc (diff)
Added by William Grzybowski over 4 years ago

fix(alert): freenas bmc alert is of type "fire_once" Ticket: #21915

History

#1 Updated by Bonnie Follweiler over 4 years ago

  • Assignee set to Sean Fagan

#2 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Assignee changed from Sean Fagan to William Grzybowski
  • Priority changed from No priority to Nice to have
  • Target version set to 9.10.3

This may be intentional, perhaps part of some debug or alert monitoring? William?

#3 Updated by William Grzybowski over 4 years ago

  • Status changed from Unscreened to Screened

#4 Updated by Cpu Roast over 4 years ago

I assume it might be related to the Asrock Avoton board check used by many people including the FreeNAS Minis:

On my non-Avoton boxes it just returns this:

Asrock E3C226D2I
----------------
/usr/local/sbin/dmidecode -s baseboard-product-name
E3C226D2I

/usr/local/sbin/dmidecode -s system-product-name
To Be Filled By O.E.M.

Supermicro X10SRH-CLN4F inside a Supermicro SuperStorage Server 5048R-E1CR36L
-----------------------------------------------------------------------------
/usr/local/sbin/dmidecode -s baseboard-product-name
X10SRH-CLN4F
Invalid entry length (16). Fixed up to 11.

/usr/local/sbin/dmidecode -s system-product-name
SSG-5048R-E1CR36L
Invalid entry length (16). Fixed up to 11.

#5 Updated by William Grzybowski over 4 years ago

It showing in the logs is just an overly verbose call.

The alert were designed to do periodically checks, 60 minutes was the chosen value. It is not a big deal, the logs have already been removed in nightlies and I'll increase the time check.

#6 Updated by Erik Thorsell over 4 years ago

William Grzybowski wrote:

It showing in the logs is just an overly verbose call.

The alert were designed to do periodically checks, 60 minutes was the chosen value. It is not a big deal, the logs have already been removed in nightlies and I'll increase the time check.

Is there a way to turn this off? As for now my otherwise quite clean and informative log gets clogged with these outputs.

#7 Updated by William Grzybowski over 4 years ago

Erik Thorsell wrote:

William Grzybowski wrote:

It showing in the logs is just an overly verbose call.

The alert were designed to do periodically checks, 60 minutes was the chosen value. It is not a big deal, the logs have already been removed in nightlies and I'll increase the time check.

Is there a way to turn this off? As for now my otherwise quite clean and informative log gets clogged with these outputs.

No.

#8 Updated by William Grzybowski over 4 years ago

  • Status changed from Screened to Resolved

#9 Updated by William Grzybowski over 4 years ago

  • Status changed from Resolved to Ready For Release

#10 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Target version changed from 9.10.3 to 11.0

#11 Updated by Vaibhav Chauhan about 4 years ago

  • Target version changed from 11.0 to 11.0-RC

#12 Updated by Vaibhav Chauhan about 4 years ago

  • Status changed from Ready For Release to Resolved

#13 Updated by William Grzybowski about 4 years ago

  • Is duplicate of Feature #23777: Disable ASRock BMC firmware version check once version is not <0.30 added

#14 Updated by Erik Thorsell about 4 years ago

William Grzybowski wrote:

It showing in the logs is just an overly verbose call.

The alert were designed to do periodically checks, 60 minutes was the chosen value. It is not a big deal, the logs have already been removed in nightlies and I'll increase the time check.

I was under the impression this would go away in the next update, but as for FreeNAS-9.10.2-U4 (27ae72978), the overly verbose messages are still present.

#15 Updated by Dave F about 4 years ago

Erik Thorsell wrote:

William Grzybowski wrote:

It showing in the logs is just an overly verbose call.

The alert were designed to do periodically checks, 60 minutes was the chosen value. It is not a big deal, the logs have already been removed in nightlies and I'll increase the time check.

I was under the impression this would go away in the next update, but as for FreeNAS-9.10.2-U4 (27ae72978), the overly verbose messages are still present.

The resolution is present in the FreeNAS 11.0-RC as per the 'Target version'.

Also available in: Atom PDF