Project

General

Profile

Bug #22231

zfs recv -s option missing (regression?) in 9.10.2 (was present in 9.10 and 9.10.1)

Added by Philip Spigelmire over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Expected
Assignee:
Alexander Motin
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

In 9.10.2 u2:

[root] ~# zfs recv -s
invalid option 's'

In 9.10:

[root] ~# zfs recv -s
missing snapshot argument

Interestingly, zfs send -t is available in both versions and the man page includes the zfs recv -s in 9.10.2

Associated revisions

Revision e61af44a (diff)
Added by Alexander Motin over 4 years ago

Fix mismerge, breaking resumable receive. Ticket: #22231

Revision e61af44a (diff)
Added by Alexander Motin over 4 years ago

Fix mismerge, breaking resumable receive. Ticket: #22231

Revision 719be486 (diff)
Added by Alexander Motin over 4 years ago

Fix mismerge, breaking resumable receive. Ticket: #22231 (cherry picked from commit e61af44a5c56b945cd9e332235ea235bfd441db7)

Revision 719be486 (diff)
Added by Alexander Motin over 4 years ago

Fix mismerge, breaking resumable receive. Ticket: #22231 (cherry picked from commit e61af44a5c56b945cd9e332235ea235bfd441db7)

Revision 41e6a40a (diff)
Added by Alexander Motin over 4 years ago

Fix mismerge, breaking resumable receive. Ticket: #22231 (cherry picked from commit e61af44a5c56b945cd9e332235ea235bfd441db7)

Revision 41e6a40a (diff)
Added by Alexander Motin over 4 years ago

Fix mismerge, breaking resumable receive. Ticket: #22231 (cherry picked from commit e61af44a5c56b945cd9e332235ea235bfd441db7)

Revision 04a69b3e (diff)
Added by Alexander Motin over 4 years ago

Fix mismerge, breaking resumable receive. Ticket: #22231 (cherry picked from commit e61af44a5c56b945cd9e332235ea235bfd441db7)

Revision 04a69b3e (diff)
Added by Alexander Motin over 4 years ago

Fix mismerge, breaking resumable receive. Ticket: #22231 (cherry picked from commit e61af44a5c56b945cd9e332235ea235bfd441db7)

Revision f7a19bc0 (diff)
Added by Alexander Motin over 4 years ago

Fix another piece of mismerge, breaking resumable receive. Ticket: #22231

Revision f7a19bc0 (diff)
Added by Alexander Motin over 4 years ago

Fix another piece of mismerge, breaking resumable receive. Ticket: #22231

Revision e4ec2723 (diff)
Added by Alexander Motin over 4 years ago

Fix another piece of mismerge, breaking resumable receive. Ticket: #22231 (cherry picked from commit f7a19bc098ce2b66a30534c1e2d9f1af3dad12d5)

Revision e4ec2723 (diff)
Added by Alexander Motin over 4 years ago

Fix another piece of mismerge, breaking resumable receive. Ticket: #22231 (cherry picked from commit f7a19bc098ce2b66a30534c1e2d9f1af3dad12d5)

Revision 49f3210c (diff)
Added by Alexander Motin over 4 years ago

Fix another piece of mismerge, breaking resumable receive. Ticket: #22231 (cherry picked from commit f7a19bc098ce2b66a30534c1e2d9f1af3dad12d5)

Revision 49f3210c (diff)
Added by Alexander Motin over 4 years ago

Fix another piece of mismerge, breaking resumable receive. Ticket: #22231 (cherry picked from commit f7a19bc098ce2b66a30534c1e2d9f1af3dad12d5)

History

#2 Updated by Bonnie Follweiler over 4 years ago

  • Assignee set to William Grzybowski

#3 Updated by William Grzybowski over 4 years ago

  • Assignee changed from William Grzybowski to Alexander Motin

If think Sasha knows about it more than I do.

#4 Updated by Alexander Motin over 4 years ago

  • Status changed from Unscreened to Screened
  • Priority changed from No priority to Expected

It seems to be result of incorrect merge of other local patch, that axed out part of the resumable receive patch. This is exactly why I hate local patches!

#5 Updated by Alexander Motin over 4 years ago

  • Status changed from Screened to 19
  • Target version set to 9.10.3

I fixed few mismerges. Hopefully it will be enough to fix the problem.

#6 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

Mav: This looks good here. If you are happy with it, go ahead and mark it resolved.

#7 Updated by Alexander Motin over 4 years ago

  • Status changed from 19 to Resolved

Actual testing shown that it was still broken, but after adding another one-line patch it now works on my tests.

#8 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Target version changed from 9.10.3 to 11.0

#9 Updated by Philip Spigelmire over 4 years ago

I recently updated to FreeNAS-9.10.2-U3 (e1497f269) and now I get:

# zfs recv -s
internal error: out of memory

#10 Updated by Alexander Motin over 4 years ago

You may see that Target version is set for 11.0. 9.10.2-U3 update was released for the only reason of fixing Samba directory listing performance problem.

#11 Updated by Philip Spigelmire over 4 years ago

Yes, I see that, and I wasn't expecting a different result from the command, but since it did not respond to the "missing option" error, I wanted to make sure you were aware.

#13 Updated by Vaibhav Chauhan about 4 years ago

  • Target version changed from 11.0 to 11.0-RC

Also available in: Atom PDF