Project

General

Profile

Bug #22331

FPDMA TRIM fails on ASMedia ASM1061 AHCI SATA controller

Added by Jason Keller over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Important
Assignee:
Alexander Motin
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Upon trying to install fresh or upgrade from FreeNAS-9.10.2-U2 (e1497f2) with an OWC Mercury Accelsior 2 PCIe mSATA adapter (bootable; used as boot drive), system hangs continually retrying with..

SEND_FPDMA_QUEUED DATA SET MANAGEMENT
CAM status: Command timeout
Retrying command

Works fine in FreeNAS-9.10.2-U2 (e1497f2), but Corral fails with this error. New driver issue?

IMG_4847.PNG (1.97 MB) IMG_4847.PNG Jason Keller, 03/18/2017 11:30 AM
10001

Associated revisions

Revision a1ca459f (diff)
Added by Alexander Motin over 4 years ago

Block FPDMA TRIM for ASMedia HBAs. Experiments show FPDMA TRIM command timeouts on ASMedia HBAs, while the same SSDs working fine on Intel HBAs. (cherry picked from commit 1384f37b768f0b9971a49238eb7cea0c1acecc6c) Ticket: #22331

Revision a1ca459f (diff)
Added by Alexander Motin over 4 years ago

Block FPDMA TRIM for ASMedia HBAs. Experiments show FPDMA TRIM command timeouts on ASMedia HBAs, while the same SSDs working fine on Intel HBAs. (cherry picked from commit 1384f37b768f0b9971a49238eb7cea0c1acecc6c) Ticket: #22331

History

#1 Updated by Jordan Hubbard over 4 years ago

  • Seen in changed from to

#2 Updated by Alexander Motin over 4 years ago

  • Status changed from Unscreened to 15

Could you provide more data? Even screenshot of the errors could be useful.

#3 Updated by Jason Keller over 4 years ago

10001

Screenshot of a video I took to catch the error displayed on the screen during the failed upgrade (it's identical to what appears during an install attempt). I've tried multiple different mSATA drives and even a second identical adapter with multiple different mSATA drives to rule out any hardware defects.

Adapter is in a Supermicro X9SCM with a Xeon E3-1240 and 16GB ECC memory. I've also tried a different chassis with an Intel motherboard that exhibited exactly the same behavior, so it appears entirely isolated to this adapter chipset (ASMedia ASM1061). Please let me know if any further information is needed and I will try to get it to you in as timely a manner as I can.

#4 Updated by Alexander Motin over 4 years ago

  • Status changed from 15 to Screened

According to provided screenshot it looks like NCQ command was not completed by the drive, or HBA haven't noticed that. I don't know how this could be related to the driver changes done recent time. I have no good ideas.

#5 Updated by Jason Keller over 4 years ago

Would live access to the system running 9.10.2 U2 help? I could arrange a remote session with you.

#6 Updated by Alexander Motin over 4 years ago

Lets try, if you propose.

#7 Updated by Alexander Motin over 4 years ago

  • Status changed from Screened to Investigation

It seems like the problem is related to NCQ version of TRIM command. Either the HBA or the SSD does not handle requests properly and cause timeouts. Disabling NCQ TRIM in run time seems fixes the issue. Same should help global TRIM disable via setting vfs.zfs.trim.enabled=0 loader tunable, but I haven't tried. Unfortunately I have no any NCQ TRIM capable SSD in my lab now to investigate this area deeper easier.

#8 Updated by Alexander Motin over 4 years ago

It seems like the problem is indeed related to the ASmedia HBA. At least the same SSD on Intel HBA seems like working. I'll try to buy some NCQ TRIM capable SSD to test this locally on ASmedia HBA I have.

#9 Updated by Alexander Motin over 4 years ago

I haven't found anything appropriate on local market. :(

#10 Updated by Alexander Motin over 4 years ago

  • Project changed from 9 to FreeNAS
  • Category changed from 184 to 76
  • Target version set to 9.10.3

Reassign to 9.10.3, since it should also suffer from this problem.

#11 Updated by Alexander Motin over 4 years ago

  • Status changed from Investigation to 19
  • Priority changed from No priority to Important
  • Seen in changed from to 9.10.3

#12 Updated by Alexander Motin over 4 years ago

  • Subject changed from ASMedia ASM1061 AHCI SATA controller fails in Corral to FPDMA TRIM fails on ASMedia ASM1061 AHCI SATA controller

#13 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Target version changed from 9.10.3 to 11.0

#14 Updated by Alexander Motin over 4 years ago

  • Status changed from 19 to Resolved

Originator confirmed issue resolved.

#15 Updated by Vaibhav Chauhan about 4 years ago

  • Target version changed from 11.0 to 11.0-RC

Also available in: Atom PDF