Project

General

Profile

Bug #22383

Update from 9.10 to Corral

Added by Alexander Kolganov over 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Expected
Assignee:
Marcelo Araujo
Category:
Middleware
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I can not upgrade current 9.10 nightlies to Corral RELEASE/nightlies. Updated finishes with pyton 3.6 error log.

VMs errors.jpg (445 KB) VMs errors.jpg error with VMs menu Alexander Kolganov, 03/18/2017 10:20 AM
error_net.jpg (305 KB) error_net.jpg Alexander Kolganov, 03/21/2017 06:31 AM
9998
10077

History

#1 Updated by Alexander Kolganov over 3 years ago

  • File debug-bfreenas-20170318075645.txz added

#2 Updated by Sean Fagan over 3 years ago

  • Assignee set to Suraj Ravichandran

Sending to Suraj.

#3 Updated by Suraj Ravichandran over 3 years ago

  • Project changed from FreeNAS to 9
  • Category changed from 1 to 185
  • Status changed from Unscreened to 15
  • Priority changed from No priority to Expected
  • Target version set to 384
  • Parent task set to #19560
  • Branch set to master

Hi @Alexander Kolganov,

I tried to find the issue in your logs but could not.

Can I request you try the following verbose shell based update command and paste the output (all of it) in case anything goes wrong:

freenas-update -v -T FreeNAS-Corral-Nightlies update

Thanks

#4 Updated by Alexander Kolganov over 3 years ago

Can I run the following command:
freenas-update -v -T FreeNAS-Corral-Release update
?

#5 Updated by Alexander Kolganov over 3 years ago

I tried to upgrade via consol:

freenas-update -v -T FreeNAS-Corral-Nightlies update

It was done successfully, but most all settings did not migrate: jails, smb, VMs...

#6 Updated by Alexander Kolganov over 3 years ago

I think the new version of pyton (3.6) does not work correctly in GUI.

#7 Updated by Jordan Hubbard over 3 years ago

There may be some issues with the updater, but it looks like user expectations are also incorrect regarding jails, etc. They should read https://wiki.freenas.org/index.php/Migrating_from_9.X_to_FreeNAS_Corral

#8 Updated by Alexander Kolganov over 3 years ago

9998

Okey, may be. So, I revert Corral to 9.10, and I have some problem with installed pyton 3.6 in GUI. Later, the VMs menu worked correctly, but now - does not. The scrinshort demonstrates it.

#9 Updated by Suraj Ravichandran over 3 years ago

9.10 stuff not working has nothing to do with the update to 10 (they happen in separate boot environments).

I see that your update succeeded the second time but you say smb settings were not migrated over (note: jails and vms will not be migrated as we do not support that)

Can you get me a debug file (from the 10 boot environment) (GUI --> System --> Debug --> Download Debug File) and I shall investigate why smb settings were not migrated.

Thanks

#10 Updated by Alexander Kolganov over 3 years ago

  • File debug-freenas-20170319132306.tgz added

I downgrade to 9.10 and I cant load Corral version because it takes many time for upgrade to Corral and restore back. I'll wait for a while until the bugs will fixed.
I note that Corral uses only smb_3, but 9.10 version has smb_31.
For this time I want the bug to be fixed with VMsшт 9.10. Debug info was attached.

#11 Updated by Suraj Ravichandran over 3 years ago

  • Project changed from 9 to FreeNAS
  • Category changed from 185 to 201
  • Status changed from 15 to Unscreened
  • Assignee changed from Suraj Ravichandran to Marcelo Araujo
  • Target version deleted (384)
  • Parent task deleted (#19560)

Well if you want the Vm issue fixed in 9.10 then I have to hand this over to my colleague who is in charge of that.

#12 Updated by Marcelo Araujo over 3 years ago

  • Status changed from Unscreened to Resolved

Hi,

I have fixed it yesterday! If you update your FreeNAS you will get the change and it will work again.

Fix: https://github.com/freenas/freenas/commit/42d6e3d5d478c42c2ba97f4b8b3fbb67e1df9fb3

Best,

#13 Updated by Alexander Kolganov over 3 years ago

thanks

#14 Updated by Alexander Kolganov over 3 years ago

10077

I found the same bug on reporting/Network tab

#15 Updated by Marcelo Araujo over 3 years ago

Alexander Kolganov wrote:

I found the same bug on reporting/Network tab

I'm running FreeNAS-9.10-MASTER-201703210409 (142d3e8) and I can't reproduce.

What version are you using?

Best,

#16 Updated by Alexander Kolganov over 3 years ago

I use 9.10-MASTER-201703210409 version from Corral downgrade. I think Corral update affects 9.10 version

#17 Updated by Jordan Hubbard over 3 years ago

Nope, it can't. It's installing in a completely independent Boot Environment.

#18 Updated by Alexander Kolganov over 3 years ago

  • File debug-freenas-20170321200151.tgz added

I attached new debug info

#19 Updated by Marcelo Araujo over 3 years ago

  • Status changed from Resolved to Investigation

OK, I'm reopening this ticket and I will take a look on it.

#20 Updated by Marcelo Araujo over 3 years ago

Hi Alexander,

I need your help to debug this problem, I would like you to do two steps for me:

1) Inside /var/db/collectd/rrd/ you will find another directory with the hostname of your machine(Ex. in my case: freenas.local), please tarball all those files inside and send it to me. You can try to attach the tarball here or you can send to my email .

2) After you do the step 1, that also would be more less a backup, could you delete all those sub-directories inside /var/db/collectd/rrd/<machine_hostname>/.

Note: Be careful to run the right command and in the right path at the step number 2, if you remove accidentally anything else, it would be hard to recover.

If you don't feel confident to do the step number 2, let me know and we can set a time where I can do a VNC on your machine and run the step 2 for you.

Best,

#21 Updated by Marcelo Araujo over 3 years ago

  • Status changed from Investigation to 15

#22 Updated by Alexander Kolganov over 3 years ago

  • File localhost.tar.gz added

I attached "localhost" directory from /var/db/collectd/rrd/ path. Why do I need to delete all folders from "localhost" ?

#23 Updated by Marcelo Araujo over 3 years ago

  • Status changed from 15 to Investigation

Thanks for the file, I'm checking it right now.

#24 Updated by Marcelo Araujo over 3 years ago

  • Status changed from Investigation to 15

Hi,

OK, I guess it was fixed already at commit: 3be5cedd29d74e54ce82a206801f8905c097716e
Could you make a try again with the latest Nightlies?

Thanks,

#25 Updated by Alexander Kolganov over 3 years ago

The Network tab is working now correctly!

#26 Updated by Marcelo Araujo over 3 years ago

  • Status changed from 15 to Resolved

Thank you for the feedback. I'm closing this ticket.

Best,

#27 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Seen in changed from Unspecified to N/A

#28 Updated by Dru Lavigne about 3 years ago

  • File deleted (debug-bfreenas-20170318075645.txz)

#29 Updated by Dru Lavigne about 3 years ago

  • File deleted (debug-freenas-20170319132306.tgz)

#30 Updated by Dru Lavigne about 3 years ago

  • File deleted (debug-freenas-20170321200151.tgz)

#31 Updated by Dru Lavigne about 3 years ago

  • File deleted (localhost.tar.gz)

#32 Updated by Dru Lavigne about 3 years ago

  • Private changed from Yes to No

#33 Updated by Dru Lavigne almost 3 years ago

  • Target version set to Master - FreeNAS Nightlies

Also available in: Atom PDF