Project

General

Profile

Bug #22622

FN 9.10-MASTER GUI Update Process does not advance the status of the "Applying Pending Update" box.

Added by Alec Pearson over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Important
Assignee:
William Grzybowski
Category:
OS
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

HP Microserver G7
8GB RAM

ChangeLog Required:
No

Description

FN 9.10-MASTER nightlies GUI Update Process does not advance the status of the "Applying Pending Update" box.
The FN 9.10.2 all worked fine.
The progress bars stop at 100% in the upper bar and 20% in the lower installing the base OS.
If you wait long enough, some 20 minutes, the update does complete and the server reboots.
The same behaviour has been seen on the last two nightlies.
The update target is a 8GB USB stick.

History

#1 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Assignee set to William Grzybowski
  • Priority changed from No priority to Important
  • Target version set to 9.10.3

#2 Updated by William Grzybowski over 3 years ago

  • Status changed from Unscreened to Screened

#3 Updated by William Grzybowski over 3 years ago

  • Status changed from Screened to 15

I could not reproduce the issue so far.

Were you watching the progress the whole time?
It could be because it was not a delta upgrade (so it had to reinstall the whole base-os package, which is the biggest (~95%)). The base-os install itself takes a long time while the others are quite fast.

#4 Updated by Alec Pearson over 3 years ago

I tried an update from master-201703220408 to ....3240408.
After 6 minutes there was a traceback.

Request Method:     POST
Request URL:     http://10.10.0.13/system/update/check/?uuid=cdf55729025d4f339624d1c46c8bf202
Software Version:     FreeNAS-9.10-MASTER-201703220408 (50f5dd1)
Exception Type:     OperationalError
Exception Value:     database is locked

Exception Location:     ./freenasUI/freeadmin/sqlite3_ha/base.py in locked_retry, line 406
Server time:     Fri, 24 Mar 2017 15:44:28 +0000
...................................................................
Traceback

Environment:

Software Version: FreeNAS-9.10-MASTER-201703220408 (50f5dd1)
Request Method: POST
Request URL: http://10.10.0.13/system/update/check/?uuid=cdf55729025d4f339624d1c46c8bf202

Traceback:
File "/usr/local/lib/python3.6/site-packages/django/db/backends/utils.py" in execute
  64.                 return self.cursor.execute(sql, params)
File "./freenasUI/freeadmin/sqlite3_ha/base.py" in execute
  424.         execute = self.locked_retry(Database.Cursor.execute, query, params)
File "./freenasUI/freeadmin/sqlite3_ha/base.py" in locked_retry
  406.                 rv = method(self, *args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/exception.py" in inner
  39.             response = get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _legacy_get_response
  244.             response = middleware_method(request)
File "./freenasUI/freeadmin/middleware.py" in process_request
  184.             language = Settings.objects.order_by('-id')[0].stg_language
File "/usr/local/lib/python3.6/site-packages/django/db/models/query.py" in __getitem__
  295.         return list(qs)[0]
File "/usr/local/lib/python3.6/site-packages/django/db/models/query.py" in __iter__
  256.         self._fetch_all()
File "/usr/local/lib/python3.6/site-packages/django/db/models/query.py" in _fetch_all
  1087.             self._result_cache = list(self.iterator())
File "/usr/local/lib/python3.6/site-packages/django/db/models/query.py" in __iter__
  54.         results = compiler.execute_sql()
File "/usr/local/lib/python3.6/site-packages/django/db/models/sql/compiler.py" in execute_sql
  835.             cursor.execute(sql, params)
File "/usr/local/lib/python3.6/site-packages/django/db/backends/utils.py" in execute
  64.                 return self.cursor.execute(sql, params)
File "/usr/local/lib/python3.6/site-packages/django/db/utils.py" in __exit__
  94.                 six.reraise(dj_exc_type, dj_exc_value, traceback)
File "/usr/local/lib/python3.6/site-packages/django/utils/six.py" in reraise
  685.             raise value.with_traceback(tb)
File "/usr/local/lib/python3.6/site-packages/django/db/backends/utils.py" in execute
  64.                 return self.cursor.execute(sql, params)
File "./freenasUI/freeadmin/sqlite3_ha/base.py" in execute
  424.         execute = self.locked_retry(Database.Cursor.execute, query, params)
File "./freenasUI/freeadmin/sqlite3_ha/base.py" in locked_retry
  406.                 rv = method(self, *args, **kwargs)

Exception Type: OperationalError at /system/update/check/
Exception Value: database is locked

Request information
GET
Variable     Value
uuid     'cdf55729025d4f339624d1c46c8bf202'
POST

No POST data
FILES

No FILES data
COOKIES
Variable     Value
csrftoken     'ijPMqnSWuImujpNqFaruCz7oWmeDYglhNIiv1QN6zpwxaz8mqNmoy8jzwwZLRs7w'
fntreeSaveStateCookie     'root%2Croot%2F160%2F166%2F168%2Croot%2F165'
sessionid     'bqnplww53dc87ea24tco3relt01wblq4'
META
Variable     Value

The boot device has an entry for 03240408 but it cannot be activated or deleted.
I did a reboot and a successful boot scrub and tried again with the same result.

Started over with a different USB stick.

To cut a long story short it looks like a boot device issue.
There was a lot of cr*p on the boot device not associated with FN

Please close this and keep up the good work.

#5 Updated by William Grzybowski over 3 years ago

  • Status changed from 15 to Closed
  • Target version changed from 9.10.3 to N/A

Understood, let us know if you see that again.

Thanks

Also available in: Atom PDF