Project

General

Profile

Bug #22638

Avatar?id=14398&size=22x22

Starting NATed jails always flushes ipfw table

Added by Ben Greiner over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Important
Assignee:
Kris Moore
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

There is a bug in the warden backend script startjail.sh that causes the ipfw filter table to always get flushed
before a new NAT rule is inserted. If you have more than one NATed jail the rules for those get lost then when the next jail is started.

The cause for this is that sysrc in the current FreeNAS by default reports the variable names and the values but the script only checks for the value.

Please see attached patch to fix the issue by telling sysrc to only report the values of firewall_enable and firewall_type

Regards,
Ben

Associated revisions

Revision 92f28dba (diff)
Added by Kris Moore over 4 years ago

Fix an issue where firewall_enable and firewall_type aren't properly checked with sysrc command Ticket: #22638

History

#1 Updated by Ben Greiner over 4 years ago

  • File startjail.sh.patch added

#2 Updated by Ben Greiner over 4 years ago

  • Seen in changed from Unspecified to 9.10.2-U2

#3 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Status changed from Unscreened to Reviewed
  • Assignee set to Kris Moore
  • Priority changed from No priority to Important
  • Target version set to 9.10.3

Looks good! Thanks for the patch.

#4 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Target version changed from 9.10.3 to 11.0

#5 Updated by Vaibhav Chauhan about 4 years ago

  • Status changed from Reviewed to Resolved

#6 Updated by Vaibhav Chauhan about 4 years ago

  • Target version changed from 11.0 to 11.0-RC

#7 Updated by Dru Lavigne over 3 years ago

  • File deleted (startjail.sh.patch)

Also available in: Atom PDF