Project

General

Profile

Bug #23275

Avatar?id=14398&size=22x22

Compression algorithm error messages shown before grub boot menu

Added by Warren Block over 3 years ago. Updated about 3 years ago.

Status:
Closed: Duplicate
Priority:
No priority
Assignee:
Kris Moore
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Before the grub boot menu appears, errors about an unsupported compression algorithm flash past on the screen:

error: compression algerror: compression algorithm inherit not supported

.

error: compressionorithm inherit not supported

.

error: compression algorithm inherit not supporte algorithm inherit not supported

.

error: compression algorithm id

.

error: compression algorithm inherit not supported

.

error: compression algorithm inherit not supported
nherit not supported

.

error: compression algorithm inherit not supported

.

error: unsupported embedded BP (
.

error: unsupported embedded BP (type=128)

.

error: unsuptype=128)

These do not appear to cause other problems, but will cause end-user concern.


Related issues

Related to FreeNAS - Bug #20819: Possible Errors with Grub?? Compression algorithm 104 not supportedClosed: Third party to resolve2017-02-02
Related to FreeNAS - Bug #25052: Getting compression algorithm not supported on boot.Closed: Behaves correctly2017-07-07

History

#1 Updated by Bonnie Follweiler over 3 years ago

  • Assignee set to Sean Fagan

#2 Updated by Sean Fagan over 3 years ago

  • Category changed from 1 to 200
  • Status changed from Unscreened to Closed: Behaves correctly

As stated, it doesn't cause problems. (It's grub scanning disks and not knowing what to do with the newer version of ZFS on them. As long as you don't do a zfs upgrade on your boot pool, it's harmless.)

#3 Updated by Warren Block over 3 years ago

  • Status changed from Closed: Behaves correctly to Unscreened
  • Assignee changed from Sean Fagan to Kris Moore
  • Target version set to 9.10.4

Reassigned to Kris by request, since this should change or go away with the BSD bootloader.

#4 Updated by Warren Block over 3 years ago

  • Related to Bug #20819: Possible Errors with Grub?? Compression algorithm 104 not supported added

#5 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Target version changed from 9.10.4 to 11.1

#6 Updated by Warren Block over 3 years ago

  • Related to Bug #25052: Getting compression algorithm not supported on boot. added

#7 Updated by Dru Lavigne about 3 years ago

  • Status changed from Unscreened to Closed: Duplicate
  • Target version changed from 11.1 to N/A

Duplicate of 25052.

Also available in: Atom PDF