Project

General

Profile

Bug #23319

removed drive cannot be wiped

Added by T F over 3 years ago. Updated almost 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
Nice to have
Assignee:
Nick Wolff
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I had an active drive get removed from an encrypted RAIDZ3 pool. This resulted in one of the hot spares automatically being placed "IN USE" and resilvered. I then "DETACHED" the "REMOVED" drive and found the resulting drive now shows up in the "View Disks" section of storage. I'm told the proper way to get the drive back into the pool is to wipe it and then re-add it as a hot spare to replace the spare that is now being used by a vdev. However, attempts to wipe the drive are failing both in the UI & in the CLI with "operation not permitted errors"

UI message when trying to wipe disk: dd: /dev/da34: Operation not permitted
^same message displayed when trying to dd if=/dev/zero of=/dev/da34 on CLI


Related issues

Related to FreeNAS - Bug #29165: still cannot remove wiped drive (continued from 23319)Closed

History

#1 Updated by Bonnie Follweiler over 3 years ago

  • Assignee set to William Grzybowski

#2 Updated by William Grzybowski over 3 years ago

  • Status changed from Unscreened to Screened
  • Target version set to 9.10.4

#3 Updated by William Grzybowski over 3 years ago

  • Priority changed from No priority to Nice to have

#4 Updated by William Grzybowski over 3 years ago

  • Status changed from Screened to 15

This report is missing a debug file (System -> Advanced -> Save Debug)

#5 Updated by T F over 3 years ago

  • Private changed from No to Yes

#6 Updated by T F over 3 years ago

  • File debug-thumper01-18W-20170414000512.tgz added

#7 Updated by William Grzybowski over 3 years ago

  • Status changed from 15 to Screened

It seems you have multipath so thats why its not letting the disk be wiped out.

#8 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Target version changed from 9.10.4 to 11.1

#9 Updated by Sam Fourman over 3 years ago

Client facing support ticket FXH-871-58691

#10 Updated by William Grzybowski almost 3 years ago

  • Status changed from Screened to Unscreened
  • Assignee changed from William Grzybowski to Joe Maloney

Joe, I have no multipath hardware to test this. Can you try reproducing the reporter issue so I can have access and try to fix it?

#11 Updated by Dru Lavigne almost 3 years ago

  • Target version changed from 11.1 to 11.1-U1

#12 Updated by Joe Maloney almost 3 years ago

  • Status changed from Unscreened to Screened

William I have a multipath capable system that we are upgrading today to RC1. After upgrading I will connect with you offline.

#13 Updated by Joe Maloney almost 3 years ago

  • Assignee changed from Joe Maloney to Nick Wolff

#14 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Screened to Closed: Cannot reproduce
  • Target version changed from 11.1-U1 to N/A

T F: I'm going to close this out. If you are still experiencing this issue on 11.1, please attach a debug from an 11.1 system.

#15 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug-thumper01-18W-20170414000512.tgz)

#16 Updated by Dru Lavigne almost 3 years ago

  • Private changed from Yes to No

#17 Updated by Dru Lavigne over 2 years ago

  • Related to Bug #29165: still cannot remove wiped drive (continued from 23319) added

Also available in: Atom PDF