Project

General

Profile

Feature #23359

Time Machine over SMB

Added by Andrew Miskell 10 months ago. Updated about 2 months ago.

Status:
Closed: Insufficient Info
Priority:
Important
Assignee:
John Hixson
Category:
OS/Services
Target version:
Start date:
04/13/2017
Due date:
% Done:

0%

Estimated time:
Severity:
Backlog Priority:
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Hardware Configuration:
QA Status:
Not Tested

Description

Apple has deprecated AFP and have given specifications for supporting Time Machine over SMB shares.

https://developer.apple.com/library/content/releasenotes/NetworkingInternetWeb/Time_Machine_SMB_Spec/#//apple_ref/doc/uid/TP40017496-CH1-SW1

Most of the pieces were in FreeNAS Corral expect for the a patch to support F_FULLSYNC into Samba (https://bugzilla.samba.org/show_bug.cgi?id=12380)

Now that Corral is dead, this should be picked up by FreeNAS 9.10.x

History

#1 Avatar?id=14398&size=24x24 Updated by Kris Moore 10 months ago

  • Tracker changed from Bug to Feature
  • Assignee set to John Hixson
  • Priority changed from No priority to Important
  • Target version set to 9.10.4

#2 Updated by John Hixson 10 months ago

  • Status changed from Unscreened to Screened

I'd like this too. Coming soon.

#3 Avatar?id=14398&size=24x24 Updated by Kris Moore 10 months ago

  • Target version changed from 9.10.4 to 11.1

#4 Updated by Frank Riley 5 months ago

Note that for users who are running on an SSD and upgrade to High Sierra, Time Machine over SMB is required. SSD users cannot opt out of the APFS upgrade, which then makes Time Machine over AFP impossible. Source: https://support.apple.com/en-us/HT208018

#5 Updated by Andrew Miskell 5 months ago

Frank Riley wrote:

Note that for users who are running on an SSD and upgrade to High Sierra, Time Machine over SMB is required. SSD users cannot opt out of the APFS upgrade, which then makes Time Machine over AFP impossible. Source: https://support.apple.com/en-us/HT208018

I think the problem right now is that, unfortunately, the samba team has still yet to merge support into the main samba branches (there's still an open pull/merge request for this). I've posted to the discussion on these patches on the samba GitHub page and awaiting response. Hopefully stating that this is going to become a hard requirement under High Sierra may help move things along.

But yes, there's going to be a very high demand for Time Machine over SMB support in the very near future with the release of High Sierra and forced migration to APFS for SSD drive users (I'm facing that very issue now).

#6 Updated by Andrew Miskell 5 months ago

It appears Samba is indeed getting closer to having this feature included in the next Samba release.

https://github.com/samba-team/samba/pull/64

#7 Updated by originalprime - 5 months ago

@Frank Riley,

I read the same Apple Support document that you have linked there, and I thought the same thing as you have reported: that Time Machine won't work at all if one upgrades to High Sierra / APFS. However, I have updated four different Macs - all using SSDs - and they all continue to work as of the time I write this note. I suspect that we will not have long however, as Apple is likely just giving NAS makers time to update their stuff; I still would like to see SMB support since that is clearly what Apple is requiring going forward. Who knows how long before Apple cuts off AFP completely?

#8 Updated by John Hixson 5 months ago

originalprime - wrote:

@Frank Riley,

I read the same Apple Support document that you have linked there, and I thought the same thing as you have reported: that Time Machine won't work at all if one upgrades to High Sierra / APFS. However, I have updated four different Macs - all using SSDs - and they all continue to work as of the time I write this note. I suspect that we will not have long however, as Apple is likely just giving NAS makers time to update their stuff; I still would like to see SMB support since that is clearly what Apple is requiring going forward. Who knows how long before Apple cuts off AFP completely?

This PR has been around a while and discussed much: https://github.com/samba-team/samba/pull/64

If anyone in this ticket (or anyone following this ticket) would be willing to test this, I'd be happy to merge it into the nightlies. Let me know.

#9 Updated by John Hixson 5 months ago

I've cherry picked the commits into the nightlies, feel free to test. I'll try and test as well. The code has modified avahi quite a bit so I'm not clear this will work 100% since we use mDNSResponder. I'll have to take a closer look.

#10 Updated by John Hiesey 4 months ago

I have been watching this issue and set up FreeNAS in a VM to test. On the 11.0 release train I can connect via smb, but once I switched to the nightlies train (most recently version FreeNAS-11-MASTER-201710080522) I can't connect via smb from my mac at all. The error message says "There was a problem connecting to the server <ip address>." "The share does not exist on the server. Please check the share name, and then try again."

I can connect just fine from Windows 10.

#11 Avatar?id=14398&size=24x24 Updated by Kris Moore 4 months ago

  • Target version changed from 11.1 to 11.2-BETA1

#12 Updated by Dru Lavigne 3 months ago

John, is this fixed by the recent work done for mDNS?

#13 Updated by Dru Lavigne 3 months ago

  • Status changed from Screened to 46

#14 Updated by Dru Lavigne 2 months ago

  • Status changed from 46 to 15

Andrew or John Hiesey: is this still an issue or have later nightlies (or 11.1) resolved it for you?

#15 Updated by Dru Lavigne 2 months ago

  • Target version changed from 11.2-BETA1 to N/A
  • Status changed from 15 to Closed: Insufficient Info

Closing out. If you can reproduce on 11.1, please attach a debug from the 11.1 system.

#16 Updated by Andrew Miskell 2 months ago

This doesn't appear to be working, but I'm also not sure if I set it up properly to be detected by Time Machine as the share doesn't appear to be broadcast via mDNS/Bonjour to the clients.

Maybe some basic instructions on how it's supposed to be properly setup would be helpful in verifying this is actually resolved.

#17 Updated by Dru Lavigne 2 months ago

Andrew: that would be a good question for the forums.

#18 Updated by Andrew Miskell 2 months ago

I somewhat disagree.

mDNSresponder should be advertising the SMB share as a Time Machine backup volume via Bonjour. Since we shouldn't be editing mDNSresponder's configuration directly, I assume there needs to be some option or checkbox in the SMB share configuration to mark this share as a Time Machine SMB share so the backend can properly configure mDNS to broadcast it as a Time Machine share and it'll show up in Time Machine as a valid backup location.

#19 Updated by Dru Lavigne 2 months ago

Andrew: 11.1 did add this: The Home Share Time Machine checkbox has been added to Services → AFP which is supposed to do the right thing. We need feedback from forum users who have actually used it so that we can update that section of the Guide.

#20 Updated by Andrew Miskell 2 months ago

That's for AFP (Apple File Protocol) shares which are completely different than SMB (Server Messaging Block) shares.

#21 Updated by Andrew Miskell 2 months ago

And the Time Machine checkbox has been in FreeNAS for AFP shares since forever as that's how FreeNAS currently supports Time Machine.

#22 Updated by Dru Lavigne 2 months ago

#23 Updated by Andrew Miskell 2 months ago

Those issues have nothing to do with SMB only AFP (which is a deprecated protocol for Time Machine now). They are two completely different services on FreeNAS.

How is marking an AFP share as Time Machine going to effect a SMB share?

#24 Updated by Dru Lavigne about 2 months ago

Andrew: we'll need a debug from an 11.1 system in order to proceed.

#25 Updated by Lukas Kolbe about 2 months ago

Hi Dru, Andrew, I hope you don't mind if I chime in here as this particular feature is of importance for us as well.

Dru, the links you provided are about a completely different thing: Apple Time Machine over AFP (Apple File Protocol), which is provided by Netatalk and works reasonably well.

Apple has since deprecated Time Machine over AFP from macOS release 10.13 (High Sierra) onwards, and officially, it does not work anymore since macOS 10.13 (technically you can still get it to work on modern macOS).

Apple now only supports TimeMachine over SMB (Samba), and Samba 4.7 shipped with FreeNAS 11.1 does not support this feature unless you patched the FreeNAS Samba according to https://bugzilla.samba.org/show_bug.cgi?id=12380.

So, this is a feature request, not a bug report. It needs work on samba, probably the GUI for enabling TimeMachine over SMB, some configuration changes for the TimeMachine-Samba-shares and some Bonjour-advertisements to make it all work.

This is a feature more or less needed by all the Mac-users out there who keep their systems up to date, as Apple might be disabling the TimeMachine over AFP-Feature any time now which would leave FreeNAS- (and TrueNAS-) users depending on FreeNAS for their backup standing in the rain. I'm more than willing to test this in a multi-client setup if needed.

If this is supposed to work already (TimeMachine via SMB, not via AFP) I'd equally be more than willing to test, but that would need some documentation as to how to configure this.

Hope this clarifies things a bit. Kind regards and have a good time at the end of the year!
Lukas

#26 Updated by Timur Bakeyev about 2 months ago

Hi, Lukas!

The stability of the patch you mentioned haven't proven yet itself, in the past we've seen a lot of unverified and broken code coming from the given source. So we don't rush to back-port it into the 11.1-11.2 and FreeNAS Samba 4.7.

As an alternative for now I'm planning to make this patch configurable feature for the FreeBSD Samba 4.7 port, where it's it'll get more chances to be tested and verified. If that would go well - it'll be included into the FreeNAS as well.

Also available in: Atom PDF