Project

General

Profile

Feature #23391

Add GUI support for mirror vdev manipulation

Added by Eric Loewenthal about 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Nice to have
Assignee:
-
Category:
GUI (new)
Target version:
Estimated time:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Description

With Corral dead, it's time to bring this longstanding issue back to FreeNAS 9.

The GUI still doesn't allow for single-disk or mirror vdevs to be extended with additional mirrors, nor does it allow for the removal of mirrors. At this point, it's even reasonable if it's only added to the new UI, but please don't let this one simmer for years!


Related issues

Related to FreeNAS - Feature #26760: GUI needs to allow attaching disks to mirrors or single-disk stripe for additional redundancyClosed: Duplicate2017-11-20
Is duplicate of FreeNAS - Feature #25775: [Feature Request] Attach and Detach GUI functionalityClosed: Duplicate2017-09-05
Has duplicate FreeNAS - Feature #37630: add 3rd disk to existing mirror in UI, create n-way mirror from 2-way mirrorClosed
Has duplicate FreeNAS - Bug #37818: extending pool of 2-way mirror vdev with a 3-way mirror fails silentlyClosed

History

#1 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Category changed from 200 to 569
  • Assignee set to William Grzybowski
  • Target version set to 9.10.4

William - could we get a scoping?

#2 Updated by William Grzybowski about 4 years ago

  • Status changed from Unscreened to Screened

Its not a lot of work, probably a day's worth. I just have not been done before because it seemed there were not a lot of people looking for this.

#3 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from 9.10.4 to 11.1

#4 Updated by Stilez y about 4 years ago

As it's a proposed feature (=> dependent on perceived value to users) - if it's added I'll use it. All servers are based on mirror vdevs here, and using CLI to manage them ATM.

#5 Updated by Stuart Espey almost 4 years ago

Stilez y wrote:

As it's a proposed feature (=> dependent on perceived value to users) - if it's added I'll use it. All servers are based on mirror vdevs here, and using CLI to manage them ATM.

When a new user has destroyed their redundancy in their pool by adding a stripe, a common solution is to just mirror the stripe. Which requires formatting in the CLI,adding swap and then attaching the partition.

A very complicated process for what is a simple function.

The new users don't know they want this.

#7 Updated by William Grzybowski almost 4 years ago

  • Assignee changed from William Grzybowski to Xin Tan

#8 Updated by Dru Lavigne over 3 years ago

  • Is duplicate of Feature #25775: [Feature Request] Attach and Detach GUI functionality added

#9 Updated by BloodyIron - over 3 years ago

I opened : https://bugs.freenas.org/issues/25775 , not knowing it would be a dupe, whoops!

I see a significant need for GUI methods to attach and detach disks to/from mirror vdev(s), primarily for some backup scenarios (off-site cold storage, cyclical kind of thing). Otherwise this is, as mentioned earlier, only achieved manually through easily-breakable CLI GPT instructions.

The other concern is that by doing it via CLI the variance in actually-usable space on each disk can lead to sizing issues (which is why SWAP is used, AFAIK), and if we were to have a GUI method to attach AND detatch, then the middleware could just nicely size the partitions to ones that should be used.

BTW I was doing this on 9.10.2-U6, if we could get it on 9.10 and later that would be stellar.

Definitely not a feature we should let rot in history. I myself actually need this.

#10 Updated by BloodyIron - over 3 years ago

  • Target version deleted (11.1)

#11 Updated by Eric Loewenthal over 3 years ago

  • Target version set to 11.1

Resetting target version to previous value set by Kris to avoid having this one get lost.

#12 Updated by BloodyIron - over 3 years ago

Eric Loewenthal wrote:

Resetting target version to previous value set by Kris to avoid having this one get lost.

Any chance of this also rolling back to 9.10? Or are "new" features only for 11.x?

#13 Updated by Dru Lavigne over 3 years ago

  • Target version changed from 11.1 to Master - FreeNAS Nightlies

#14 Updated by Xin Tan over 3 years ago

  • Assignee changed from Xin Tan to Anonymous

Assigning this back to Erin since she's more familiar with this than me.

#15 Updated by Dru Lavigne over 3 years ago

  • Related to Feature #26760: GUI needs to allow attaching disks to mirrors or single-disk stripe for additional redundancy added

#16 Updated by Eric Loewenthal over 3 years ago

Is this planned for 11.2? The current target version is vague.

#17 Updated by Matt Kessler over 3 years ago

You can do this with the freenas-boot to make it "more robust" at any time, but not with user data?
Restore freenas-boot from backup is fast, not so restoring TB of user data!

Single disk setups have there place, in my opinion — I have three such boxes running as off site backup systems
and being able to attach/detach a disk from the GUI, would be great.
Sometimes you just come across a free same sized/larger disk decommissioned elsewhere… in it goes.

So, I'll give a +3 for being able to do this in 11.2 — I checked, it did not make it into 11.1

#18 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Status changed from Screened to Not Started

#19 Updated by Dru Lavigne over 3 years ago

  • Target version changed from Master - FreeNAS Nightlies to 11.2-RC2

#20 Updated by Anonymous about 3 years ago

This is not feature parity so I am pushing to 11.3

#21 Updated by Anonymous about 3 years ago

  • Target version changed from 11.2-RC2 to 11.3

#22 Avatar?id=13649&size=24x24 Updated by Ben Gadd about 3 years ago

  • Target version changed from 11.3 to Backlog

#23 Avatar?id=13649&size=24x24 Updated by Ben Gadd about 3 years ago

  • Severity set to New

#24 Updated by William Grzybowski almost 3 years ago

  • Has duplicate Feature #37630: add 3rd disk to existing mirror in UI, create n-way mirror from 2-way mirror added

#25 Updated by Dru Lavigne almost 3 years ago

  • Has duplicate Bug #37818: extending pool of 2-way mirror vdev with a 3-way mirror fails silently added

#26 Updated by Dru Lavigne almost 3 years ago

  • Target version changed from Backlog to 11.3

#27 Avatar?id=14398&size=24x24 Updated by Kris Moore about 2 years ago

  • Status changed from Not Started to Closed

Also available in: Atom PDF