Project

General

Profile

Bug #23395

Jails/ Plugins 9.10-MASTER-201704150516

Added by Saeed Ibrahim over 3 years ago. Updated over 3 years ago.

Status:
Closed: User Config Issue
Priority:
Expected
Assignee:
John Hixson
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I have moved from Corral to 9.10-MASTER-201704140409

when i install a plugin it does not start and it gives an error

warden_exception('route: writing to routing socket: Invalid argument\narp: writing to routing socket: Invalid argument\narp: 192.168.1.1: Invalid argument\nAbort trap\n',)

Account

History

#1 Updated by Saeed Ibrahim over 3 years ago

  • Subject changed from Jails/ Plugins 9.10-MASTER-201704140409 to Jails/ Plugins 9.10-MASTER-201704150516

#2 Updated by Bonnie Follweiler over 3 years ago

  • Assignee set to Kris Moore

#3 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Assignee changed from Kris Moore to John Hixson
  • Priority changed from No priority to Expected
  • Target version set to 9.10.3-U1

John, is this one easily fixable or should we just wait for iocage jails?

#4 Updated by Ron Hubbard over 3 years ago

There are going to be issues like this popping up for those downgrading.

It may be simpler to tell people who are on corral to stay put tell you get things updated to freebsd 11.
Corral stable for the most part and downgrading is going to break things for those with updated pools.

Would save on having a bunch of bug reports from people when things like this break and plugins aren't going to be the only thing not working correctly.

#5 Updated by John Hixson over 3 years ago

  • Status changed from Unscreened to Screened

#6 Updated by John Hixson over 3 years ago

  • Status changed from Screened to 15

Please attach a debug: system->advanced->save debug

#7 Updated by Saeed Ibrahim over 3 years ago

  • File debug-freenas-20170418115753.tgz added

#8 Updated by John Hixson over 3 years ago

  • Status changed from 15 to Closed: User Config Issue

I have reviewed your debug. What you are doing is creating a virtualized 192.168.1.0/24 network, while being on a 192.168.1.0/24 network. This won't work the way you expect it to work. Either change the network to something else, or use DHCP for your jails. If you choose to use DHCP (is there any reason in particular you are not?), you can configure it under jails->configuration->ipv4 dhcp. You will also need to change DHCP for the jails/plugins you have already created.

#9 Updated by John Hixson over 3 years ago

John Hixson wrote:

I have reviewed your debug. What you are doing is creating a virtualized 192.168.1.0/24 network, while being on a 192.168.1.0/24 network. This won't work the way you expect it to work. Either change the network to something else, or use DHCP for your jails. If you choose to use DHCP (is there any reason in particular you are not?), you can configure it under jails->configuration->ipv4 dhcp. You will also need to change DHCP for the jails/plugins you have already created.

If you would like to manually configure 192.168.1.x/24 addresses for your jails/plugins, you can disable VIMAGE on the jails you would like to do this for, then assign the IP addresses individually (or keep your current configuration as is and disable VIMAGE). You will need to restart all jails you modify for changes to take effect.

#10 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Target version changed from 9.10.3-U1 to N/A

#11 Updated by Saeed Ibrahim over 3 years ago

  • File debug-freenas-20170419205628.tgz added

I have disabled VIMAGE
Restarted the jail
it gives this error

warden_exception('Abort trap\n',)

#12 Updated by Dru Lavigne over 3 years ago

  • Status changed from Closed: User Config Issue to Unscreened

#13 Updated by John Hixson over 3 years ago

  • Status changed from Unscreened to Screened
  • Target version changed from N/A to 11.1

#14 Updated by John Hixson over 3 years ago

  • Status changed from Screened to 15

Looks like you got bit by the bug that grabs x86 jails instead of 64-bit jails. You will need to update to latest nightly and nuke your plugin and pluginjail templates and install again. You can confirm you've gotten correct template from the CLI:

warden template list -v

#15 Updated by Saeed Ibrahim over 3 years ago

I have fixed the installation issue and the plugins run

#16 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Status changed from 15 to Closed: User Config Issue
  • Target version changed from 11.1 to N/A

#17 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug-freenas-20170418115753.tgz)

#18 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug-freenas-20170419205628.tgz)

Also available in: Atom PDF