Project

General

Profile

Bug #23415

Wrong Driver (mfi) selected when using PERC H330 Mini RAID card

Added by Paul B over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Important
Assignee:
Alexander Motin
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hardware: Dell PowerEdge R530 w/ PERC H330 Mini Card on Firmware 4.270.01-8113.
Software: FreeNAS 9.10.2 U2

Driver loaded is MFI. This works, however, drives show up as "mfisysXXX" and SMART data, hot swap is not available. Even when card is manually switched to HBA mode, these drivers still don't work. This is the incorrect driver for this card.

Correct driver is MRSAS. When forced, drives show up as "daX" and everything works as intended.

Associated revisions

Revision 16970663 (diff)
Added by Alexander Motin over 4 years ago

Prefer newer mrsas(4) to mfi(4) for controllers supported by both. If somebody have a problem with this change, he should be able to revert it locally by setting hw.mfi.mrsas_enable="0" loader tunable back via WebUI. Ticket: #23415

Revision 3315fdc5 (diff)
Added by Warren Block about 4 years ago

Add note about using mrsas(4) in preference to mfi(4). Ticket: #23415

History

#1 Updated by Bonnie Follweiler over 4 years ago

  • Assignee set to Kris Moore

A debug from System -> Advanced -> Save Debug could be helpful.

#2 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Assignee changed from Kris Moore to Alexander Motin

Didn't we once discuss having a switcher to toggle between drivers? Or is my memory wrong here?

#3 Updated by Alexander Motin over 4 years ago

  • Status changed from Unscreened to Resolved
  • Priority changed from No priority to Important
  • Target version set to 9.10.3

There is a switcher in form of loader tunable. Switched it toward mrsas(4).

If somebody have a problem with this change, he should be able to revert it locally by setting hw.mfi.mrsas_enable="0" loader tunable back via WebUI.

#4 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Target version changed from 9.10.3 to 11.0

#5 Updated by Vaibhav Chauhan about 4 years ago

  • Target version changed from 11.0 to 11.0-RC

Also available in: Atom PDF