Project

General

Profile

Bug #23423

MiddlewareError: b'Unable to GPT format the disk "da0"

Added by James Rounce over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Critical
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I'm on the latest nightlies and unable to create a new volume with the same name as a previously destroyed volume, via the GUI (not the nw UX).

Environment:

Software Version: FreeNAS-9.10-MASTER-201704170553 (1ea4bf6)
Request Method: POST
Request URL: http://192.168.1.87/storage/volumemanager/

Traceback:
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/exception.py" in inner
39. response = get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in legacy_get_response
249. response = self._get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _get_response
178. response = middleware_method(request, callback, callback_args, callback_kwargs)
File "./freenasUI/freeadmin/middleware.py" in process_view
161. return login_required(view_func)(request, *view_args, **view_kwargs)
File "/usr/local/lib/python3.6/site-packages/django/contrib/auth/decorators.py" in _wrapped_view
23. return view_func(request, *args, **kwargs)
File "./freenasUI/storage/views.py" in volumemanager
157. if form.is_valid() and form.save():
File "./freenasUI/storage/forms.py" in save
290. init_rand=init_rand,
File "./freenasUI/middleware/notifier.py" in init
238. f(objectid, *args, **kwargs)
File "./freenasUI/middleware/notifier.py" in _init_volume
1059. self.
_create_zfs_volume(volume, swapsize, kwargs.pop('groups', False), kwargs.pop('path', None), init_rand=kwargs.pop('init_rand', False))
File "./freenasUI/middleware/notifier.py" in _create_zfs_volume
804. vdevs = self.
_prepare_zfs_vdev(vgrp['disks'], vdev_swapsize, encrypt, volume)
File "./freenasUI/middleware/notifier.py" in __prepare_zfs_vdev
740. swapsize=swapsize)
File "./freenasUI/middleware/notifier.py" in __gpt_labeldisk
411. raise MiddlewareError('Unable to GPT format the disk "%s"' % devname)

Exception Type: MiddlewareError at /storage/volumemanager/
Exception Value: [MiddlewareError: b'Unable to GPT format the disk "da0"']


Related issues

Is duplicate of FreeNAS - Bug #23454: Cannot create volume from disk with partition information on itClosed: Duplicate2017-04-19

History

#1 Updated by Bonnie Follweiler over 4 years ago

  • Assignee set to Kris Moore

A debug from System -> Advanced -> Save Debug could be helpful.

#2 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

Yea, a debug would be helpful. Typically its due to a previous gmirror being on the disk, keeping it "locked" from changes.

#3 Updated by James Rounce over 4 years ago

  • File debug-freenas-20170417123713.tgz added

Debug attached - hope that helps

#4 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Assignee changed from Kris Moore to William Grzybowski

William - I'm not seeing a gmirror here, is this a bug then?

#5 Updated by William Grzybowski over 4 years ago

  • Status changed from Unscreened to 15

It seems like you have sent the debug after a reboot? Is that right?

Can you try repeating the same process and send the debug right after the error happens? Thanks.

#6 Updated by James Rounce over 4 years ago

  • File debug-freenas-20170419072441.tgz added

Just updated to the latest nightly, rebooted and then tried to create a new volume again. Coming up with a middleware error again - debug attached.

At the console I'm getting an error message that 'GEOM: da0: the primary GPT table is corrupt or invalid' after running the create volume in the GUI

#7 Updated by William Grzybowski over 4 years ago

  • Status changed from 15 to 19
  • Target version set to 9.10.3

I see whats wrong there, its not destroying the GPT table.

A fix went in this morning, can you try again tomorrow, please?

1b995167e8dc7f1e

#8 Updated by William Grzybowski over 4 years ago

  • Priority changed from No priority to Critical

#9 Updated by James Rounce over 4 years ago

Will do and thanks

#10 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Target version changed from 9.10.3 to 11.0

#11 Updated by William Grzybowski over 4 years ago

  • Is duplicate of Bug #23454: Cannot create volume from disk with partition information on it added

#12 Updated by James Rounce over 4 years ago

Updated to the latest build (FreeNAS-11-MASTER-201704200433 (d94329c)) and volume creation now works successfully.

Thank you!

#13 Updated by William Grzybowski over 4 years ago

  • Status changed from 19 to Resolved

Thanks for the report!

#15 Updated by Vaibhav Chauhan about 4 years ago

  • Target version changed from 11.0 to 11.0-RC

#16 Updated by Dru Lavigne over 3 years ago

  • File deleted (debug-freenas-20170417123713.tgz)

#17 Updated by Dru Lavigne over 3 years ago

  • File deleted (debug-freenas-20170419072441.tgz)

Also available in: Atom PDF