Project

General

Profile

Bug #23440

Certificate creation dialog stuck

Added by Christian X over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
William Grzybowski
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hi,

I've created an internal certificate authority and when I try to create a certificate with it, then the dialog is stuck. This happens as soon as I select the CA from the drop down. There are no errors in the browser console and nothing in dmsg. I don't know about any other locations with logs to check.
I'm not entirely sure, if this is a local issue on my side or a real bug. I've attached a test-CA, with which I can reliably reproduce the problem. It would be nice, if someone could import it and see if the issue is related to the CA file.

I'm running 9.10.2-U2 (e1497f2)

Thanks & Regards,
Christian

dialog.png (25.9 KB) dialog.png dialog inputs frozen Christian X, 04/18/2017 08:48 AM
10752

History

#1 Updated by Bonnie Follweiler over 4 years ago

  • Assignee set to William Grzybowski

Would you please provide a debug from System -> Advanced -> Save Debug? It might be helpful.

#2 Updated by William Grzybowski over 4 years ago

  • Status changed from Unscreened to Screened

Also, what do you mean by stuck, exactly? You click "OK" and nothing happens? Do you see any error in the browser console (and which browser are you using)?

#3 Updated by William Grzybowski over 4 years ago

  • Status changed from Screened to 15

#4 Updated by Christian X over 4 years ago

Oh, nevermind. I just noticed that the dialog is not really stuck forever. I had it open while writing the bug entry and when I was done writing it, the dialog was working again.
So I guess this is no bug, but a performance issue at best. It takes about 3 minutes for the dialog to unfreeze after the selection of the CA from the dropdown.
Well, with this twist I'd be ok to close the ticket. (Unless you want to follow up with it. But I guess that's not really worthwhile with the new GUI coming soon)

#5 Updated by William Grzybowski over 4 years ago

  • Status changed from 15 to Resolved
  • Priority changed from No priority to Nice to have
  • Target version set to 9.10.3

I actually think this is related to the automatic error report to rollbar taking a long time to complete.

There is no way to confirm but it should be fixed in d80b58abc6b433af

Thanks for the report.

#6 Updated by Christian X over 4 years ago

10752

William Grzybowski wrote:

Also, what do you mean by stuck, exactly? You click "OK" and nothing happens? Do you see any error in the browser console (and which browser are you using)?

No, it's before I click OK. When I select the CA from the dropdown all remaining input fields do not accept the focus.
I did test it with Firefox 52.0.2 and a Chrome Canary. The browser console is empty.

#7 Updated by William Grzybowski over 4 years ago

  • Target version set to 9.10.3

#8 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Target version changed from 9.10.3 to 11.0

#10 Updated by Vaibhav Chauhan about 4 years ago

  • Target version changed from 11.0 to 11.0-RC

#11 Updated by Dru Lavigne over 3 years ago

  • File deleted (test-CA.crt)

Also available in: Atom PDF