Project

General

Profile

Bug #23493

Fix VM stop

Added by Anthony Takata over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
No priority
Assignee:
Marcelo Araujo
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

FreeNAS-11-MASTER-201704210416 (196a1c9)

ChangeLog Required:
No

Description

On occasion bhyve freezes while maxing out CPU on one of the threads (seems to be a VirtIO issue without further diagnosis). At this point I need to kill the VM, but the "Stop" button doesn't seem to be able to do this like it does in Corral. Instead, it seems to just send the ACPI Shutdown request and that's it, and I have to kill -9 the bhyve process to actually shut it down.

I'd like to see the State to be "Stopping" and if the user clicks the Stop button once again, a kill command should be issued.


Related issues

Is duplicate of FreeNAS - Bug #23975: Feature Request: VM Poweroff buttonClosed: Duplicate2017-05-15

Associated revisions

Revision b75967f9 (diff)
Added by Marcelo Araujo over 1 year ago

fix(vm): Gracefully stop vm using bhyvectl(8).

Ticket: #23975
Ticket: #23493

Revision cbb9120e (diff)
Added by Marcelo Araujo over 1 year ago

fix(vm): Handle the bhyve return for --force-poweroff and avoid try to destroy it twice.

Ticket: #23975
Ticket: #23493

History

#1 Updated by Marcelo Araujo over 1 year ago

  • Status changed from Unscreened to Screened

#2 Updated by Marcelo Araujo over 1 year ago

  • Target version set to 11.0-U1

#3 Updated by Marcelo Araujo over 1 year ago

  • Target version changed from 11.0-U1 to 11.1

Ooops!!! It should be targeted to 11.1.

#4 Updated by Marcelo Araujo over 1 year ago

  • Status changed from Screened to Resolved

#5 Updated by Dru Lavigne over 1 year ago

  • Subject changed from Unable to stop VM to Fix VM stop

#6 Updated by Dru Lavigne over 1 year ago

  • Is duplicate of Bug #23975: Feature Request: VM Poweroff button added

#7 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.1 to 11.1-BETA1

#8 Updated by Joe Maloney about 1 year ago

  • Needs QA changed from Yes to No
  • QA Status Test Passes FreeNAS added
  • QA Status deleted (Not Tested)

Also available in: Atom PDF