Project

General

Profile

Feature #23523

Support for mirrored swap partitions

Added by Dean None over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Expected
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Estimated time:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Description

Hey, so I opened a thread about this issue: https://forums.freenas.org/index.php?threads/9-10-system-crash-with-unexplained-log.53865/#post-372899
TL;DR
The server crashed last night, destroying file transfers and killing jails, and also the GUI was unresponsive - ping were acknowledged, mails kept getting sent.

I'm openning this bug to attach the debug info, and also to get this issue to your attention guys because its really severe.

After reseting the unit I got the errors on the on-screen console, picture is attached.


Related issues

Related to FreeNAS - Bug #24237: Allow S.M.A.R.T. tests for boot devicesResolved2017-05-30
Is duplicate of FreeNAS - Bug #23931: hot swappable disks being part of swap and disabling swap is strongly discouragedClosed: Duplicate2017-05-12

Associated revisions

Revision 667438dd (diff)
Added by William Grzybowski over 1 year ago

feat(middlewared): listen to devd events

Ticket: #23523

Revision 2a6c69e8 (diff)
Added by William Grzybowski over 1 year ago

fix(middlewared): wait a bit before trying again

Ticket: #23523

Revision 5d37d1ac (diff)
Added by William Grzybowski over 1 year ago

feat(middlewared): react on DEVFS events

Ticket: #23523

Revision fdcb0620 (diff)
Added by William Grzybowski over 1 year ago

rm(rc.d): storage_mountpoint does not even exist anymore

Ticket: #23523

Revision 89845e7e (diff)
Added by William Grzybowski over 1 year ago

feat(middlewared): private method to create mirror for swaps

Ticket: #23523

Revision 69edf84c (diff)
Added by William Grzybowski over 1 year ago

fix(middlewared): add existing mirrors to the list

Ticket: #23523

Revision c68b71b8 (diff)
Added by William Grzybowski over 1 year ago

feat(middlewared): auxiliary method to remove disk from swap

Ticket: #23523

Revision 790437c3 (diff)
Added by William Grzybowski over 1 year ago

fix(notifier): use middleware to detach swap

While I'm here remove most of the UFS volumes codepath.

Ticket: #23523

Revision aac1ae8b (diff)
Added by William Grzybowski over 1 year ago

feat(rc.d): configure and use swap from middlewared

Ticket: #23523

Revision abddd30c (diff)
Added by William Grzybowski over 1 year ago

fix(rc.d): remove now unused function and use ld path for jq

Ticket: #23523

Revision f4a63cc2 (diff)
Added by William Grzybowski over 1 year ago

feat(middlewared): set up geli and online swap

While I'm here fix bug of name of mirror on existing swaps and skip
".sync".

Ticket: #23523

Revision 8edc3365 (diff)
Added by William Grzybowski over 1 year ago

feat(middlewared): use single disks if swap mirror could not be formed

Ticket: #23523

Revision 72e198a5 (diff)
Added by William Grzybowski over 1 year ago

fix(rc.d): use absolure path for jq

Ticket: #23523

Revision 22fb5b61 (diff)
Added by William Grzybowski over 1 year ago

feat(middlewared): change disk.swaps_remove_disks to accept a list

Ticket: #23523

Revision 39e1b682 (diff)
Added by William Grzybowski over 1 year ago

feat(middlewared): try to save core and configure dumpdev

Ticket: #23523

Revision a6cd1960 (diff)
Added by William Grzybowski over 1 year ago

fix(middlewared): make sure socket file exists before trying

Ticket: #23523

Revision 5ba6c1a7 (diff)
Added by William Grzybowski over 1 year ago

fix(middlewared): missing import

Ticket: #23523

Revision dac73cd1 (diff)
Added by William Grzybowski over 1 year ago

fix(middlewared): wait socket to be ready for read

Make this gevent friendly or it can block indefinitely.

Ticket: #23523

Revision 32e2f052 (diff)
Added by William Grzybowski over 1 year ago

fix(middlewared): configure dumpdev on the first disk of gmirror

Or in the first unused partition.

Ticket: #23523

Revision d5f13461 (diff)
Added by William Grzybowski over 1 year ago

fix(middlewared): remove degraded swap mirror and start again

Ticket: #23523

Revision f87bdb8a (diff)
Added by William Grzybowski over 1 year ago

fix(middlewared): fix savecore arg

Ticket: #23523

Revision a4a5a35b (diff)
Added by William Grzybowski over 1 year ago

rm(rc.d): swap is now handled in middlewared

Ticket: #23523

Revision e07070f2 (diff)
Added by Dru Lavigne about 1 year ago

Mention mirrored swap.
Ticket: #23523

History

#1 Updated by William Grzybowski over 1 year ago

  • Assignee changed from William Grzybowski to Alexander Motin

#2 Updated by William Grzybowski over 1 year ago

Sasha, it seems like it was using swap in one of the disks that died. Would you agree?

If so, seems like we should be creating swap mirrors out of the disks in a pool?

#3 Updated by Alexander Motin over 1 year ago

  • Tracker changed from Bug to Feature
  • Subject changed from FN Crashed completely with strange log to FreeNAS needs mirrored log partitions
  • Category changed from 53 to 201
  • Status changed from Unscreened to Screened
  • Priority changed from No priority to Nice to have
  • Target version set to 11.1

Yes. Looking on provided logs and messages it seems like you lost one of your SATA disks. Because that disk also included swap partition that was used for some reason, some system daemons went south. We obviously should do something to increase reliability of swap partitions, but at this point system did what it supposed to, so it is more misfeature then a bug.

#4 Updated by Alexander Motin over 1 year ago

  • Assignee changed from Alexander Motin to William Grzybowski

#5 Updated by William Grzybowski over 1 year ago

  • Priority changed from Nice to have to Expected

#6 Updated by William Grzybowski over 1 year ago

  • Subject changed from FreeNAS needs mirrored log partitions to FreeNAS needs mirrored swap partitions

#7 Updated by William Grzybowski over 1 year ago

  • Is duplicate of Bug #23931: hot swappable disks being part of swap and disabling swap is strongly discouraged added

#8 Updated by William Grzybowski over 1 year ago

  • Status changed from Screened to Ready For Release

#9 Updated by William Grzybowski over 1 year ago

  • Related to Bug #24237: Allow S.M.A.R.T. tests for boot devices added

#10 Updated by Dru Lavigne over 1 year ago

  • Private changed from Yes to No

#11 Updated by Dru Lavigne over 1 year ago

  • Subject changed from FreeNAS needs mirrored swap partitions to Support for mirrored swap partitions

#12 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.1 to 11.1-BETA1

#13 Updated by Dru Lavigne about 1 year ago

  • Status changed from Ready For Release to Resolved

#14 Updated by Bonnie Follweiler about 1 year ago

  • Needs QA changed from Yes to No
  • QA Status Test Passes FreeNAS added
  • QA Status deleted (Not Tested)

Also available in: Atom PDF