Project

General

Profile

Bug #23579

bridge0: error setting interface capabilities on lagg0

Added by Damon Hagerstrom over 3 years ago. Updated almost 3 years ago.

Status:
Closed: Duplicate
Priority:
No priority
Assignee:
Marcelo Araujo
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I get this error in dmesg when starting a VM - I have not played around enough to figure out which capabilities are or are not working though.
I don't know if it's a virtual switch issue or what. If you need any real information please let me know what to send and how to get the info.
LACP from AsRock Rack to Cisco 2960S
FreeNAS FreeNAS-11-MASTER-201704250734

Error appears as soon as VM is started, doesn't seem to matter what the VM is - Linux or Windows.


Related issues

Is duplicate of FreeNAS - Bug #23447: if_lagg and if_vlan need SIOCSIFCAP support for plugins to work properlyResolved2017-04-19

History

#1 Updated by Marcelo Araujo over 3 years ago

  • Status changed from Unscreened to Screened

#2 Updated by Damon Hagerstrom over 3 years ago

So far, I have found that this is stopping a Windows guest from accessing CIFS shares.
Guest is Server 2016 - two fresh installs
Can ping freenas, has internet access, can see DLNA devices on network but not freenas box.
I have tried using both the Intel NIC and the Virtio NIC devices for the VM - The error given in the guest while troubleshooting is "Windows sockets registry entries required for network connectivity are missing" - I have tried the suggest trouble shooting for that problem and had no success.
I have tried changing the SMB service version back to 2.1 - no change.
Another user has also report this here "https://forums.freenas.org/index.php?threads/11-0-vm-cant-access-host-via-network.54074/#post-374452"

#3 Updated by Anthony Takata over 3 years ago

piping in here. Similar issue with the lagg and vm communication, except the VM is unable to access the host or any of the jails.

#4 Updated by Damon Hagerstrom over 3 years ago

Error from Linux VM is 'CIFS VFS: Error connecting to socket. Aborting operation.
'CIFS VFS: cifs_mount failed w/return code = -115'

#5 Updated by Anthony Takata over 3 years ago

Despite this, fixes in #23447 seem to have let this be a non-issue.

#6 Updated by Marcelo Araujo over 3 years ago

  • Status changed from Screened to Resolved

Anthony Takata wrote:

Despite this, fixes in #23447 seem to have let this be a non-issue.

Great, I'm closing this ticket!

Thanks,

#7 Updated by Dru Lavigne almost 3 years ago

  • Is duplicate of Bug #23447: if_lagg and if_vlan need SIOCSIFCAP support for plugins to work properly added

#8 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Resolved to Closed: Duplicate
  • Target version set to N/A

Also available in: Atom PDF