Project

General

Profile

Bug #23604

FreeNAS 9.10.2-U3 hangs at boot "Loading kernel modules:"

Added by Thomas Kleffel about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
No priority
Assignee:
Alexander Motin
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

* Supermicro X11SSZ-TLN4F
* CPU: Intel(R) Xeon(R) CPU E3-1275 v5 @ 3.60GHz
* Memory: 2x 16GB DDR4 ECC Kingston

ChangeLog Required:
No

Description

FreeNAS 9.10.2-U3 installs fine from USB-Stick to SATA SSD.

At first boot, it hangs at "Loading kernel modules:". Ctrl-C will yield hundreds of ACPI Errors ("Could not acquire AML Interpreter mutex..." and more). Then the systems hangs again at "Starting mdnsd.". Another Ctrl-C triggers python errors after which the FreeNAS Console is visible, but the system seems to be non-functional (nginx only shows and error page).

The same hardware works fine with 9.10.1-U4.


Related issues

Related to FreeNAS - Bug #20927: [regression] After upgrade 9.10.1-U4 > 9.10.2 or 9.10.2-U1 stuck on "loading kernel modules"Resolved2017-02-07

History

#1 Updated by Thomas Kleffel about 4 years ago

  • Description updated (diff)

#2 Updated by Bonnie Follweiler about 4 years ago

  • Related to Bug #20927: [regression] After upgrade 9.10.1-U4 > 9.10.2 or 9.10.2-U1 stuck on "loading kernel modules" added

#3 Updated by Alexander Motin about 4 years ago

  • Status changed from Unscreened to 15

Could you try nightly build of FreeNAS 11? This problem could be fixed by ACPI code changes already merged there.

#4 Updated by Thomas Kleffel about 4 years ago

Just tested FreeNAS-11-MASTER-201704280408-83eff7b and it works just fine. Will those changes be included in 9.10.2-U4?

#5 Updated by Alexander Motin about 4 years ago

  • Status changed from 15 to Resolved
  • Target version set to 11.0

No. Even if there will be 9.10.2-U4 (which is not planned), this change is too big to merge it there. Fix will be only in FreeNAS 11.0.

#6 Updated by Vaibhav Chauhan about 4 years ago

  • Target version changed from 11.0 to 11.0-RC

Also available in: Atom PDF