Project

General

Profile

Bug #23651

Add ability to set the VM NIC Mac Address

Added by Marcelo Araujo over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
No priority
Assignee:
Marcelo Araujo
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Should allow users set their own MAC Address and also allow selecting bridged/NAT and other.


Related issues

Related to FreeNAS - Feature #27121: Please persist MAC addresses for bhyve VM's network interfacesClosed: Duplicate2017-12-09
Is duplicate of FreeNAS - Feature #23819: Please add an option to set a MAC address for VM NICS in GUIClosed: Duplicate2017-05-06
Has duplicate FreeNAS - Feature #26703: VM NICs need MAC controlsClosed: Duplicate2017-11-16

Associated revisions

Revision 9e11b11d (diff)
Added by Marcelo Araujo over 1 year ago

feat(vm): Allow users to set the NIC Mac Address or let it be auto generated with the fixed OUI 00:a0:98 and with the remaining bytes from an MD5 hash of the slot and function numbers and the device name.

Ticket: #23651
Ticket: #23819

Revision 35352f7e (diff)
Added by Dru Lavigne about 1 year ago

Document ability to specify MAC address.
Ticket: #23651

History

#1 Updated by Marcelo Araujo over 1 year ago

  • Status changed from Screened to Resolved

#2 Updated by Dru Lavigne over 1 year ago

  • Subject changed from VM: Network device to Add ability to set the VM NIC Mac Address

#3 Updated by Dru Lavigne over 1 year ago

  • Is duplicate of Feature #23819: Please add an option to set a MAC address for VM NICS in GUI added

#4 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.1 to 11.1-BETA1

#5 Updated by Joe Maloney about 1 year ago

  • Needs QA changed from Yes to No
  • QA Status Test Passes FreeNAS added
  • QA Status deleted (Not Tested)

#6 Updated by Dru Lavigne about 1 year ago

#7 Updated by Dru Lavigne about 1 year ago

  • Related to Feature #27121: Please persist MAC addresses for bhyve VM's network interfaces added

Also available in: Atom PDF