Project

General

Profile

Feature #23686

Get FreeNAS a sophisticated network GUI that does justice for VM management

Added by Peter Brille over 3 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Important
Assignee:
Erin Clark
Category:
GUI (new)
Target version:
Estimated time:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Description

Since FreeNAS ist not only a fileserver solution any more, we need a good network management.
Especially for people who run jails and also bhyve guests they usually want their guests to reside within different vlan.
Some ones might want to put the FreeNAS host itself untagged on a switch port while the same port has tagged setup for VM guests or maybe all is tagged (802.1Q). One might want to utilize vlan, bridging and Link Aggregation all at the same time.

We need this, because it should be an easy task to just put the hosts into different VLANs. Bridging makes sure that multiple hosts can use the same vlan.
The FreeNAS host may not have an IPv4 or IPv6 address on this bridge because in some cases it should not or may not have one.

I tested Corral quite intensively with that requirement and I must say it absolutely meets those requirements. The only thing I did not try is a combination with Link Aggregation.

Reference:
https://forums.freenas.org/index.php?threads/how-to-set-separate-vlan-for-jail.54019/
https://www.youtube.com/watch?v=W3DkHzhPq3k&t=2s


Related issues

Related to FreeNAS - Umbrella #50841: Network Interfaces Management RewriteDone
Related to FreeNAS - Feature #52517: Implement network rewrite in new UIClosed
Is duplicate of FreeNAS - Feature #27454: Give bhyve-VMs a bridge networkClosed

History

#1 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Target version changed from 11.0 to 11.1

Re-targeting for 11.1

#2 Updated by Xin Tan over 3 years ago

  • Status changed from Unscreened to Screened

#3 Updated by Dru Lavigne almost 3 years ago

  • Target version changed from 11.1 to Master - FreeNAS Nightlies

#4 Updated by Kanthamohan Jeyaraman over 2 years ago

Is this feature going to get picked up anytime soon? I was excited that it moved to nightlies, but have not seen any progress since :-(

#5 Updated by Xin Tan over 2 years ago

  • Target version changed from Master - FreeNAS Nightlies to 11.3

BRB: Not in 11.2. Currently, we're focusing on feature parity, hence we'll start considering this one after we released 11.2.

#6 Avatar?id=14398&size=24x24 Updated by Kris Moore over 2 years ago

  • Status changed from Screened to Not Started

#7 Updated by Dru Lavigne over 2 years ago

  • Assignee changed from Xin Tan to Erin Clark

#8 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Target version changed from 11.3 to Backlog

#9 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Severity set to New

#10 Updated by Dru Lavigne about 2 years ago

  • Target version changed from Backlog to 11.3

#11 Updated by Dru Lavigne almost 2 years ago

  • Is duplicate of Feature #27454: Give bhyve-VMs a bridge network added

#12 Updated by Dru Lavigne almost 2 years ago

#13 Updated by Dru Lavigne almost 2 years ago

  • Related to Feature #52517: Implement network rewrite in new UI added

#14 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Not Started to Closed
  • Target version changed from 11.3 to N/A
  • Reason for Closing set to Duplicate Issue

Peter: the work to implement this feature will occur in the related tickets.

Also available in: Atom PDF