Project

General

Profile

Bug #23786

Can't update any existing User after upgrading from 9.10.2-u3 to 11

Added by Bonnie Follweiler over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Important
Assignee:
John Hixson
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I upgraded my mini from 9.10.2-u3 to FreeNAS 11 Stable
I had two users already set up, with home directories that worked
I updated one user with an extra long password (26 characters a thru z)
I clicked save and it gave me a traceback error but the screenshot didn't save

I rebooted it in the 9.10.2-u3 environment and they work
I updated again and it didn't work again. I got screenshots of the error messages this time

Let me know if I can provide any other insight.
If it helps my mini's ip is 10.20.1.95
root
abcd1234

Associated revisions

Revision 4be0bc12 (diff)
Added by John Hixson over 3 years ago

Add account/user node Ticket: #23786

Revision ef2c4790 (diff)
Added by John Hixson over 3 years ago

Set call timeout value / Catch exceptions Ticket: #23786

Revision 1bcdf59e (diff)
Added by John Hixson over 3 years ago

Add account/user node Ticket: #23786 (cherry picked from commit 4be0bc12b7d00f5733b81b1a3873a10fabf63ad3)

Revision 48888560 (diff)
Added by John Hixson over 3 years ago

Set call timeout value / Catch exceptions Ticket: #23786 (cherry picked from commit ef2c4790117582b5a5af04202dad7eee5810b541)

History

#1 Updated by Bonnie Follweiler over 3 years ago

I forgot to add that I extra long password works in 9.10.2-U3 and in a "clean install" of FreeNAS 11
My mini is on FreeNAS-9.10.2-U3 (e1497f269) right now. You can update it, or I can, if you need me to.

#2 Updated by Sean Fagan over 3 years ago

  • Category changed from 1 to 201
  • Assignee changed from Sean Fagan to Bonnie Follweiler

That's a middleware issue -- if I'm understanding it correctly, the problem is that you can't set the long password i 11, but you can in 9.10?

#3 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Assignee changed from Bonnie Follweiler to William Grzybowski

#4 Updated by Bonnie Follweiler over 3 years ago

Sean, the issue only affects upgrades to FreeNAS 11. My "clean" install of FreeNAS 11 allows the long password.

#5 Updated by William Grzybowski over 3 years ago

  • Status changed from Unscreened to Screened

Bonnie Follweiler wrote:

Sean, the issue only affects upgrades to FreeNAS 11. My "clean" install of FreeNAS 11 allows the long password.

I'll be using your mini in a few to try to reproduce and fix the issue. Please let it alone for a while, is that possible? Thanks

#6 Updated by Bonnie Follweiler over 3 years ago

Of course you can
My mini is your mini
:)

#7 Updated by William Grzybowski over 3 years ago

  • Status changed from Screened to Unscreened
  • Assignee changed from William Grzybowski to John Hixson
  • Priority changed from No priority to Critical
  • Target version set to 11.0

When AD is enabled making user operations take a lot of time

Generating smb4.conf is one of them:
  1. time /usr/local/libexec/nas/generate_smb4_conf.py
    1.017u 0.153s 0:23.76 4.8% 360+554k 2+0io 0pf+0w

John said he will look into it.

#8 Updated by John Hixson over 3 years ago

  • Status changed from Unscreened to Screened
  • Priority changed from Critical to Important

#9 Updated by John Hixson over 3 years ago

I can't reproduce this, but it's another call timeout ;-)

#10 Updated by John Hixson over 3 years ago

  • Status changed from Screened to 15

So I've added the ability to tune this. Also, you shouldn't get a stack trace anymore. It would be nice if you could verify ;-) If when you update a user, you still see in /var/log/debug.log "ERROR: call timeout", then this is still taking too long and there may be a bigger problem. The default for this is 30 seconds, but you can adjust it by adding a sysctl with freenas.account.user.timeout.reload=xxx where xxx is value in seconds.

#11 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Status changed from 15 to Needs Developer Review
  • Assignee changed from John Hixson to Sean Fagan

Sean, can you review this?

Thanks!

#12 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Assignee changed from Sean Fagan to Marcelo Araujo

#13 Updated by Marcelo Araujo over 3 years ago

  • Status changed from Needs Developer Review to Reviewed

LGTM!

#14 Updated by Marcelo Araujo over 3 years ago

  • Assignee changed from Marcelo Araujo to Kris Moore

#15 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Assignee changed from Kris Moore to John Hixson

VB will merge, but keep it assigned as John.

#16 Updated by Vaibhav Chauhan over 3 years ago

  • Status changed from Reviewed to Merged
  • Assignee changed from John Hixson to Kris Moore

#17 Updated by Vaibhav Chauhan over 3 years ago

  • Target version changed from 11.0 to 11.0-RC3

#18 Updated by William Grzybowski over 3 years ago

  • Assignee changed from Kris Moore to John Hixson

#19 Updated by Vaibhav Chauhan over 3 years ago

  • Status changed from Merged to Resolved

#20 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug-bonniemini-20170504115718.tgz)

Also available in: Atom PDF