Project

General

Profile

Feature #23849

Add alerts to Support Ticket tab for files that are "too large"

Added by Shawn Cox over 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
No priority
Assignee:
Vaibhav Chauhan
Category:
GUI (new)
Target version:
Estimated time:
(Total: 0.00 h)
Severity:
Low
Reason for Closing:
Not Applicable
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Description

Two items here when submitting a ticket

1. With attach debug checked, if the debug is too large(?20MB>?), the ticket will not be submitted and the GUI will report the following:
Connection timed out: HTTPSConnectionPool(host='support-proxy.ixsystems.com', port=443): Read timed out. (read timeout=10)

2. Attaching files(?20MB>?) will just sit on attaching

Add an alert to check size of files being attached. Currently you can try attaching large files and the GUI will sit.

Screen Shot 2017-11-09 at 11.14.12 AM.png (20.3 KB) Screen Shot 2017-11-09 at 11.14.12 AM.png this is missing in your PR Vaibhav Chauhan, 11/09/2017 11:14 AM
Selection_047.png (90.4 KB) Selection_047.png Nesma Shah, 12/01/2017 02:15 AM
12989
13263

Subtasks

Bug #26644: Submitting Ticket for Files Closed: Insufficient InfoWilliam Grzybowski

Related issues

Related to FreeNAS - Bug #26785: Use websockets to prevent Support debug upload from timing outResolved2017-11-21
Related to FreeNAS - Feature #29613: Check size of debug file and generate an error if it is over the size limitDone

History

#1 Updated by William Grzybowski over 2 years ago

  • Project changed from TrueNAS to FreeNAS
  • Category changed from 42 to 135
  • Status changed from Unscreened to Screened
  • Priority changed from No priority to Nice to have
  • Target version set to 11.0-U1

#2 Updated by William Grzybowski over 2 years ago

  • Target version changed from 11.0-U1 to 11.1

#3 Updated by William Grzybowski about 2 years ago

  • Category changed from Middleware to GUI (new)
  • Status changed from Screened to Unscreened
  • Assignee changed from William Grzybowski to Erin Clark
  • Target version changed from 11.1 to 11.2-BETA1

I will defer that to the new GUI.

#4 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 2 years ago

  • Assignee changed from Erin Clark to Nesma Shah

#5 Updated by Nesma Shah almost 2 years ago

  • Status changed from Unscreened to Screened

#6 Updated by Nesma Shah almost 2 years ago

  • Status changed from Screened to Ready For Release

#7 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Ready For Release to 46

Nesma: https://github.com/freenas/webui/pull/72 is still showing as open.

#8 Updated by Nesma Shah almost 2 years ago

  • Status changed from 46 to Needs Developer Review

#9 Updated by Dru Lavigne almost 2 years ago

  • Assignee changed from Nesma Shah to Lola Yang

#10 Updated by Vaibhav Chauhan almost 2 years ago

12989

as part of submitting ticket thru support portal, we have users wait as shown in screenshot, please reimplement that thanks

#11 Updated by Nesma Shah almost 2 years ago

I think that problem is from server side
Frontend is no-where-near involved in this process

#12 Updated by Dru Lavigne almost 2 years ago

  • Assignee changed from Nesma Shah to Vaibhav Chauhan

#13 Updated by Vaibhav Chauhan almost 2 years ago

  • Assignee changed from Vaibhav Chauhan to Nesma Shah

please open up a middleware ticket if you think it's a middleware issue, and link to this bug.

#14 Updated by Dru Lavigne almost 2 years ago

  • Status changed from 15 to Unscreened

#15 Updated by Nesma Shah almost 2 years ago

  • Status changed from Unscreened to 15
  • Assignee changed from Nesma Shah to William Grzybowski

#16 Updated by William Grzybowski almost 2 years ago

  • Assignee changed from William Grzybowski to Nesma Shah

Why did you assign it to me?

Its clearly stated in the ticket, if the attachment file is big it should be denied. HTML5 has ability to check attachment size.

#17 Updated by Nesma Shah almost 2 years ago

  • Assignee changed from Nesma Shah to William Grzybowski

Yes I understand that and that issue I have solved.

this ticket states two issues, I am talking about first one.

With attach debug checked, if the debug is too large(?20MB>?), the ticket will not be submitted and the GUI will report the following:
Connection timed out: HTTPSConnectionPool(host='support-proxy.ixsystems.com', port=443): Read timed out. (read timeout=10)

The problem is related to API/Middleware.

#18 Updated by William Grzybowski almost 2 years ago

  • Status changed from 15 to Ready For Release
  • Assignee changed from William Grzybowski to Nesma Shah

An explanation next time will be appreciated, thanks.

Middleware issue will be handled in #26785

#19 Updated by William Grzybowski almost 2 years ago

  • Related to Bug #26785: Use websockets to prevent Support debug upload from timing out added

#20 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Ready For Release to 46
  • Target version changed from 11.2-BETA1 to Master - FreeNAS Nightlies

Nesma: the pull request has not been merged: https://github.com/freenas/webui/pull/72

#21 Updated by Nesma Shah almost 2 years ago

I am waiting for William to get the ticket done which is Related to Bug #26785: When sending a Support Ticket in the GUI, the ticket sends, but the "Submitting a ticket Attaching a debug" window stays at 0% added .

#22 Updated by Dru Lavigne almost 2 years ago

  • Status changed from 46 to Screened

Nesma: the code in that ticket has been merged.

#23 Updated by Nesma Shah almost 2 years ago

13263

I am facing one issue, While I enter credentials for username and password

I receive these errors as attached in screenshot.

#24 Updated by Dru Lavigne almost 2 years ago

  • Status changed from 15 to Unscreened
  • Assignee changed from Lola Yang to Erin Clark

Erin: please load balance the remaining work.

#25 Updated by Erin Clark almost 2 years ago

  • Assignee changed from Erin Clark to Vaibhav Chauhan

#26 Updated by Vaibhav Chauhan almost 2 years ago

  • Tracker changed from Bug to Feature
  • Seen in deleted (TrueNAS-9.10.2)
  • ChangeLog Required deleted (No)

#27 Avatar?id=14398&size=24x24 Updated by Kris Moore over 1 year ago

  • Status changed from Unscreened to Not Started

#28 Updated by Dru Lavigne over 1 year ago

  • Target version changed from Master - FreeNAS Nightlies to 11.2-RC2

#29 Updated by Vaibhav Chauhan over 1 year ago

  • Related to Feature #29613: Check size of debug file and generate an error if it is over the size limit added

#30 Updated by Vaibhav Chauhan over 1 year ago

  • Target version changed from 11.2-RC2 to 11.3

retargeting to 11.3 as related middleware code will be ready around that time,

#31 Updated by Vaibhav Chauhan over 1 year ago

  • Status changed from Not Started to Blocked

#32 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 1 year ago

  • Target version changed from 11.3 to Backlog

#33 Updated by Vaibhav Chauhan over 1 year ago

  • Severity set to Low

#34 Updated by Vaibhav Chauhan over 1 year ago

  • Status changed from Blocked to Unscreened

related middleware task is now marked for testing so setting appropriate status.

#35 Updated by Dru Lavigne about 1 year ago

  • Target version changed from Backlog to 11.2-BETA3

Retargetting as the middleware and doc portions are complete.

#36 Updated by Erin Clark about 1 year ago

  • Status changed from Unscreened to Closed

The consensus around this ticket seems to be that there is nothing left to be done with this, the middleware warns the user if the debug is too large and the UI handles that error so nothing left to do. Closing ticket.

#37 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.2-BETA3 to N/A
  • Reason for Closing set to Not Applicable

Also available in: Atom PDF