Project

General

Profile

Bug #23881

Unify API code to create/update zvol

Added by Vaibhav Chauhan over 1 year ago. Updated 12 months ago.

Status:
Resolved
Priority:
Important
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Sprint:
Severity:
New
Backlog Priority:
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Request:
{"name":"test-zvol-zle-2","volsize":"100M","sparse":false,"compression":"zle"}

Response:
{"avail": 11937632256, "compression": "zle", "name": "test-zvol-zle-2", "refer": 57344, "sparse": false, "used": 110362624, "volsize": 104857600}

however I can see that it has lz4 as compression type

root@freenas:~ # zfs list -o compression tank/test-zvol-zle-2
COMPRESS
     lz4


Related issues

Related to FreeNAS - Bug #24231: Creating zvols via api only uses name and volsize from inputClosed: Duplicate2017-05-30
Is duplicate of FreeNAS - Bug #24432: Change size of zvol via API not passed through to LUNClosed: Duplicate2017-06-08

Associated revisions

Revision c330668a (diff)
Added by William Grzybowski over 1 year ago

fix(api): unify code to create/update zvol

Ticket: #23881

Revision c01c80a6 (diff)
Added by William Grzybowski over 1 year ago

fix(api): add helper to get initial data from form

Ticket: #23881

History

#1 Updated by William Grzybowski over 1 year ago

  • Status changed from Unscreened to Screened
  • Target version set to 11.1

#2 Updated by William Grzybowski over 1 year ago

  • Status changed from Screened to Resolved

Give it another try now.

#3 Updated by William Grzybowski over 1 year ago

  • Related to Bug #24231: Creating zvols via api only uses name and volsize from input added

#4 Updated by William Grzybowski over 1 year ago

  • Is duplicate of Bug #24432: Change size of zvol via API not passed through to LUN added

#5 Updated by Dru Lavigne about 1 year ago

  • Subject changed from RestAPI not setting compression setting to intended value, it's defaulting to inherit compression of dataset. to Unify API code to create/update zvol

#6 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.1 to 11.1-BETA1

#7 Updated by Joe Maloney 12 months ago

  • Needs QA changed from Yes to No
  • QA Status deleted (Not Tested)

Also available in: Atom PDF