Project

General

Profile

Bug #23927

Add ability to select the NIC used by a VM

Added by Ryan Hamel over 1 year ago. Updated 11 months ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
Marcelo Araujo
Category:
Middleware
Target version:
Seen in:
Sprint:
Severity:
New
Backlog Priority:
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

While I am using the old UI due to a number of bugs in the new UI redirecting me back to login page, the old UI does not give me an option to specify which FreeBSD network interface (LAG/VLAN/physical interface/TUN-You get the idea.). This would be a nice feature to have because I cannot setup pfSense 2.4 (UEFI) as I don't know what VM NIC interfaces are bound to what FreeBSD network interface.


Related issues

Is duplicate of FreeNAS - Bug #24753: VM Start Shuts down NetworkClosed: Duplicate2017-06-20

Associated revisions

Revision d1f84fed (diff)
Added by Marcelo Araujo over 1 year ago

feat(vm): Add the capability for guests to choose which nic it will be attached to. We create dynamically a bridge(4) with the chosen NIC and attach the guest's tap(4) interface to it.

Ticket: #23927
Ticket: #24222
Ticket: #24571
Ticket: #24753

commit 97736d23a83644b25586af921f43b3d6230bb957
Author: Marcelo Araujo <>
Date: Fri Jun 23 09:57:11 2017 +0800

fix(vm/middlewared): I'm keeping backward compatibility prior the option to choose attached nic, in this case the if_attached can be None and I need to handle this case.
Spotted by: william-gr

commit 49481a9abf43d56378caa67491084e93344022c7
Author: Marcelo Araujo <>
Date: Fri Jun 23 09:40:35 2017 +0800

fix(vm/middleared): Fix double identation.
Spotted by: william-gr

commit da31e3de0021efa11e6b3dd67e67842392fdb3e7
Merge: f6ab6bd84 e1c2de77a
Author: Marcelo Araujo <>
Date: Fri Jun 23 09:23:48 2017 +0800

Merge branch 'master' into wip_vmiface

commit f6ab6bd8499539d5a6baf3a56795c01698a5dc3d
Author: Marcelo Araujo <>
Date: Thu Jun 22 17:59:03 2017 +0800

feat(vm/middlewared): Add try/except guards in case there is no default gateway.

commit efb1f6137749e83098cf6ad925d4aae7a58d509b
Author: Marcelo Araujo <>
Date: Thu Jun 22 15:48:08 2017 +0800

feat(vm/middlwared): Add get_attached_iface method that will return all attached physical interfaces from a given guest.

commit 2bb59b82057a14e7dc36f857c218a62c2360f133
Author: Marcelo Araujo <>
Date: Thu Jun 22 15:33:31 2017 +0800

feat(vm/middlwared): Use netif module instead of make a syscall to find out the default gateway interface.

commit 6fefec6870c683f02be87037ecfe91862d8ee352
Author: Marcelo Araujo <>
Date: Thu Jun 22 15:08:27 2017 +0800

feat(vm/middlewared): backward compatibility for guests that are already installed and didn't had the iface attached option.

commit 15617d0d2f7f79c55e6996c9e759b6c488bf224a
Author: Marcelo Araujo <>
Date: Thu Jun 22 11:44:34 2017 +0800

feat(vm/middlewared): asyncio method bridge_setup.

commit 5f9f35b3f45b76f6c57c4b3bf929301486b78a41
Author: Marcelo Araujo <>
Date: Thu Jun 22 10:59:22 2017 +0800

feat(vm/middleared): Attach the selected NIC into the bridge.

commit 4c8a61adf6e4de8ea9786f5f3559ac7e8d16238c
Merge: d66be7aea 876bb1348
Author: Marcelo Araujo <>
Date: Thu Jun 22 10:36:12 2017 +0800

Merge branch 'master' into wip_vmiface

commit d66be7aeae8139bb9abfbdc8532e56f67f109ad0
Author: Marcelo Araujo <>
Date: Thu Jun 22 10:31:07 2017 +0800

feat(vm/middlewared): Setup the bridge with the prefered nic attached chosen by the user.

commit 76fd3fe4091beafa1169d261e2c91c650f24e10c
Author: Marcelo Araujo <>
Date: Wed Jun 21 17:12:48 2017 +0800

feat(vm): First wave of changes to allow users to choose what interface the guest vm will be attached.

Revision 49e1eb8e (diff)
Added by Marcelo Araujo over 1 year ago

feat(vm): Add the capability for guests to choose which nic it will be attached to. We create dynamically a bridge(4) with the chosen NIC and attach the guest's tap(4) interface to it.

Ticket: #23927
Ticket: #24222
Ticket: #24571
Ticket: #24753

commit 97736d23a83644b25586af921f43b3d6230bb957
Author: Marcelo Araujo <>
Date: Fri Jun 23 09:57:11 2017 +0800

fix(vm/middlewared): I'm keeping backward compatibility prior the option to choose attached nic, in this case the if_attached can be None and I need to handle this case.
Spotted by: william-gr

commit 49481a9abf43d56378caa67491084e93344022c7
Author: Marcelo Araujo <>
Date: Fri Jun 23 09:40:35 2017 +0800

fix(vm/middleared): Fix double identation.
Spotted by: william-gr

commit da31e3de0021efa11e6b3dd67e67842392fdb3e7
Merge: f6ab6bd84 e1c2de77a
Author: Marcelo Araujo <>
Date: Fri Jun 23 09:23:48 2017 +0800

Merge branch 'master' into wip_vmiface

commit f6ab6bd8499539d5a6baf3a56795c01698a5dc3d
Author: Marcelo Araujo <>
Date: Thu Jun 22 17:59:03 2017 +0800

feat(vm/middlewared): Add try/except guards in case there is no default gateway.

commit efb1f6137749e83098cf6ad925d4aae7a58d509b
Author: Marcelo Araujo <>
Date: Thu Jun 22 15:48:08 2017 +0800

feat(vm/middlwared): Add get_attached_iface method that will return all attached physical interfaces from a given guest.

commit 2bb59b82057a14e7dc36f857c218a62c2360f133
Author: Marcelo Araujo <>
Date: Thu Jun 22 15:33:31 2017 +0800

feat(vm/middlwared): Use netif module instead of make a syscall to find out the default gateway interface.

commit 6fefec6870c683f02be87037ecfe91862d8ee352
Author: Marcelo Araujo <>
Date: Thu Jun 22 15:08:27 2017 +0800

feat(vm/middlewared): backward compatibility for guests that are already installed and didn't had the iface attached option.

commit 15617d0d2f7f79c55e6996c9e759b6c488bf224a
Author: Marcelo Araujo <>
Date: Thu Jun 22 11:44:34 2017 +0800

feat(vm/middlewared): asyncio method bridge_setup.

commit 5f9f35b3f45b76f6c57c4b3bf929301486b78a41
Author: Marcelo Araujo <>
Date: Thu Jun 22 10:59:22 2017 +0800

feat(vm/middleared): Attach the selected NIC into the bridge.

commit 4c8a61adf6e4de8ea9786f5f3559ac7e8d16238c
Merge: d66be7aea 876bb1348
Author: Marcelo Araujo <>
Date: Thu Jun 22 10:36:12 2017 +0800

Merge branch 'master' into wip_vmiface

commit d66be7aeae8139bb9abfbdc8532e56f67f109ad0
Author: Marcelo Araujo <>
Date: Thu Jun 22 10:31:07 2017 +0800

feat(vm/middlewared): Setup the bridge with the prefered nic attached chosen by the user.

commit 76fd3fe4091beafa1169d261e2c91c650f24e10c
Author: Marcelo Araujo <>
Date: Wed Jun 21 17:12:48 2017 +0800

feat(vm): First wave of changes to allow users to choose what interface the guest vm will be attached.

Revision bcf82f4a (diff)
Added by Dru Lavigne about 1 year ago

Mention ability to specify VM NIC.
Ticket: #23927

History

#1 Updated by Marcelo Araujo over 1 year ago

  • Status changed from Unscreened to Screened
  • Priority changed from No priority to Nice to have
  • Target version set to 11.2-BETA1

#2 Updated by Marcelo Araujo over 1 year ago

  • Status changed from Screened to Resolved
  • Target version changed from 11.2-BETA1 to 11.1

The feature will be in Nightlies soon and it is targeted to FreeNAS 11.1-RELEASE.

#3 Updated by Dru Lavigne about 1 year ago

  • Subject changed from Bhyve NIC VM Association to Add ability to select the NIC used by a VM

#4 Updated by Dru Lavigne about 1 year ago

  • Is duplicate of Bug #24753: VM Start Shuts down Network added

#5 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.1 to 11.1-BETA1

#6 Updated by Joe Maloney 11 months ago

  • Needs QA changed from Yes to No
  • QA Status Test Passes FreeNAS added
  • QA Status deleted (Not Tested)

Also available in: Atom PDF